aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-14 23:58:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-14 23:58:18 +0000
commit2a283c136b8f9f621809f59086177e64df3d8163 (patch)
tree759165ea7c66c1bc280d8a9eef03ebeb89b4c881 /converters
parent964ea15958009bc85e915fd0487dff56629251e4 (diff)
downloadports-2a283c136b8f9f621809f59086177e64df3d8163.tar.gz
ports-2a283c136b8f9f621809f59086177e64df3d8163.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/py-pint/Makefile21
-rw-r--r--converters/py-pint/distinfo3
-rw-r--r--converters/py-pint/pkg-descr11
4 files changed, 36 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 18f2cbffc1d0..6eb250b3fc6b 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -158,6 +158,7 @@
SUBDIR += py-better-bencode
SUBDIR += py-bsdconv
SUBDIR += py-iconv
+ SUBDIR += py-pint
SUBDIR += py-rencode
SUBDIR += py-unidecode
SUBDIR += py-webencodings
diff --git a/converters/py-pint/Makefile b/converters/py-pint/Makefile
new file mode 100644
index 000000000000..f3bb3a35a4ac
--- /dev/null
+++ b/converters/py-pint/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pint
+PORTVERSION= 0.8.1
+CATEGORIES= converters python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pint-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Define, operate and manipulate physical quantities
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/converters/py-pint/distinfo b/converters/py-pint/distinfo
new file mode 100644
index 000000000000..b0461c700bb0
--- /dev/null
+++ b/converters/py-pint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523722809
+SHA256 (Pint-0.8.1.tar.gz) = afcf31443a478c32bbac4b00337ee9026a13d0e2ac83d30c79151462513bb0d4
+SIZE (Pint-0.8.1.tar.gz) = 162197
diff --git a/converters/py-pint/pkg-descr b/converters/py-pint/pkg-descr
new file mode 100644
index 000000000000..e39f67ceecf1
--- /dev/null
+++ b/converters/py-pint/pkg-descr
@@ -0,0 +1,11 @@
+Pint is a Python package to define, operate and manipulate physical quantities:
+the product of a numerical value and a unit of measurement. It allows arithmetic
+operations between them and conversions from and to different units.
+
+It is distributed with a comprehensive list of physical units, prefixes and
+constants. Due to its modular design, you can extend (or even rewrite!) the
+complete list without changing the source code. It supports a lot of numpy
+mathematical operations without monkey patching or wrapping numpy.
+
+WWW: https://pypi.python.org/pypi/Pint
+WWW: https://github.com/hgrecco/pint