aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-19 07:50:53 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-19 07:50:53 +0000
commitdae43d7a6d5bdca67edda0ed02db4a1593899b62 (patch)
treee02fe0a758ee3fd52b58a10326bb7c498ab3c957 /converters
parent57f1865da832cd9d777a31b47df5288436112d6a (diff)
downloadports-dae43d7a6d5bdca67edda0ed02db4a1593899b62.tar.gz
ports-dae43d7a6d5bdca67edda0ed02db4a1593899b62.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/gbsdconv/Makefile2
-rw-r--r--converters/py-bsdconv/Makefile4
-rw-r--r--converters/py-unidecode/Makefile5
-rw-r--r--converters/py-zfec/Makefile5
-rw-r--r--converters/zbase32/Makefile5
5 files changed, 9 insertions, 12 deletions
diff --git a/converters/gbsdconv/Makefile b/converters/gbsdconv/Makefile
index ce70905bef6a..40d9d75a9e9c 100644
--- a/converters/gbsdconv/Makefile
+++ b/converters/gbsdconv/Makefile
@@ -18,8 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= buganini
GH_COMMIT= 0a9ad34
+USES= python
USE_GNOME= gtk30 introspection:run
-USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/converters/py-bsdconv/Makefile b/converters/py-bsdconv/Makefile
index 7c58e8140443..554508e1ec1d 100644
--- a/converters/py-bsdconv/Makefile
+++ b/converters/py-bsdconv/Makefile
@@ -19,8 +19,8 @@ GH_ACCOUNT= buganini
GH_COMMIT= 075a20e
GH_PROJECT= python-${PORTNAME}
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
diff --git a/converters/py-unidecode/Makefile b/converters/py-unidecode/Makefile
index d273cd2be9d0..9c4890565861 100644
--- a/converters/py-unidecode/Makefile
+++ b/converters/py-unidecode/Makefile
@@ -13,8 +13,7 @@ COMMENT= ASCII transliterations of Unicode text
LICENSE= GPLv2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/converters/py-zfec/Makefile b/converters/py-zfec/Makefile
index 7670f64cd23b..881207fe88e9 100644
--- a/converters/py-zfec/Makefile
+++ b/converters/py-zfec/Makefile
@@ -18,9 +18,8 @@ BUILD_DEPENDS= darcsver:${PORTSDIR}/devel/py-darcsver \
unsort:${PORTSDIR}/devel/py-pyutil
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/converters/zbase32/Makefile b/converters/zbase32/Makefile
index 4cb8ceb71506..9da85a5017ec 100644
--- a/converters/zbase32/Makefile
+++ b/converters/zbase32/Makefile
@@ -14,8 +14,7 @@ COMMENT= Base32 Encoder/Decoder
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_darcs>=1.2.11:${PORTSDIR}/devel/py-setuptools_darcs
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distuils autoplist
.include <bsd.port.mk>