aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 13:16:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 13:16:21 +0000
commit7d368ef278d329671b7a720876a4bdf4ba74d88e (patch)
treee611e22461b384d3b53855f7df36aeff99989912 /converters
parent54593bf61f83e0a82348acbf4dfd386e8499530a (diff)
downloadports-7d368ef278d329671b7a720876a4bdf4ba74d88e.tar.gz
ports-7d368ef278d329671b7a720876a4bdf4ba74d88e.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/ish/Makefile6
-rw-r--r--converters/ish/files/patch-mvol.c27
2 files changed, 30 insertions, 3 deletions
diff --git a/converters/ish/Makefile b/converters/ish/Makefile
index 7ac3426ea687..968024e522fc 100644
--- a/converters/ish/Makefile
+++ b/converters/ish/Makefile
@@ -13,11 +13,11 @@ COMMENT= Binary-to-text file-encoder
MAKEFILE= makefile
MAKE_ARGS= CFLAGS="${CFLAGS}" DEST=${PREFIX}/bin
-PLIST_FILES= bin/ish
ALL_TARGET= ish
-NO_STAGE= yes
+PLIST_FILES= bin/ish
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ish ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.mk>
diff --git a/converters/ish/files/patch-mvol.c b/converters/ish/files/patch-mvol.c
new file mode 100644
index 000000000000..0be35c2eb23e
--- /dev/null
+++ b/converters/ish/files/patch-mvol.c
@@ -0,0 +1,27 @@
+--- mvol.c.orig
++++ mvol.c
+@@ -4,6 +4,7 @@
+ /* 930823 modified (aka) */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+ #include <string.h>
+@@ -25,6 +26,8 @@
+ extern char tname[];
+ extern int delvol;
+
++void restore_done(char *, char *, long);
++
+ #define ID "ID block for multi volume ish file"
+
+ typedef struct {
+@@ -208,6 +211,7 @@
+
+ #define COPY_BUF 1024
+
++void
+ restore_done(src, dst,sz)
+ char *src;
+ char *dst;