aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-26 11:14:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-26 11:14:09 +0000
commit2dd72cdfb1bf63935b02d047b626ff4ce60012ba (patch)
treec76e13cf8326cf1c575259a81b7386568d923b94 /converters
parentedecfedd29e45e6fab5198041610b3a9e230ed8b (diff)
downloadports-2dd72cdfb1bf63935b02d047b626ff4ce60012ba.tar.gz
ports-2dd72cdfb1bf63935b02d047b626ff4ce60012ba.zip
converters/ocaml-jsonm: update the port to version 1.0.1 and
- Chase HTTP/1.1 301 redirection when fetching the distfile - Update license (ISCL), assume maintainership of the port - Use provided build scripts instead of performing it manually - Convert to static pkg-plist, 16 lines don't warrant dynamic devel/ocaml-uutf: (required) update the port to version 1.0.2 and make changes similar to the above; devel/ocaml-topkg: call `do-build' recipe in ${BUILD_WRKSRC}.
Diffstat (limited to 'converters')
-rw-r--r--converters/ocaml-jsonm/Makefile32
-rw-r--r--converters/ocaml-jsonm/distinfo5
-rw-r--r--converters/ocaml-jsonm/pkg-plist16
3 files changed, 38 insertions, 15 deletions
diff --git a/converters/ocaml-jsonm/Makefile b/converters/ocaml-jsonm/Makefile
index 4ebc60463543..80bb4c11e6eb 100644
--- a/converters/ocaml-jsonm/Makefile
+++ b/converters/ocaml-jsonm/Makefile
@@ -1,35 +1,41 @@
# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
PORTNAME= jsonm
-PORTVERSION= 0.9.1
+PORTVERSION= 1.0.1
CATEGORIES= converters
-MASTER_SITES= http://erratique.ch/software/jsonm/releases/
+MASTER_SITES= https://erratique.ch/software/jsonm/releases/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Non-blocking streaming JSON codec for OCaml
-LICENSE= BSD3CLAUSE
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BUILD_DEPENDS= ${SA_DIR}/uutf/uutf.a:devel/ocaml-uutf
-BUILD_DEPENDS+= ocamlbuild:devel/ocaml-ocamlbuild
-RUN_DEPENDS= ${SA_DIR}/uutf/uutf.a:devel/ocaml-uutf
+BUILD_DEPENDS= ocamlbuild:devel/ocaml-ocamlbuild \
+ opam-installer:devel/ocaml-opam \
+ ${SA_DIR}/topkg/META:devel/ocaml-topkg \
+ ${SA_DIR}/uchar/META:devel/ocaml-uchar \
+ ${SA_DIR}/uutf/META:devel/ocaml-uutf
+RUN_DEPENDS= ${SA_DIR}/uchar/META:devel/ocaml-uchar \
+ ${SA_DIR}/uutf/META:devel/ocaml-uutf
USES= tar:tbz
USE_OCAML= yes
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
USE_OCAML_FINDLIB= yes
-USE_OCAMLFIND_PLIST= yes
USE_OCAML_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
- cd ${WRKSRC} && ocamlbuild src/jsonm.cmxs src/jsonm.cma src/jsonm.a
+ cd ${BUILD_WRKSRC} && ocaml pkg/pkg.ml build
do-install:
- ${MKDIR} ${STAGEDIR}${OCAMLFIND_DESTDIR}/jsonm
- cd ${WRKSRC} && ocamlfind install -destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib jsonm src/META _build/src/jsonm.a _build/src/jsonm.cma _build/src/jsonm.cmi _build/src/jsonm.cmx _build/src/jsonm.cmxa _build/src/jsonm.cmxs _build/src/jsonm.mli
- ${INSTALL_LIB} ${WRKSRC}/_build/src/jsonm.cmxs \
- ${STAGEDIR}${OCAMLFIND_DESTDIR}/jsonm
+ cd ${INSTALL_WRKSRC} && opam-installer -i \
+ --prefix=${STAGEDIR}${PREFIX} \
+ --docdir=${OCAML_DOCSDIR:S,^${PREFIX}/,,} \
+ --libdir=${OCAML_SITELIBDIR} ${PORTNAME}.install
.include <bsd.port.mk>
diff --git a/converters/ocaml-jsonm/distinfo b/converters/ocaml-jsonm/distinfo
index e76db4733fc3..198e1dab92bc 100644
--- a/converters/ocaml-jsonm/distinfo
+++ b/converters/ocaml-jsonm/distinfo
@@ -1,2 +1,3 @@
-SHA256 (jsonm-0.9.1.tbz) = 3fd4dca045d82332da847e65e981d8b504883571d299a3f7e71447d46bc65f73
-SIZE (jsonm-0.9.1.tbz) = 64843
+TIMESTAMP = 1632410748
+SHA256 (jsonm-1.0.1.tbz) = 3c09562ed43b617d8b6d9522a249ff770228e7d6de9f9508b72e84d52b6be684
+SIZE (jsonm-1.0.1.tbz) = 21608
diff --git a/converters/ocaml-jsonm/pkg-plist b/converters/ocaml-jsonm/pkg-plist
new file mode 100644
index 000000000000..97b64489f21b
--- /dev/null
+++ b/converters/ocaml-jsonm/pkg-plist
@@ -0,0 +1,16 @@
+bin/jsontrip
+%%OCAML_SITELIBDIR%%/jsonm/META
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.a
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cma
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cmi
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cmti
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cmx
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cmxa
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.cmxs
+%%OCAML_SITELIBDIR%%/jsonm/jsonm.mli
+%%OCAML_SITELIBDIR%%/jsonm/opam
+%%PORTDOCS%%share/doc/ocaml/jsonm/CHANGES.md
+%%PORTDOCS%%share/doc/ocaml/jsonm/LICENSE.md
+%%PORTDOCS%%share/doc/ocaml/jsonm/README.md
+%%PORTDOCS%%share/doc/ocaml/jsonm/examples.ml
+%%PORTDOCS%%share/doc/ocaml/jsonm/jtree.ml