aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-10-23 16:09:07 +0000
committerR. Imura <imura@FreeBSD.org>2000-10-23 16:09:07 +0000
commit9fbd04e5bf4c4fafb72c0e31d6f175f612c9a497 (patch)
treeaa925fdff2f73da8688898e9ddcdea576e07ab8d /converters
parent49bb5900774725b3e2336367d6edeb1a6b6b22a1 (diff)
downloadports-9fbd04e5bf4c4fafb72c0e31d6f175f612c9a497.tar.gz
ports-9fbd04e5bf4c4fafb72c0e31d6f175f612c9a497.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/kdesupport11/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/converters/kdesupport11/Makefile b/converters/kdesupport11/Makefile
index cc35f3b09fd4..8e402b4dccec 100644
--- a/converters/kdesupport11/Makefile
+++ b/converters/kdesupport11/Makefile
@@ -21,7 +21,15 @@ USE_QT= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --without-libjpeg --without-libgif \
- --without-libgdbm --without-libuulib
-CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" INSTALL_SCRIPT="install -c -m 555"
+ --without-libgdbm --without-libuulib \
+ --with-qt-includes=${QTDIR}/include/X11/qt
+CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" INSTALL_SCRIPT="install -c -m 555" \
+ QTDIR=${QTDIR}
+
+.if defined(PREFIX)
+QTDIR?= ${PREFIX}
+.else
+QTDIR?= ${X11BASE}
+.endif
.include <bsd.port.mk>