aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /converters
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/libiconv/Makefile9
-rw-r--r--converters/libiconv/files/patch-include-iconv.h.in59
-rw-r--r--converters/wkhtmltopdf/Makefile1
-rw-r--r--converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test11
-rw-r--r--converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp11
-rw-r--r--converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp39
6 files changed, 125 insertions, 5 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index db0824da1261..be7d261b5a24 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libiconv
PORTVERSION= 1.14
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= converters devel
MASTER_SITES= GNU
@@ -12,10 +12,9 @@ COMMENT= Character set conversion library
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
- --without-libintl-prefix \
- --docdir=${DOCSDIR}
-CONFIGURE_ENV= am_cv_func_iconv="yes" \
- am_cv_proto_iconv_arg1="const"
+ --disable-nls \
+ --docdir=${DOCSDIR} \
+ am_cv_func_iconv=no
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
USES= libtool
diff --git a/converters/libiconv/files/patch-include-iconv.h.in b/converters/libiconv/files/patch-include-iconv.h.in
new file mode 100644
index 000000000000..5f5b86cd2dd3
--- /dev/null
+++ b/converters/libiconv/files/patch-include-iconv.h.in
@@ -0,0 +1,59 @@
+--- include/iconv.h.in.orig 2011-08-07 17:48:03 UTC
++++ include/iconv.h.in
+@@ -94,7 +94,6 @@ extern int iconv_close (iconv_t cd);
+ #endif
+
+
+-#ifndef LIBICONV_PLUG
+
+ /* Nonstandard extensions. */
+
+@@ -127,12 +126,16 @@ typedef struct {
+ /* Allocates descriptor for code conversion from encoding ‘fromcode’ to
+ encoding ‘tocode’ into preallocated memory. Returns an error indicator
+ (0 or -1 with errno set). */
++#ifndef LIBICONV_PLUG
+ #define iconv_open_into libiconv_open_into
++#endif
+ extern int iconv_open_into (const char* tocode, const char* fromcode,
+ iconv_allocation_t* resultp);
+
+ /* Control of attributes. */
++#ifndef LIBICONV_PLUG
+ #define iconvctl libiconvctl
++#endif
+ extern int iconvctl (iconv_t cd, int request, void* argument);
+
+ /* Hook performed after every successful conversion of a Unicode character. */
+@@ -212,7 +215,9 @@ struct iconv_fallbacks {
+ #define ICONV_SET_FALLBACKS 6 /* const struct iconv_fallbacks *argument */
+
+ /* Listing of locale independent encodings. */
++#ifndef LIBICONV_PLUG
+ #define iconvlist libiconvlist
++#endif
+ extern void iconvlist (int (*do_one) (unsigned int namescount,
+ const char * const * names,
+ void* data),
+@@ -224,6 +229,7 @@ extern const char * iconv_canonicalize (
+
+ /* Support for relocatable packages. */
+
++#ifndef LIBICONV_PLUG
+ /* Sets the original and the current installation prefix of the package.
+ Relocation simply replaces a pathname starting with the original prefix
+ by the corresponding pathname with the current prefix instead. Both
+@@ -231,12 +237,12 @@ extern const char * iconv_canonicalize (
+ instead of "/"). */
+ extern void libiconv_set_relocation_prefix (const char *orig_prefix,
+ const char *curr_prefix);
++#endif
+
+ #ifdef __cplusplus
+ }
+ #endif
+
+-#endif
+
+
+ #endif /* _LIBICONV_H */
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 1ca2144333fe..a32636c47b8d 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wkhtmltopdf
PORTVERSION= 0.12.2.1
+PORTREVISION= 1
CATEGORIES= converters
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
diff --git a/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test b/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test
new file mode 100644
index 000000000000..2046425ad53c
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-config.tests_unix_compile.test
@@ -0,0 +1,11 @@
+--- config.tests/unix/compile.test.orig
++++ config.tests/unix/compile.test
+@@ -13,7 +13,7 @@
+ shift 7
+ LFLAGS="$SYSROOT_FLAG"
+ INCLUDEPATH=""
+-CXXFLAGS="$SYSROOT_FLAG"
++CXXFLAGS="$CXXFLAGS $SYSROOT_FLAG"
+ MAC_ARCH_CXXFLAGS=""
+ MAC_ARCH_LFLAGS=""
+ while [ "$#" -gt 0 ]; do
diff --git a/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp b/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp
new file mode 100644
index 000000000000..5f5c16ea37f5
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-config.tests_unix_gnu-libiconv_gnu-libiconv.cpp
@@ -0,0 +1,11 @@
+--- config.tests/unix/gnu-libiconv/gnu-libiconv.cpp.orig 2015-01-03 18:06:12 UTC
++++ config.tests/unix/gnu-libiconv/gnu-libiconv.cpp
+@@ -48,7 +48,7 @@ int main(int, char **)
+ {
+ iconv_t x = iconv_open("", "");
+
+- const char *inp;
++ char *inp;
+ char *outp;
+ size_t inbytes, outbytes;
+ iconv(x, &inp, &inbytes, &outp, &outbytes);
diff --git a/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp b/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp
new file mode 100644
index 000000000000..99bfac114be0
--- /dev/null
+++ b/converters/wkhtmltopdf/files/patch-src_corelib_codecs_qiconvcodec.cpp
@@ -0,0 +1,39 @@
+--- src/corelib/codecs/qiconvcodec.cpp.orig 2015-01-03 18:06:52 UTC
++++ src/corelib/codecs/qiconvcodec.cpp
+@@ -219,12 +219,7 @@ QString QIconvCodec::convertToUnicode(co
+ IconvState *state = *pstate;
+ size_t inBytesLeft = len;
+ // best case assumption, each byte is converted into one UTF-16 character, plus 2 bytes for the BOM
+-#ifdef GNU_LIBICONV
+- // GNU doesn't disagree with POSIX :/
+- const char *inBytes = chars;
+-#else
+ char *inBytes = const_cast<char *>(chars);
+-#endif
+
+ QByteArray in;
+ if (remainingCount) {
+@@ -318,11 +313,7 @@ static bool setByteOrder(iconv_t cd)
+ size_t outBytesLeft = sizeof buf;
+ size_t inBytesLeft = sizeof bom;
+
+-#if defined(GNU_LIBICONV)
+- const char **inBytesPtr = const_cast<const char **>(&inBytes);
+-#else
+ char **inBytesPtr = &inBytes;
+-#endif
+
+ if (iconv(cd, inBytesPtr, &inBytesLeft, &outBytes, &outBytesLeft) == (size_t) -1) {
+ return false;
+@@ -338,11 +329,7 @@ QByteArray QIconvCodec::convertFromUnico
+ char *outBytes;
+ size_t inBytesLeft;
+
+-#if defined(GNU_LIBICONV)
+- const char **inBytesPtr = const_cast<const char **>(&inBytes);
+-#else
+ char **inBytesPtr = &inBytes;
+-#endif
+
+ IconvState *temporaryState = 0;
+ QThreadStorage<QIconvCodec::IconvState *> *ts = fromUnicodeState();