aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-27 08:50:46 +0000
commit821843ca06f2354ffe250825fcdffabb6d0caefa (patch)
tree5b8de344e457d5da2cf746d56e495a2ce03e1d99 /converters
parent89d548370ac959aac24d63bd8ab8e32723ecf53d (diff)
downloadports-821843ca06f2354ffe250825fcdffabb6d0caefa.tar.gz
ports-821843ca06f2354ffe250825fcdffabb6d0caefa.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/cocot/Makefile2
-rw-r--r--converters/enca/Makefile3
-rw-r--r--converters/lua-iconv/Makefile3
-rw-r--r--converters/p5-Text-Iconv/Makefile2
-rw-r--r--converters/py-iconv/Makefile2
-rw-r--r--converters/recode/Makefile3
-rw-r--r--converters/ruby-iconv/Makefile2
7 files changed, 7 insertions, 10 deletions
diff --git a/converters/cocot/Makefile b/converters/cocot/Makefile
index 07c1f28296bc..f06b33c47368 100644
--- a/converters/cocot/Makefile
+++ b/converters/cocot/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= Code Converter on TTY
USE_ZIP= yes
-USE_ICONV= yes
+USES= iconv
WRKSRC= ${WRKDIR}/vmi-${PORTNAME}-8bc9f64
GNU_CONFIGURE= yes
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index 668c35494a0f..cc5f8ce8a165 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= umap:${PORTSDIR}/converters/p5-Unicode-Map8
LICENSE= GPLv2
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig
-USE_ICONV= yes
+USES= pkgconfig iconv
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/converters/lua-iconv/Makefile b/converters/lua-iconv/Makefile
index 2bc39255fbff..3988537d9b05 100644
--- a/converters/lua-iconv/Makefile
+++ b/converters/lua-iconv/Makefile
@@ -16,8 +16,7 @@ COMMENT= Iconv binding for Lua 5
WRKSRC= ${WRKDIR}/lua-${PORTNAME}-${PORTVERSION}
USE_LUA?= 5.1
-USE_GNOME= pkgconfig
-USE_ICONV= yes
+USES= pkgconfig iconv
PLIST_FILES= %%LUA_MODLIBDIR%%/iconv.so
diff --git a/converters/p5-Text-Iconv/Makefile b/converters/p5-Text-Iconv/Makefile
index 3645f8ee71a8..4b8b4762d8ac 100644
--- a/converters/p5-Text-Iconv/Makefile
+++ b/converters/p5-Text-Iconv/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to iconv() codeset conversion function
-USE_ICONV= yes
+USES= iconv
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include" \
diff --git a/converters/py-iconv/Makefile b/converters/py-iconv/Makefile
index 32fadf55bdab..5193fe4fdfa5 100644
--- a/converters/py-iconv/Makefile
+++ b/converters/py-iconv/Makefile
@@ -16,7 +16,7 @@ DIST_SUBDIR= python
MAINTAINER= ports@FreeBSD.org
COMMENT= An iconv wrapper with Unicode codec for Python
-USE_ICONV= yes
+USES= iconv
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index da28ae276d42..18d1bc523217 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -11,11 +11,10 @@ MASTER_SITE_SUBDIR= recode
MAINTAINER= demon@FreeBSD.org
COMMENT= Converts files between character sets and usages
-USES= gettext
+USES= gettext iconv
USE_AUTOTOOLS= libtool
USE_PERL5= yes
USE_LDCONFIG= yes
-USE_ICONV= yes
CONFIGURE_ARGS= --without-included-gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/converters/ruby-iconv/Makefile b/converters/ruby-iconv/Makefile
index 03fa98bfd168..2cff791fc673 100644
--- a/converters/ruby-iconv/Makefile
+++ b/converters/ruby-iconv/Makefile
@@ -20,7 +20,7 @@ COMMENT= An iconv wrapper class for Ruby
FETCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/${RUBY_PORT}:patch
-USE_ICONV= yes
+USES= iconv
USE_RUBY= yes
USE_RUBY_EXTCONF= yes