aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-09-04 15:58:00 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-09-04 15:58:00 +0000
commitb6da34d1dc5794034d8604cd744865fa5cdf2cbc (patch)
tree6e46e153ba1d4c77c320a194e86b0d0f0a59d981 /converters
parent1b1e8d04903ade99d04b970899f06710bf9b4053 (diff)
downloadports-b6da34d1dc5794034d8604cd744865fa5cdf2cbc.tar.gz
ports-b6da34d1dc5794034d8604cd744865fa5cdf2cbc.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/recode/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index b94a12b65cba..de630b5c2cde 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -4,20 +4,24 @@
PORTNAME= recode
PORTVERSION= 3.6
DISTVERSIONPREFIX= v
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= converters
MAINTAINER= demon@FreeBSD.org
COMMENT= Converts files between character sets and usages
+LICENSE= GPLv2+
+
+USES= gettext iconv libtool makeinfo perl5
+
USE_GITHUB= yes
GH_ACCOUNT= pinard
GH_PROJECT= Recode
-GNU_CONFIGURE= yes
-USES= gettext iconv libtool perl5
-USE_PERL5= run build
USE_LDCONFIG= yes
+USE_PERL5= run build
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
@@ -38,4 +42,8 @@ post-patch:
${WRKSRC}/src/libiconv.c
@${CP} ${WRKSRC}/lib/error.c ${WRKSRC}/src
+# to enable, remove this line and the leading @: from the STRIP_CMD line
+post-install:
+ @: ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librecode.so.*.*.*
+
.include <bsd.port.mk>