aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-07-08 10:08:50 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-07-08 10:08:50 +0000
commit8d63344834ae432b68cb4e3bad2e1665e9e3ebc7 (patch)
tree54ebc7d7a17b32fef9db329a5891e814617fe512 /converters
parent2f16f5811708bf05778b09774a4591c224b502f1 (diff)
downloadports-8d63344834ae432b68cb4e3bad2e1665e9e3ebc7.tar.gz
ports-8d63344834ae432b68cb4e3bad2e1665e9e3ebc7.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/mimepp/Makefile34
-rw-r--r--converters/mimepp/distinfo1
-rw-r--r--converters/mimepp/files/Makefile51
-rw-r--r--converters/mimepp/pkg-comment1
-rw-r--r--converters/mimepp/pkg-descr8
-rw-r--r--converters/mimepp/pkg-plist70
6 files changed, 165 insertions, 0 deletions
diff --git a/converters/mimepp/Makefile b/converters/mimepp/Makefile
new file mode 100644
index 000000000000..15ecdff966a5
--- /dev/null
+++ b/converters/mimepp/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mimepp
+# Version required: 0.8.0
+# Date created: 3 July 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= mimepp-0.8.0
+CATEGORIES= converters
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= devel/lang/c++
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/mimepp-970213
+ALL_TARGET= lib
+
+do-install:
+ @ ${INSTALL_DATA} ${WRKSRC}/libmimepp.a ${PREFIX}/lib/libmimepp.a
+ @ ${MKDIR} ${PREFIX}/include/mimepp
+ @ ${INSTALL_DATA} ${WRKSRC}/mimepp/* ${PREFIX}/include/mimepp
+ @ ${MKDIR} ${PREFIX}/share/doc/mimepp
+.for file in CPYRIGHT README Tutorial
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/mimepp/${file}
+.endfor
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/mimepp
+ @ ${MKDIR} ${PREFIX}/share/examples/mimepp
+.for file in exampl01.cc exampl02.cc exampl03.cc exampl04.cc exampl05.cc attach.cc basicmsg.cc multipar.cc attach.h basicmsg.h multipar.h test01.txt test02.txt test03.txt test04.txt test05.txt
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/examples/mimepp/${file}
+.endfor
+ @ ${INSTALL_DATA} files/Makefile ${PREFIX}/share/examples/mimepp
+
+.include <bsd.port.mk>
diff --git a/converters/mimepp/distinfo b/converters/mimepp/distinfo
new file mode 100644
index 000000000000..a921508dc664
--- /dev/null
+++ b/converters/mimepp/distinfo
@@ -0,0 +1 @@
+MD5 (mimepp-0.8.0.tar.gz) = 2268f857f9f27d31e466986d9ab1fba4
diff --git a/converters/mimepp/files/Makefile b/converters/mimepp/files/Makefile
new file mode 100644
index 000000000000..da85e23ee52c
--- /dev/null
+++ b/converters/mimepp/files/Makefile
@@ -0,0 +1,51 @@
+# makefile for MIME++ example programs
+
+# C++ compiler driver
+CXX = g++
+
+# C++ compiler flags (except -c, -I, -L, -l)
+# Add -g here if you want debugger symbols included
+CXXFLAGS = -DDW_EOL_LF
+
+# The search path for include files. Change only if necessary.
+INC_PATH = -I/usr/local/include
+
+# The search path for library files. Change only if necessary.
+LIB_PATH = -L/usr/local/lib
+
+# Libraries to be included. Change only if necessary.
+LIBS =
+
+# The library directory where MIME++ (libmimepp.a) will be installed.
+LIB_DIR = /usr/local/lib
+
+# The include directory where MIME++ include files should be installed.
+# The include files will actually be copied to $(INC_DIR)/mimepp/.
+INC_DIR = /usr/local/include
+
+LIB_OBJ = $(LIB_CC:.cc=.o)
+
+all: exampl01 exampl02 exampl03 exampl04 exampl05
+
+exampl01 : exampl01.o basicmsg.o libmimepp.a
+ $(CXX) -o exampl01 exampl01.o basicmsg.o $(LIB_PATH) -lmimepp
+
+exampl02 : exampl02.o basicmsg.o libmimepp.a
+ $(CXX) -o exampl02 exampl02.o basicmsg.o $(LIB_PATH) -lmimepp
+
+exampl03 : exampl03.o multipar.o basicmsg.o libmimepp.a
+ $(CXX) -o exampl03 exampl03.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp
+
+exampl04 : exampl04.o multipar.o basicmsg.o libmimepp.a
+ $(CXX) -o exampl04 exampl04.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp
+
+exampl05 : exampl05.o attach.o multipar.o basicmsg.o libmimepp.a
+ $(CXX) -o exampl05 exampl05.o attach.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp
+
+clean:
+ -rm *.o exampl0? *.out
+
+.SUFFIXES: .cc
+
+.cc.o:
+ $(CXX) -c $(CXXFLAGS) $< $(INC_PATH)
diff --git a/converters/mimepp/pkg-comment b/converters/mimepp/pkg-comment
new file mode 100644
index 000000000000..dc79e7effade
--- /dev/null
+++ b/converters/mimepp/pkg-comment
@@ -0,0 +1 @@
+C++ class library for MIME messages
diff --git a/converters/mimepp/pkg-descr b/converters/mimepp/pkg-descr
new file mode 100644
index 000000000000..c43e98b3736b
--- /dev/null
+++ b/converters/mimepp/pkg-descr
@@ -0,0 +1,8 @@
+MIME++ is a C++ class library for creating, parsing, and
+editing messages in MIME format. The class structure in
+MIME++ closely follows the BNF grammar specified in RFC-822
+and RFC-1521, making the library intuitive for developers
+who are familiar with the MIME standard. MIME++ supports
+quoted-printable and base64 encoding/decoding, and all
+header fields specified in RFC-822, RFC-1036, and RFC-1521.
+MIME++ is extensible through inheritance and polymorphism.
diff --git a/converters/mimepp/pkg-plist b/converters/mimepp/pkg-plist
new file mode 100644
index 000000000000..f97c7d1f724e
--- /dev/null
+++ b/converters/mimepp/pkg-plist
@@ -0,0 +1,70 @@
+include/mimepp/address.h
+include/mimepp/addrlist.h
+include/mimepp/body.h
+include/mimepp/bodypart.h
+include/mimepp/datetime.h
+include/mimepp/disptype.h
+include/mimepp/dw_debug.h
+include/mimepp/dw_mime.h
+include/mimepp/dwstring.h
+include/mimepp/entity.h
+include/mimepp/field.h
+include/mimepp/fieldbdy.h
+include/mimepp/group.h
+include/mimepp/header.h
+include/mimepp/mailbox.h
+include/mimepp/mboxlist.h
+include/mimepp/mechansm.h
+include/mimepp/mediatyp.h
+include/mimepp/message.h
+include/mimepp/mimepp.h
+include/mimepp/msgcmp.h
+include/mimepp/msgid.h
+include/mimepp/param.h
+include/mimepp/text.h
+include/mimepp/token.h
+lib/libmimepp.a
+share/doc/mimepp/CPYRIGHT
+share/doc/mimepp/README
+share/doc/mimepp/Tutorial
+share/doc/mimepp/address.html
+share/doc/mimepp/addrlist.html
+share/doc/mimepp/body.html
+share/doc/mimepp/bodypart.html
+share/doc/mimepp/datetime.html
+share/doc/mimepp/dwstring.html
+share/doc/mimepp/entity.html
+share/doc/mimepp/field.html
+share/doc/mimepp/fieldbdy.html
+share/doc/mimepp/group.html
+share/doc/mimepp/header.html
+share/doc/mimepp/mailbox.html
+share/doc/mimepp/mboxlist.html
+share/doc/mimepp/mechansm.html
+share/doc/mimepp/mediatyp.html
+share/doc/mimepp/message.html
+share/doc/mimepp/mimepp.html
+share/doc/mimepp/msgcmp.html
+share/doc/mimepp/msgid.html
+share/doc/mimepp/param.html
+share/doc/mimepp/text.html
+share/examples/mimepp/Makefile
+share/examples/mimepp/attach.cc
+share/examples/mimepp/basicmsg.cc
+share/examples/mimepp/exampl01.cc
+share/examples/mimepp/exampl02.cc
+share/examples/mimepp/exampl03.cc
+share/examples/mimepp/exampl04.cc
+share/examples/mimepp/exampl05.cc
+share/examples/mimepp/multipar.cc
+share/examples/mimepp/attach.h
+share/examples/mimepp/basicmsg.h
+share/examples/mimepp/multipar.h
+share/examples/mimepp/test01.txt
+share/examples/mimepp/test02.txt
+share/examples/mimepp/test03.txt
+share/examples/mimepp/test04.txt
+share/examples/mimepp/test05.txt
+@dirrm include/mimepp
+@dirrm share/doc/mimepp
+@dirrm share/examples/mimepp