aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-10 07:12:35 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-10 07:12:35 +0000
commit38499cc4f9de561964aa3bd7556c9f4c6684f038 (patch)
tree93d2de2f9a4bf6801932ddc030f955193b833745 /converters
parent886f50deb78afdd44d1fa3bbf50cbf6ab29baa3a (diff)
downloadports-38499cc4f9de561964aa3bd7556c9f4c6684f038.tar.gz
ports-38499cc4f9de561964aa3bd7556c9f4c6684f038.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/convmv/Makefile8
-rw-r--r--converters/iconv-extra/Makefile8
-rw-r--r--converters/osm2mp/Makefile3
-rw-r--r--converters/p5-Convert-UU/Makefile9
-rw-r--r--converters/p5-JSON1/Makefile8
-rw-r--r--converters/p5-MIME-Base32/Makefile5
-rw-r--r--converters/p5-Sereal-Decoder/Makefile3
-rw-r--r--converters/p5-String-SetUTF8/Makefile9
-rw-r--r--converters/p5-URI-UTF8-Punycode/Makefile3
-rw-r--r--converters/p5-bsdconv/Makefile3
10 files changed, 23 insertions, 36 deletions
diff --git a/converters/convmv/Makefile b/converters/convmv/Makefile
index 315117764554..c371a67da338 100644
--- a/converters/convmv/Makefile
+++ b/converters/convmv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: convmv
-# Date created: 27 October 2004
-# Whom: Kuang-che Wu <kcwu@csie.org>
-#
+# Created by: Kuang-che Wu <kcwu@csie.org>
# $FreeBSD$
-#
PORTNAME= convmv
PORTVERSION= 1.15
@@ -17,7 +13,7 @@ COMMENT= Convert filenames from one encoding to another
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/convmv
MAN1= convmv.1
diff --git a/converters/iconv-extra/Makefile b/converters/iconv-extra/Makefile
index 4cccab60862d..3d05d315a9c1 100644
--- a/converters/iconv-extra/Makefile
+++ b/converters/iconv-extra/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iconv
-# Date created: 10 September 2000
-# Whom: Konstantin Chuguev <Konstantin.Chuguev@dante.org.uk>
-#
+# Created by: Konstantin Chuguev <Konstantin.Chuguev@dante.org.uk>
# $FreeBSD$
-#
PORTNAME= iconv-extra
PORTVERSION= 2.0
@@ -16,6 +12,6 @@ COMMENT= Additional charsets for the iconv library (those from the Unicode site)
LIB_DEPENDS= biconv.2:${PORTSDIR}/converters/iconv
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.mk>
diff --git a/converters/osm2mp/Makefile b/converters/osm2mp/Makefile
index 4bc8cc4a8705..cd75fb9e6887 100644
--- a/converters/osm2mp/Makefile
+++ b/converters/osm2mp/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
LICENSE= GPLv2
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/converters/p5-Convert-UU/Makefile b/converters/p5-Convert-UU/Makefile
index 94fa707c4a80..46cdd95b0886 100644
--- a/converters/p5-Convert-UU/Makefile
+++ b/converters/p5-Convert-UU/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Convert-UU
-# Date created: October 20th 1996
-# Whom: James FitzGibbon <jfitz@FreeBSD.org>
-#
+# Created by: James FitzGibbon <jfitz@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Convert-UU
PORTVERSION= 0.52.01
@@ -15,7 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module for uuencode and uudecode
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN1= puuencode.1 puudecode.1
MAN3= Convert::UU.3
diff --git a/converters/p5-JSON1/Makefile b/converters/p5-JSON1/Makefile
index 3762ab2ff237..fa2be37a8d4f 100644
--- a/converters/p5-JSON1/Makefile
+++ b/converters/p5-JSON1/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: JSON
-# Date created: 19 Aug 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= JSON
PORTVERSION= 1.15
@@ -18,7 +13,8 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFLICTS= p5-JSON-2.*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
NO_LATEST_LINK= yes
MAN3= Apache::JSONRPC.3 JSON.3 JSON::Converter.3 \
JSON::PP.3 JSON::PP5005.3 JSON::PP56.3 JSON::Parser.3 \
diff --git a/converters/p5-MIME-Base32/Makefile b/converters/p5-MIME-Base32/Makefile
index 9c7379c01984..45c74fe21002 100644
--- a/converters/p5-MIME-Base32/Makefile
+++ b/converters/p5-MIME-Base32/Makefile
@@ -1,4 +1,4 @@
-# Created by: nork@freebsd.org
+# Created by: nork@FreeBSD.org
# $FreeBSD$
PORTNAME= MIME-Base32
@@ -14,7 +14,8 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/${PORTNAME}-1.02
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= MIME::Base32.3
diff --git a/converters/p5-Sereal-Decoder/Makefile b/converters/p5-Sereal-Decoder/Makefile
index 9a71a18c70cb..0d9bfd91132c 100644
--- a/converters/p5-Sereal-Decoder/Makefile
+++ b/converters/p5-Sereal-Decoder/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for fast, compact, powerful binary deserialization
TEST_DEPENDS= \
p5-Test-LongString>0:${PORTSDIR}/devel/p5-Test-LongString
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sereal::Decoder.3
diff --git a/converters/p5-String-SetUTF8/Makefile b/converters/p5-String-SetUTF8/Makefile
index a8dd6e60719f..29331889c9a4 100644
--- a/converters/p5-String-SetUTF8/Makefile
+++ b/converters/p5-String-SetUTF8/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: String::SetUTF8
-# Date created: 25 May 2009
-# Whom: Andrei V. Shetuhin <reki@reki.ru>
-#
+# Created by: Andrei V. Shetuhin <reki@reki.ru>
# $FreeBSD$
-#
PORTNAME= String-SetUTF8
PORTVERSION= 1.00
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= reki@reki.ru
COMMENT= Perl module to manipulate internal UTF-8 flag on strings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::SetUTF8.3
diff --git a/converters/p5-URI-UTF8-Punycode/Makefile b/converters/p5-URI-UTF8-Punycode/Makefile
index d8f6a5040f4c..fa529a2c4114 100644
--- a/converters/p5-URI-UTF8-Punycode/Makefile
+++ b/converters/p5-URI-UTF8-Punycode/Makefile
@@ -12,7 +12,8 @@ COMMENT= Punycode conversion of UTF-8 string
LICENSE= GPLv3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::UTF8::Punycode.3
diff --git a/converters/p5-bsdconv/Makefile b/converters/p5-bsdconv/Makefile
index cf74b298d221..77a8e26b5c94 100644
--- a/converters/p5-bsdconv/Makefile
+++ b/converters/p5-bsdconv/Makefile
@@ -19,7 +19,8 @@ GH_ACCOUNT= buganini
GH_COMMIT= 092d398
GH_PROJECT= perl-${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= bsdconv.3