aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-03-23 13:26:20 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-03-23 13:26:20 +0000
commit96557119e29c571f67824d5085265d6e7aba1615 (patch)
tree172388a0863abddeacf3b3a5ccdfcebc4b383bf3 /converters
parent46cbef16108008eec48a7142d4c7d7aac0bcbacd (diff)
downloadports-96557119e29c571f67824d5085265d6e7aba1615.tar.gz
ports-96557119e29c571f67824d5085265d6e7aba1615.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/libiconv/Makefile10
-rw-r--r--converters/libiconv/files/patch-lib-iconv.c11
2 files changed, 16 insertions, 5 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index b49ccb3bd2a3..4a1bb71e6e2b 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -3,24 +3,24 @@
PORTNAME= libiconv
PORTVERSION= 1.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= converters devel
MASTER_SITES= GNU
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A character set conversion library
+COMMENT= Character set conversion library
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
--without-libintl-prefix \
--docdir=${DOCSDIR}
-CONFIGURE_ENV= gl_cv_cc_visibility="no" \
- am_cv_func_iconv="yes" \
+CONFIGURE_ENV= am_cv_func_iconv="yes" \
am_cv_proto_iconv_arg1="const"
MAKE_JOBS_UNSAFE= yes
+USE_CSTD= gnu89
USE_LDCONFIG= yes
-OPTIONS_DEFINE= ENCODINGS PATCHES
+OPTIONS_DEFINE= DOCS ENCODINGS PATCHES
OPTIONS_DEFAULT=ENCODINGS
ENCODINGS_DESC= Include extra character sets
PATCHES_DESC= Apply patches to fix CP932, add EUCJP-MS
diff --git a/converters/libiconv/files/patch-lib-iconv.c b/converters/libiconv/files/patch-lib-iconv.c
new file mode 100644
index 000000000000..a5f0e8578d60
--- /dev/null
+++ b/converters/libiconv/files/patch-lib-iconv.c
@@ -0,0 +1,11 @@
+--- lib/iconv.c.orig
++++ lib/iconv.c
+@@ -598,7 +598,7 @@
+ It wants to define the symbols 'iconv_open', 'iconv', 'iconv_close'. */
+ #define strong_alias(name, aliasname) _strong_alias(name, aliasname)
+ #define _strong_alias(name, aliasname) \
+- extern __typeof (name) aliasname __attribute__ ((alias (#name)));
++ extern LIBICONV_DLL_EXPORTED __typeof (name) aliasname __attribute__ ((alias (#name)));
+ #undef iconv_open
+ #undef iconv
+ #undef iconv_close