aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-26 18:21:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-04-26 18:21:20 +0000
commitce62ca6298b31400fad418c4469315348c20555e (patch)
treeee3415a7c552598574ba3787c331a4f434afbdeb /converters
parentdf7adf2638a4527f4e98c4856a13cd0c5cd7f6e0 (diff)
downloadports-ce62ca6298b31400fad418c4469315348c20555e.tar.gz
ports-ce62ca6298b31400fad418c4469315348c20555e.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/php5-bsdconv/Makefile24
-rw-r--r--converters/php5-bsdconv/distinfo2
-rw-r--r--converters/py-bsdconv/Makefile20
-rw-r--r--converters/py-bsdconv/distinfo2
4 files changed, 29 insertions, 19 deletions
diff --git a/converters/php5-bsdconv/Makefile b/converters/php5-bsdconv/Makefile
index b20a11fc5b91..750c20a9fc16 100644
--- a/converters/php5-bsdconv/Makefile
+++ b/converters/php5-bsdconv/Makefile
@@ -5,25 +5,29 @@
# $FreeBSD$
#
-CATEGORIES+= converters
+PORTNAME= bsdconv
+PORTVERSION= 4.6
+CATEGORIES= converters
+MASTER_SITES= https://github.com/buganini/php-${PORTNAME}/tarball/${PORTVERSION}/
PKGNAMEPREFIX= php5-
+DISTNAME= buganini-${PORTNAME}-${PORTVERSION}-0-g${GITVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= PHP wrapper for bsdconv
LIB_DEPENDS= bsdconv.4:${PORTSDIR}/converters/bsdconv
-MASTERDIR= ${.CURDIR}/../bsdconv
-WRKSRC= ${WRKDIR}/${DISTNAME}/wrapper/php
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
-DESCR= ${.CURDIR}/pkg-descr
-PLIST= ${NONEXISTENT}
+LICENSE= BSD
+
+GITVERSION= 4297d53
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/buganini-php-${PORTNAME}-${GITVERSION}
USE_PHP= yes
+USE_PHPEXT= yes
USE_PHPIZE= yes
USE_PHP_BUILD= yes
-USE_PHPEXT= yes
-PHP_MODNAME= bsdconv
-CONFIGURE_ARGS+=--with-bsdconv=${LOCALBASE}
+PHP_MODNAME= ${PORTNAME}
+CONFIGURE_ARGS= --with-bsdconv=${LOCALBASE}
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/converters/php5-bsdconv/distinfo b/converters/php5-bsdconv/distinfo
new file mode 100644
index 000000000000..f2e8b4c25443
--- /dev/null
+++ b/converters/php5-bsdconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (buganini-bsdconv-4.6-0-g4297d53.tar.gz) = 7d40955e082c8b56088d7bb0707fab48bc6e2e6f42cdf75f72e2f53a84f65ebd
+SIZE (buganini-bsdconv-4.6-0-g4297d53.tar.gz) = 4394
diff --git a/converters/py-bsdconv/Makefile b/converters/py-bsdconv/Makefile
index f6a4d40216bc..c2b91c4caba4 100644
--- a/converters/py-bsdconv/Makefile
+++ b/converters/py-bsdconv/Makefile
@@ -5,26 +5,28 @@
# $FreeBSD$
#
-CATEGORIES+= python
+PORTNAME= bsdconv
+PORTVERSION= 4.6
+CATEGORIES= converters python
+MASTER_SITES= https://github.com/buganini/python-${PORTNAME}/tarball/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= buganini-${PORTNAME}-${PORTVERSION}-0-g${GITVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= Python wrapper for bsdconv
LIB_DEPENDS= bsdconv.4:${PORTSDIR}/converters/bsdconv
-MASTERDIR= ${.CURDIR}/../bsdconv
-WRKSRC= ${WRKDIR}/${DISTNAME}/wrapper/python
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
-DESCR= ${.CURDIR}/pkg-descr
-PLIST= ${.CURDIR}/pkg-plist
+LICENSE= BSD
+GITVERSION= 274d3f1
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/buganini-python-${PORTNAME}-${GITVERSION}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/setup.py
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/converters/py-bsdconv/distinfo b/converters/py-bsdconv/distinfo
new file mode 100644
index 000000000000..43dd0e8ff39c
--- /dev/null
+++ b/converters/py-bsdconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (buganini-bsdconv-4.6-0-g274d3f1.tar.gz) = 7e5c24bbddb2d3bb047003ac172a283da659d6832914a357c9f37315baa8a070
+SIZE (buganini-bsdconv-4.6-0-g274d3f1.tar.gz) = 2362