aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-07-05 06:25:12 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-07-05 06:25:12 +0000
commit4b9d53e4b42830c0884b06e258ec4e09143badc6 (patch)
tree43b641e3481ab0701c35389496dccacc6f5ff780 /converters
parent4717954523394e376601f58aa46f31378523b417 (diff)
downloadports-4b9d53e4b42830c0884b06e258ec4e09143badc6.tar.gz
ports-4b9d53e4b42830c0884b06e258ec4e09143badc6.zip
New port: converters/base91
basE91 is an advanced method for encoding binary data as ASCII characters. It is similar to UUencode or base64, but is more efficient. The overhead produced by basE91 depends on the input data. It amounts at most to 23% (versus 33% for base64) and can range down to 14%, which typically occurs on 0-byte blocks. This makes basE91 very useful for transferring larger files over binary unsafe connections like e-mail or terminal lines. WWW: http://base91.sourceforge.net/ PR: 238202 Submitted by: takefu@airport.fm Reviewed by: miwi, tcberner Differential Revision: https://reviews.freebsd.org/D20803
Notes
Notes: svn path=/head/; revision=505884
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/base91/Makefile24
-rw-r--r--converters/base91/distinfo3
-rw-r--r--converters/base91/files/patch-Makefile35
-rw-r--r--converters/base91/pkg-descr11
5 files changed, 74 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 92c840f846a3..7d41cb9deffa 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -11,6 +11,7 @@
SUBDIR += ascii2binary
SUBDIR += asr10
SUBDIR += base64
+ SUBDIR += base91
SUBDIR += bibtexconv
SUBDIR += bsdconv
SUBDIR += btoa
diff --git a/converters/base91/Makefile b/converters/base91/Makefile
new file mode 100644
index 000000000000..1c1c110e7d6a
--- /dev/null
+++ b/converters/base91/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= base91
+PORTVERSION= 0.6.0
+CATEGORIES= converters
+MASTER_SITES= SF/${PORTNAME}/basE91/${PORTVERSION}/
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Utility to encode and decode base91 files
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# INSTALL_DATA is only used to install documentation related files
+MAKE_ENV+= INSTALL_DATA="${INSTALL_MAN}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+
+PLIST_FILES= bin/b91dec \
+ bin/b91enc \
+ bin/base91 \
+ man/man1/b91dec.1.gz \
+ man/man1/b91enc.1.gz \
+ man/man1/base91.1.gz
+
+.include <bsd.port.mk>
diff --git a/converters/base91/distinfo b/converters/base91/distinfo
new file mode 100644
index 000000000000..d1cc0d3afff7
--- /dev/null
+++ b/converters/base91/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559031250
+SHA256 (base91-0.6.0.tar.gz) = 02cfae7322c1f865ca6ce8f2e0bb8d38c8513e76aed67bf1c94eab1343c6c651
+SIZE (base91-0.6.0.tar.gz) = 15009
diff --git a/converters/base91/files/patch-Makefile b/converters/base91/files/patch-Makefile
new file mode 100644
index 000000000000..989205168c5d
--- /dev/null
+++ b/converters/base91/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig 2006-09-03 18:00:00 UTC
++++ Makefile
+@@ -1,15 +1,15 @@
+-CFLAGS = -Wall -W -O2
+-LDFLAGS = -s
++CFLAGS ?= -Wall -W -O2
++LDFLAGS ?= -s
+
+-CC = gcc
+-INSTALL = install
+-INSTALL_DATA = $(INSTALL) -m 444
+-INSTALL_PROGRAM = $(INSTALL) -m 555
++CC ?= gcc
++INSTALL ?= install
++INSTALL_DATA ?= $(INSTALL) -m 444
++INSTALL_PROGRAM ?= $(INSTALL) -m 555
+
+-prefix = /usr/local
++prefix = ${PREFIX}
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+-mandir = $(prefix)/share/man
++mandir = $(prefix)/man
+ man1dir = $(mandir)/man1
+ manext = .1
+
+@@ -23,7 +23,7 @@ all: $(BIN)
+ $(CC) $(CFLAGS) -c $<
+
+ base91: cli.o base91.o
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ cli.o base91.o
+
+ install: all
+ mkdir -p $(DESTDIR)$(bindir)
diff --git a/converters/base91/pkg-descr b/converters/base91/pkg-descr
new file mode 100644
index 000000000000..096635d3a7bc
--- /dev/null
+++ b/converters/base91/pkg-descr
@@ -0,0 +1,11 @@
+basE91 is an advanced method for encoding binary data as ASCII characters.
+It is similar to UUencode or base64, but is more efficient.
+
+The overhead produced by basE91 depends on the input data. It amounts at most
+to 23% (versus 33% for base64) and can range down to 14%, which typically
+occurs on 0-byte blocks.
+
+This makes basE91 very useful for transferring larger files over binary unsafe
+connections like e-mail or terminal lines.
+
+WWW: http://base91.sourceforge.net/