aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-10-07 18:56:22 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-10-07 18:56:22 +0000
commit18bac1eaf91db026b9b2137ed7b48230122d79ed (patch)
tree93527dc1c8c6cdbe20d6c0015b2b5c9a9ea084f9 /converters
parent430a5eab53f2a87af2cbf81a05a8e24278870ebe (diff)
downloadports-18bac1eaf91db026b9b2137ed7b48230122d79ed.tar.gz
ports-18bac1eaf91db026b9b2137ed7b48230122d79ed.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/py-bencode.py/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/converters/py-bencode.py/Makefile b/converters/py-bencode.py/Makefile
index 065e7546fe42..c04554d307c0 100644
--- a/converters/py-bencode.py/Makefile
+++ b/converters/py-bencode.py/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bencode.py
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= converters devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,8 +16,13 @@ LICENSE_TEXT= See http://directory.fsf.org/wiki/License:BitTorrentOSL1.1
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest
+NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+
.include <bsd.port.mk>