aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-04 02:49:13 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-04 02:49:13 +0000
commit1d825fc49428b25aec69715c66e63a5a589a999b (patch)
tree993b4f46a22188196fe114497e762db6bae9357f /converters
parent0f0f8e198c1ebdcf469aeedcfd4ed82aa0ffa651 (diff)
downloadports-1d825fc49428b25aec69715c66e63a5a589a999b.tar.gz
ports-1d825fc49428b25aec69715c66e63a5a589a999b.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/igbinary/Makefile4
-rw-r--r--converters/igbinary/files/patch-apc_serializer.h11
2 files changed, 15 insertions, 0 deletions
diff --git a/converters/igbinary/Makefile b/converters/igbinary/Makefile
index 95fdc026a93e..79ae859b88c0 100644
--- a/converters/igbinary/Makefile
+++ b/converters/igbinary/Makefile
@@ -3,6 +3,7 @@
PORTNAME= igbinary
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= converters
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -19,4 +20,7 @@ USE_PHPEXT= yes
USE_PHPIZE= yes
USES= tar:tgz
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/${PHP_MODNAME}.so
+
.include <bsd.port.mk>
diff --git a/converters/igbinary/files/patch-apc_serializer.h b/converters/igbinary/files/patch-apc_serializer.h
new file mode 100644
index 000000000000..e7e7ebfae6a9
--- /dev/null
+++ b/converters/igbinary/files/patch-apc_serializer.h
@@ -0,0 +1,11 @@
+--- apc_serializer.h.orig 2011-03-14 20:32:48.000000000 +0800
++++ apc_serializer.h 2014-07-03 23:40:39.234972645 +0800
+@@ -54,7 +54,7 @@
+
+ ALLOC_INIT_ZVAL(apc_magic_constant);
+
+- if (zend_get_constant(APC_SERIALIZER_CONSTANT, sizeof(APC_SERIALIZER_CONSTANT)-1, apc_magic_constant)) {
++ if (zend_get_constant(APC_SERIALIZER_CONSTANT, sizeof(APC_SERIALIZER_CONSTANT)-1, apc_magic_constant TSRMLS_CC)) {
+ if(apc_magic_constant) {
+ apc_register_serializer_t register_func = (apc_register_serializer_t)(Z_LVAL_P(apc_magic_constant));
+ if(register_func) {