aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-24 22:15:59 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-24 22:15:59 +0000
commitcd5ac27b080695645adeb97642ae92ac8987ddc3 (patch)
tree02f05001735d741a4930238201a081a66e0609f8 /converters
parentfce35d76d86005c078b7e52929a04856f64425c7 (diff)
downloadports-cd5ac27b080695645adeb97642ae92ac8987ddc3.tar.gz
ports-cd5ac27b080695645adeb97642ae92ac8987ddc3.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/kdesupport2/Makefile36
-rw-r--r--converters/kdesupport2/files/patch-ae11
2 files changed, 6 insertions, 41 deletions
diff --git a/converters/kdesupport2/Makefile b/converters/kdesupport2/Makefile
index 2cbfda0eb7e6..1d4896ca12c8 100644
--- a/converters/kdesupport2/Makefile
+++ b/converters/kdesupport2/Makefile
@@ -17,46 +17,22 @@ LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_QT2= yes
-MOC= ${X11BASE}/bin/moc2
+MOC?= ${X11BASE}/bin/moc2
USE_BZIP2= yes
USE_NEWGCC= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-
-.include <bsd.port.pre.mk>
-
-# Hack to make pthread support work correctly. Even if we have a
-# libqt2-mt, it may not be wise to build with it if we don't have
-# a threads stub for X.
-.if exists(${X11BASE}/lib/libqt2-mt.so)
-.if exists(${X11BASE}/lib/libXThrStub.so)
-QTNAME= "qt2-mt"
-.if ${OSVERSION} >= 500016
-PTHREAD_CFLAGS= ""
-PTHREAD_LIBS= "-lc_r"
-.else
-PTHREAD_CFLAGS= "-D_THREAD_SAFE"
-PTHREAD_LIBS= "-pthread"
-.endif
-.else
-QTNAME= "qt2"
-PTHREAD_CFLAGS= ""
-PTHREAD_LIBS= ""
-.endif
-.endif
+USE_GMAKE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib \
--without-audiofile
-CONFIGURE_ENV+= LIBQT="-l${QTNAME}" MOC="${MOC}" LIBQTFILE="lib${QTNAME}" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H ${PTHREAD_CFLAGS}" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
-USE_GMAKE= yes
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
pre-configure:
- ${PERL} -pi -e "s@TOPSUBDIRS libaps@TOPSUBDIRS@g ; \
- s@odbc libaps@odbc@g" ${WRKSRC}/configure
${PERL} -pi -e "s@-version-info 1:1@-version-info 3:0@g" ${WRKSRC}/mimelib/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/converters/kdesupport2/files/patch-ae b/converters/kdesupport2/files/patch-ae
deleted file mode 100644
index 5694a2ed4dc1..000000000000
--- a/converters/kdesupport2/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- mimelib/Makefile.in Tue May 9 19:33:18 2000
-+++ mimelib/Makefile.in.new Tue May 16 18:32:11 2000
-@@ -233,7 +233,7 @@
-
- DEFS = -D$(LIBVERSION) @DEFS@
-
--libmimelib_la_LDFLAGS = -version-info 1:1
-+libmimelib_la_LDFLAGS = -version-info 3:0
- mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =