aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-29 02:44:58 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-29 02:44:58 +0000
commit7c6b0a6ca67c232e3193583296b01e93dca141d0 (patch)
tree9e447eb977d3bcd634436471bc866293fd9f1989 /converters
parentafd41a13ec53118181a879d55ecf0a8275dccb01 (diff)
downloadports-7c6b0a6ca67c232e3193583296b01e93dca141d0.tar.gz
ports-7c6b0a6ca67c232e3193583296b01e93dca141d0.zip
Notes
Diffstat (limited to 'converters')
-rw-r--r--converters/kdesupport2/Makefile29
-rw-r--r--converters/kdesupport2/distinfo2
-rw-r--r--converters/kdesupport2/pkg-plist8
3 files changed, 25 insertions, 14 deletions
diff --git a/converters/kdesupport2/Makefile b/converters/kdesupport2/Makefile
index 431b31a4ea0a..8bbb85cd7c5d 100644
--- a/converters/kdesupport2/Makefile
+++ b/converters/kdesupport2/Makefile
@@ -6,18 +6,21 @@
#
PORTNAME= kdesupport
-PORTVERSION= 1.90
+PORTVERSION= 20000724A
CATEGORIES= converters kde
-MASTER_SITES= $(MASTER_SITE_KDE)
-MASTER_SITE_SUBDIR= unstable/distribution/tar/src
+MASTER_SITES= $(MASTER_SITE_LOCAL)
+MASTER_SITE_SUBDIR= will
MAINTAINER= will@FreeBSD.org
-BROKEN= "Does not compile/run properly"
+LIB_DEPENDS= qt2.4:${PORTSDIR}/x11-toolkits/qt22
+WRKSRC= ${WRKDIR}/kdesupport
MOC= ${X11BASE}/bin/moc2
+SOMAJOR= 8
+SOMINOR= 0
USE_BZIP2= yes
-USE_QT2= yes
+USE_NEWGCC= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
@@ -25,8 +28,20 @@ CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
--with-qt-libraries=${X11BASE}/lib \
--without-libjpeg --without-libgif \
--without-libgdbm --without-libuulib \
- --without-odbc --without-audiofile
-CONFIGURE_ENV+= MOC="${MOC}"
+ --without-odbc --without-audiofile \
+ --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -lqt2 -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
+PLIST_SUB+= LIBVER="${SOMAJOR}"
+
+pre-configure:
+ ${PERL} -pi -e "s@version-info 2:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/QwSpriteField/Makefile.in
+ ${PERL} -pi -e "s@TOPSUBDIRS libaps@TOPSUBDIRS@g" ${WRKSRC}/configure
+ ${PERL} -pi -e "s@odbc libaps@odbc@g" ${WRKSRC}/configure
+
+pre-install:
+ @(find ${WRKSRC} -name CVS | xargs rm -rf)
.include <bsd.port.mk>
diff --git a/converters/kdesupport2/distinfo b/converters/kdesupport2/distinfo
index 9bba7474ad3d..687cd0a0de93 100644
--- a/converters/kdesupport2/distinfo
+++ b/converters/kdesupport2/distinfo
@@ -1 +1 @@
-MD5 (kdesupport-1.90.tar.bz2) = 884a602ec84fb40a840e1dc8403d5db4
+MD5 (kdesupport-20000724A.tar.bz2) = b92d434814d10c1698dbe9d366172a43
diff --git a/converters/kdesupport2/pkg-plist b/converters/kdesupport2/pkg-plist
index ced6e23cbf13..c37abc88b2e0 100644
--- a/converters/kdesupport2/pkg-plist
+++ b/converters/kdesupport2/pkg-plist
@@ -39,9 +39,5 @@ include/mimelib/uuencode.h
lib/libQwSpriteField.la
lib/libQwSpriteField.so.8
lib/libmimelib.la
-lib/libmimelib.so.3
-@exec ln -sf libQwSpriteField.so.7 %D/lib/libQwSpriteField.so
-@exec ln -sf libmimelib.so.3 %D/lib/libmimelib.so
-@dirrm include/mimelib
-@unexec rm -f %D/lib/libQwSpriteField.so
-@unexec rm -f %D/lib/libmimelib.so
+lib/libmimelib.so.1
+include/mimelib