aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-18 19:22:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-18 19:22:02 +0000
commit617155369d56e876edcd482bede1e9e016172607 (patch)
tree97bb6b77de6652c5fa07599944b3e7da3af85b84 /databases/Makefile
parent77b98e079110110faed273725ef34bbd258fbbc2 (diff)
Pure Python
All code, at first, is written in pure Python so that py-postgresql will work anywhere that you can install Python 3. Optimizations in C are made where needed, but are always optional. Prepared Statements Using the PG-API interface, protocol-level prepared statements may be created and used multiple times. db.prepare(sql)(*args) COPY Support Use the convenient COPY interface to directly copy data from one connection to another. No intermediate files or tricks are necessary. Arrays and Composite Typescw Arrays and composites are fully supported. Queries requesting them will returns objects that provide access to the elements within. "pg_python" Quick Console Get a Python console with a connection to PostgreSQL for quick tests and simple scripts. WWW: http://python.projects.postgresql.org/ PR: ports/137782 Submitted by: Volodymyr Kostyrko <c.kworr@gmail.com>
Notes
Notes: svn path=/head/; revision=246167
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 77dcc7ae1d8c..431900ab5469 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -569,6 +569,7 @@
SUBDIR += py-oops
SUBDIR += py-pg8000
SUBDIR += py-pg_pqueue
+ SUBDIR += py-postgresql
SUBDIR += py-psycopg
SUBDIR += py-psycopg2
SUBDIR += py-pyPgSQL