aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-03-18 01:22:11 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-03-18 01:22:11 +0000
commitabb6952193cea42ead402f869bd512b730acb466 (patch)
treed3b7d515eb15c01bb56680fa45ab2abadf444c0e /databases/Makefile
parent5ae8b2a249c35ec4fb82ab51ab3a344d0a41d80c (diff)
This module provides methods for working with adjacency lists. The
adjacency list model is a very common way of representing a tree structure. In this model each row in a table has a prent ID column that references the primary key of another row in the same table. Because of this the primary key must only be one column and is usually some sort of integer. The row with a parent ID of 0 is the root node and is usually the parent of all other rows. Although, there is no limitation in this module that would stop you from having multiple root nodes. WWW: http://search.cpan.org/dist/DBIx-Class-Tree/
Notes
Notes: svn path=/head/; revision=271191
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ad527813ae02..bb16f5731617 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -364,6 +364,7 @@
SUBDIR += p5-DBIx-Class-ResultSet-RecursiveUpdate
SUBDIR += p5-DBIx-Class-Schema-Loader
SUBDIR += p5-DBIx-Class-TimeStamp
+ SUBDIR += p5-DBIx-Class-Tree
SUBDIR += p5-DBIx-Class-UUIDColumns
SUBDIR += p5-DBIx-Class-Validation
SUBDIR += p5-DBIx-Class-WebForm