aboutsummaryrefslogtreecommitdiff
path: root/databases/akonadi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-27 00:46:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-27 00:46:33 +0000
commit253e47f5dc9b977d360f0fe9a09eb4b042a31485 (patch)
tree80bcedc05a67ad0f19d7c835a0dd49ac27786889 /databases/akonadi
parent0891a793aa22eebb05bb2bc781d77825a4bdb4b0 (diff)
downloadports-253e47f5dc9b977d360f0fe9a09eb4b042a31485.tar.gz
ports-253e47f5dc9b977d360f0fe9a09eb4b042a31485.zip
Notes
Diffstat (limited to 'databases/akonadi')
-rw-r--r--databases/akonadi/Makefile4
-rw-r--r--databases/akonadi/files/patch-105320169
2 files changed, 73 insertions, 0 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index dc5df41b1c55..80d4fa35540a 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -19,6 +19,10 @@ BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
RUN_DEPENDS= ${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
+# Let process generate meaningful backtrace on core dump
+LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
+CMAKE_ARGS+= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
+
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib network qtestlib dbus sql \
diff --git a/databases/akonadi/files/patch-1053201 b/databases/akonadi/files/patch-1053201
new file mode 100644
index 000000000000..e6b67aded329
--- /dev/null
+++ b/databases/akonadi/files/patch-1053201
@@ -0,0 +1,69 @@
+Index: server/control/CMakeLists.txt
+===================================================================
+--- server/control/CMakeLists.txt (revision 1053200)
++++ server/control/CMakeLists.txt (working copy)
+@@ -43,7 +43,7 @@
+ target_link_libraries(akonadi_control ${QT_QTMAIN_LIBRARY})
+ endif (WIN32)
+
+-target_link_libraries(akonadi_control ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${AKONADI_PROTOCOLINTERNALS_LIBS} ${Boost_PROGRAM_OPTIONS_LIBRARY})
++target_link_libraries(akonadi_control ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${AKONADI_PROTOCOLINTERNALS_LIBS} ${AKONADI_SYSTEM_LIBS} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+
+ install(TARGETS akonadi_control DESTINATION ${BIN_INSTALL_DIR})
+
+Index: server/akonadictl/CMakeLists.txt
+===================================================================
+--- server/akonadictl/CMakeLists.txt (revision 1053200)
++++ server/akonadictl/CMakeLists.txt (working copy)
+@@ -16,6 +16,6 @@
+ automoc4_add_executable(akonadictl ${akonadictl_SRCS})
+ set_target_properties(akonadictl PROPERTIES OUTPUT_NAME akonadictl)
+
+-target_link_libraries(akonadictl ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${AKONADI_PROTOCOLINTERNALS_LIBS} ${Boost_PROGRAM_OPTIONS_LIBRARY})
++target_link_libraries(akonadictl ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${AKONADI_PROTOCOLINTERNALS_LIBS} ${AKONADI_SYSTEM_LIBS} ${Boost_PROGRAM_OPTIONS_LIBRARY})
+
+ install(TARGETS akonadictl DESTINATION ${BIN_INSTALL_DIR})
+Index: server/CMakeLists.txt
+===================================================================
+--- server/CMakeLists.txt (revision 1053200)
++++ server/CMakeLists.txt (working copy)
+@@ -169,6 +169,7 @@
+ ${QT_QTDBUS_LIBRARY}
+ ${QT_QTXML_LIBRARY}
+ ${AKONADI_PROTOCOLINTERNALS_LIBS}
++ ${AKONADI_SYSTEM_LIBS}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${SOPRANO_LIBRARIES}
+ )
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 1053200)
++++ CMakeLists.txt (working copy)
+@@ -24,6 +24,7 @@
+
+ include(MacroLogFeature)
+ include(InstallSettings)
++include(CheckFunctionExists)
+ include(CheckIncludeFiles)
+ include(MacroWriteBasicCMakeVersionFile)
+
+@@ -132,7 +133,19 @@
+
+ ############### Configure checks ###############
+
++set (AKONADI_SYSTEM_LIBS)
++
+ check_include_files(execinfo.h HAVE_EXECINFO_H)
++if (HAVE_EXECINFO_H)
++ check_function_exists(backtrace BACKTRACE_IN_LIBC)
++ if (NOT BACKTRACE_IN_LIBC)
++ find_library (EXECINFO_LIBRARY NAMES execinfo)
++ if (EXECINFO_LIBRARY)
++ set (AKONADI_SYSTEM_LIBS ${AKONADI_SYSTEM_LIBS} ${EXECINFO_LIBRARY})
++ endif (EXECINFO_LIBRARY)
++ endif (NOT BACKTRACE_IN_LIBC)
++endif (HAVE_EXECINFO_H)
++
+ check_include_files(unistd.h HAVE_UNISTD_H)
+
+ # set the output paths