aboutsummaryrefslogtreecommitdiff
path: root/databases/arcexplorer
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2002-07-10 01:58:27 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2002-07-10 01:58:27 +0000
commit3662771140b536337d4dc08c0e044fdbbf70c89c (patch)
tree2eb9d5009ee6fd2391fcec485c88615a665621f4 /databases/arcexplorer
parentb181342166ac458602ca5095a5f2fbc84e2d9384 (diff)
downloadports-3662771140b536337d4dc08c0e044fdbbf70c89c.tar.gz
ports-3662771140b536337d4dc08c0e044fdbbf70c89c.zip
Notes
Diffstat (limited to 'databases/arcexplorer')
-rw-r--r--databases/arcexplorer/Makefile43
-rw-r--r--databases/arcexplorer/distinfo1
-rw-r--r--databases/arcexplorer/pkg-comment1
-rw-r--r--databases/arcexplorer/pkg-descr10
-rw-r--r--databases/arcexplorer/pkg-message11
-rw-r--r--databases/arcexplorer/pkg-plist234
6 files changed, 300 insertions, 0 deletions
diff --git a/databases/arcexplorer/Makefile b/databases/arcexplorer/Makefile
new file mode 100644
index 000000000000..274172d01686
--- /dev/null
+++ b/databases/arcexplorer/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: arcexplorer
+# Date created: 09 July 2002
+# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arcexplorer
+PORTVERSION= 4.0
+CATEGORIES= databases java
+MASTER_SITES= #
+DISTNAME= Linux_ArcExplorer${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= jedgar@FreeBSD.org
+
+USE_JAVA= 1.2+
+
+DOWNLOAD_URL= http://www.esri.com/software/arcexplorer/download4.html
+NO_BUILD= yes
+NO_BUILD_DEPENDS_JAVA= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/ArcExplorer${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE=You must manually fetch the ArcExplorer 4.0 tarball (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
+.endif
+
+do-install:
+ ${TAR} -xvf ${WRKSRC}/02.tar -C ${PREFIX}/lib
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/lib/aej40exe
+ @${REINPLACE_CMD} -e 's|/bin/ksh|/bin/sh|' \
+ ${PREFIX}/lib/aej40exe/bin/aejava
+ @${RM} ${PREFIX}/lib/aej40exe/bin/aejava.bak
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|'
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/databases/arcexplorer/distinfo b/databases/arcexplorer/distinfo
new file mode 100644
index 000000000000..1bc504b543b7
--- /dev/null
+++ b/databases/arcexplorer/distinfo
@@ -0,0 +1 @@
+MD5 (Linux_ArcExplorer4.0.tar.Z) = d74c9a9ecf0ad1397b402a1c7c92950f
diff --git a/databases/arcexplorer/pkg-comment b/databases/arcexplorer/pkg-comment
new file mode 100644
index 000000000000..2bedaa3c317c
--- /dev/null
+++ b/databases/arcexplorer/pkg-comment
@@ -0,0 +1 @@
+Lightweight java-based GIS data viewer
diff --git a/databases/arcexplorer/pkg-descr b/databases/arcexplorer/pkg-descr
new file mode 100644
index 000000000000..7a18f9095107
--- /dev/null
+++ b/databases/arcexplorer/pkg-descr
@@ -0,0 +1,10 @@
+Lightweight java-based GIS data viewer providing an easy way to perform
+basic GIS functions. ArcExplorer may be used for a variety of display,
+query, and data retrieval applications and supports a wide variety of
+standard data sources. It can be used on its own with local data sets
+or as a client to Internet data and map servers.
+
+
+WWW: http://www.esri.com/software/arcexplorer/index.html
+- Chris D. Faulhaber
+ <jedgar@FreeBSD.org>
diff --git a/databases/arcexplorer/pkg-message b/databases/arcexplorer/pkg-message
new file mode 100644
index 000000000000..feb8f5185ceb
--- /dev/null
+++ b/databases/arcexplorer/pkg-message
@@ -0,0 +1,11 @@
+To use ArcExplorer4.0, add the following to your environment:
+
+ AEJHOME=%%PREFIX%%/lib/aej40exe
+ PATH=$PATH:$AEJHOME/bin
+
+and execute:
+
+ $ aejava
+
+Please read %%PREFIX%%/lib/aej40exe/License.txt for licensing
+information.
diff --git a/databases/arcexplorer/pkg-plist b/databases/arcexplorer/pkg-plist
new file mode 100644
index 000000000000..e71e708fad61
--- /dev/null
+++ b/databases/arcexplorer/pkg-plist
@@ -0,0 +1,234 @@
+lib/aej40exe/Help/81helprev.css
+lib/aej40exe/Help/81helprev_ns.css
+lib/aej40exe/Help/adding_an_overview_map.html
+lib/aej40exe/Help/adding_arcsde_layers.html
+lib/aej40exe/Help/adding_data_layers.html
+lib/aej40exe/Help/adding_images.html
+lib/aej40exe/Help/adding_labels_to_a_map.html
+lib/aej40exe/Help/adding_shapefiles.html
+lib/aej40exe/Help/adding_shields_to_line_features.html
+lib/aej40exe/Help/address_matching.html
+lib/aej40exe/Help/ae_javaed_cover.gif
+lib/aej40exe/Help/aejava_help.htm
+lib/aej40exe/Help/aejava_help.log
+lib/aej40exe/Help/aejava_help_csh.htm
+lib/aej40exe/Help/aejava_help_rhc.htm
+lib/aej40exe/Help/bsscdhtm.js
+lib/aej40exe/Help/buffering_features.html
+lib/aej40exe/Help/building_a_query_expression.html
+lib/aej40exe/Help/copying_a_map_to_a_file.html
+lib/aej40exe/Help/cshdat_robohelp.htm
+lib/aej40exe/Help/cshdat_webhelp.htm
+lib/aej40exe/Help/displaying_maptips.html
+lib/aej40exe/Help/drawing_features_with_one_symbol.html
+lib/aej40exe/Help/ehelp.xml
+lib/aej40exe/Help/ehlpdhtm.js
+lib/aej40exe/Help/finding_features.html
+lib/aej40exe/Help/getting_and_using_the_attributes_of_features.html
+lib/aej40exe/Help/getting_general_information_about_a_layer.html
+lib/aej40exe/Help/how_to_get_help.html
+lib/aej40exe/Help/identifying_features.html
+lib/aej40exe/Help/introduction_to_arcexplorer_java.html
+lib/aej40exe/Help/locating_an_address.html
+lib/aej40exe/Help/main_page.htm
+lib/aej40exe/Help/making_a_graduated_symbols_map.html
+lib/aej40exe/Help/making_a_unique_symbols_map.html
+lib/aej40exe/Help/measuring_distances.html
+lib/aej40exe/Help/printing_a_map.html
+lib/aej40exe/Help/printing_copying_and_saving.html
+lib/aej40exe/Help/properties_of_the_legend_overview_map_and_scale_bar.html
+lib/aej40exe/Help/saving_a_project.html
+lib/aej40exe/Help/searching_for_features.html
+lib/aej40exe/Help/selecting_features.html
+lib/aej40exe/Help/setting_a_layers_scale_factors.html
+lib/aej40exe/Help/symbolizing_layers.html
+lib/aej40exe/Help/using_the_legend.html
+lib/aej40exe/Help/viewing_data_in_a_service.html
+lib/aej40exe/Help/viewing_data_on_gn.htm
+lib/aej40exe/Help/webhelp.cab
+lib/aej40exe/Help/webhelp.jar
+lib/aej40exe/Help/what_you_can_do_with_arcexplorer_java.html
+lib/aej40exe/Help/whd_dpns.htm
+lib/aej40exe/Help/whd_hide0.gif
+lib/aej40exe/Help/whd_hide1.gif
+lib/aej40exe/Help/whd_hide2.gif
+lib/aej40exe/Help/whd_next0.gif
+lib/aej40exe/Help/whd_next1.gif
+lib/aej40exe/Help/whd_next2.gif
+lib/aej40exe/Help/whd_nvp10.htm
+lib/aej40exe/Help/whd_nvp20.htm
+lib/aej40exe/Help/whd_prev0.gif
+lib/aej40exe/Help/whd_prev1.gif
+lib/aej40exe/Help/whd_prev2.gif
+lib/aej40exe/Help/whd_show0.gif
+lib/aej40exe/Help/whd_show1.gif
+lib/aej40exe/Help/whd_show2.gif
+lib/aej40exe/Help/whd_sync0.gif
+lib/aej40exe/Help/whd_sync1.gif
+lib/aej40exe/Help/whd_sync2.gif
+lib/aej40exe/Help/whd_tab0.gif
+lib/aej40exe/Help/whd_tab1.gif
+lib/aej40exe/Help/whd_tab2.gif
+lib/aej40exe/Help/whd_tab3.gif
+lib/aej40exe/Help/whd_tab4.gif
+lib/aej40exe/Help/whd_tab5.gif
+lib/aej40exe/Help/whd_tab6.gif
+lib/aej40exe/Help/whd_tab7.gif
+lib/aej40exe/Help/whd_tab8.gif
+lib/aej40exe/Help/whd_tabs.htm
+lib/aej40exe/Help/whd_toc1.gif
+lib/aej40exe/Help/whd_toc2.gif
+lib/aej40exe/Help/whd_toc3.gif
+lib/aej40exe/Help/whd_toc4.gif
+lib/aej40exe/Help/whd_topic.xml
+lib/aej40exe/Help/whd_wbsh0.gif
+lib/aej40exe/Help/whd_wbsh1.gif
+lib/aej40exe/Help/whd_wbsh2.gif
+lib/aej40exe/Help/whdata/whftdata.js
+lib/aej40exe/Help/whdata/whftdata0.htm
+lib/aej40exe/Help/whdata/whftdata0.xml
+lib/aej40exe/Help/whdata/whfts.htm
+lib/aej40exe/Help/whdata/whfts.js
+lib/aej40exe/Help/whdata/whfts.xml
+lib/aej40exe/Help/whdata/whfwdata.js
+lib/aej40exe/Help/whdata/whfwdata0.htm
+lib/aej40exe/Help/whdata/whfwdata0.xml
+lib/aej40exe/Help/whdata/whgdata.js
+lib/aej40exe/Help/whdata/whglo.htm
+lib/aej40exe/Help/whdata/whglo.js
+lib/aej40exe/Help/whdata/whglo.xml
+lib/aej40exe/Help/whdata/whidata.js
+lib/aej40exe/Help/whdata/whidata0.htm
+lib/aej40exe/Help/whdata/whidata0.xml
+lib/aej40exe/Help/whdata/whidx.htm
+lib/aej40exe/Help/whdata/whidx.js
+lib/aej40exe/Help/whdata/whidx.xml
+lib/aej40exe/Help/whdata/whtdata.js
+lib/aej40exe/Help/whdata/whtdata0.htm
+lib/aej40exe/Help/whdata/whtdata0.xml
+lib/aej40exe/Help/whdata/whtoc.htm
+lib/aej40exe/Help/whdata/whtoc.js
+lib/aej40exe/Help/whdata/whtoc.xml
+lib/aej40exe/Help/whfbody.htm
+lib/aej40exe/Help/whfdhtml.htm
+lib/aej40exe/Help/whfform.htm
+lib/aej40exe/Help/whfhost.js
+lib/aej40exe/Help/whform.js
+lib/aej40exe/Help/whframes.js
+lib/aej40exe/Help/whgbody.htm
+lib/aej40exe/Help/whgdata/whexpbar.gif
+lib/aej40exe/Help/whgdata/whlstf0.htm
+lib/aej40exe/Help/whgdata/whlstf1.htm
+lib/aej40exe/Help/whgdata/whlstf2.htm
+lib/aej40exe/Help/whgdata/whlstf3.htm
+lib/aej40exe/Help/whgdata/whlstf4.htm
+lib/aej40exe/Help/whgdata/whlstf5.htm
+lib/aej40exe/Help/whgdata/whlstf6.htm
+lib/aej40exe/Help/whgdata/whlstf7.htm
+lib/aej40exe/Help/whgdata/whlstf8.htm
+lib/aej40exe/Help/whgdata/whlstfl0.htm
+lib/aej40exe/Help/whgdata/whlstfl1.htm
+lib/aej40exe/Help/whgdata/whlstfl10.htm
+lib/aej40exe/Help/whgdata/whlstfl11.htm
+lib/aej40exe/Help/whgdata/whlstfl12.htm
+lib/aej40exe/Help/whgdata/whlstfl13.htm
+lib/aej40exe/Help/whgdata/whlstfl14.htm
+lib/aej40exe/Help/whgdata/whlstfl15.htm
+lib/aej40exe/Help/whgdata/whlstfl16.htm
+lib/aej40exe/Help/whgdata/whlstfl17.htm
+lib/aej40exe/Help/whgdata/whlstfl18.htm
+lib/aej40exe/Help/whgdata/whlstfl19.htm
+lib/aej40exe/Help/whgdata/whlstfl2.htm
+lib/aej40exe/Help/whgdata/whlstfl20.htm
+lib/aej40exe/Help/whgdata/whlstfl21.htm
+lib/aej40exe/Help/whgdata/whlstfl3.htm
+lib/aej40exe/Help/whgdata/whlstfl4.htm
+lib/aej40exe/Help/whgdata/whlstfl5.htm
+lib/aej40exe/Help/whgdata/whlstfl6.htm
+lib/aej40exe/Help/whgdata/whlstfl7.htm
+lib/aej40exe/Help/whgdata/whlstfl8.htm
+lib/aej40exe/Help/whgdata/whlstfl9.htm
+lib/aej40exe/Help/whgdata/whlstg0.htm
+lib/aej40exe/Help/whgdata/whlsti0.htm
+lib/aej40exe/Help/whgdata/whlstt0.htm
+lib/aej40exe/Help/whgdata/whlstt1.htm
+lib/aej40exe/Help/whgdata/whlstt2.htm
+lib/aej40exe/Help/whgdata/whlstt3.htm
+lib/aej40exe/Help/whgdata/whlstt4.htm
+lib/aej40exe/Help/whgdata/whlstt5.htm
+lib/aej40exe/Help/whgdata/whlstt6.htm
+lib/aej40exe/Help/whgdata/whlstt7.htm
+lib/aej40exe/Help/whgdata/whnvf30.htm
+lib/aej40exe/Help/whgdata/whnvf31.htm
+lib/aej40exe/Help/whgdata/whnvf32.htm
+lib/aej40exe/Help/whgdata/whnvf33.htm
+lib/aej40exe/Help/whgdata/whnvl31.htm
+lib/aej40exe/Help/whgdata/whnvl32.htm
+lib/aej40exe/Help/whgdata/whnvl33.htm
+lib/aej40exe/Help/whgdata/whnvp30.htm
+lib/aej40exe/Help/whgdata/whnvp31.htm
+lib/aej40exe/Help/whgdata/whnvp32.htm
+lib/aej40exe/Help/whgdata/whnvp33.htm
+lib/aej40exe/Help/whgdata/whnvt30.htm
+lib/aej40exe/Help/whgdata/whnvt31.htm
+lib/aej40exe/Help/whgdata/whnvt32.htm
+lib/aej40exe/Help/whgdata/whnvt33.htm
+lib/aej40exe/Help/whgdef.htm
+lib/aej40exe/Help/whgdhtml.htm
+lib/aej40exe/Help/whghost.js
+lib/aej40exe/Help/whhost.js
+lib/aej40exe/Help/whibody.htm
+lib/aej40exe/Help/whidhtml.htm
+lib/aej40exe/Help/whiform.htm
+lib/aej40exe/Help/whihost.js
+lib/aej40exe/Help/whlang.js
+lib/aej40exe/Help/whmozemu.js
+lib/aej40exe/Help/whmsg.js
+lib/aej40exe/Help/whnjs.htm
+lib/aej40exe/Help/whphost.js
+lib/aej40exe/Help/whproj.htm
+lib/aej40exe/Help/whproj.js
+lib/aej40exe/Help/whproj.xml
+lib/aej40exe/Help/whproxy.js
+lib/aej40exe/Help/whres.xml
+lib/aej40exe/Help/whskin_blank.htm
+lib/aej40exe/Help/whskin_info.htm
+lib/aej40exe/Help/whstart.js
+lib/aej40exe/Help/whstub.js
+lib/aej40exe/Help/whtdhtml.htm
+lib/aej40exe/Help/whthost.js
+lib/aej40exe/Help/whtopic.js
+lib/aej40exe/Help/whutils.js
+lib/aej40exe/Help/whver.js
+lib/aej40exe/Help/working_with_the_scale_bar.html
+lib/aej40exe/License.txt
+lib/aej40exe/Xenv/.java.policy
+lib/aej40exe/Xenv/ESRIPublicKey
+lib/aej40exe/Xenv/aimsclient.properties
+lib/aej40exe/Xenv/aimsproxy.properties
+lib/aej40exe/Xenv/cshrc
+lib/aej40exe/Xenv/login
+lib/aej40exe/bin/aejava
+lib/aej40exe/fonts/esri_0.ttf
+lib/aej40exe/lib/arcims_aej.jar
+lib/aej40exe/lib/arcims_resaej.jar
+lib/aej40exe/lib/esri_mo10.jar
+lib/aej40exe/lib/esri_mo10res.jar
+lib/aej40exe/lib/jai_codec.jar
+lib/aej40exe/lib/jai_core.jar
+lib/aej40exe/lib/jaxp.jar
+lib/aej40exe/lib/jcert.jar
+lib/aej40exe/lib/jnet.jar
+lib/aej40exe/lib/jsde82_sdk.jar
+lib/aej40exe/lib/jsde82_sdkres.jar
+lib/aej40exe/lib/jsse.jar
+lib/aej40exe/lib/mlibwrapper_jai.jar
+lib/aej40exe/lib/parser.jar
+@dirrm lib/aej40exe/lib
+@dirrm lib/aej40exe/fonts
+@dirrm lib/aej40exe/bin
+@dirrm lib/aej40exe/Xenv
+@dirrm lib/aej40exe/Help/whgdata
+@dirrm lib/aej40exe/Help/whdata
+@dirrm lib/aej40exe/Help
+@dirrm lib/aej40exe