aboutsummaryrefslogtreecommitdiff
path: root/databases/c3p0
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2013-02-09 17:00:02 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2013-02-09 17:00:02 +0000
commitb770aec54fcad334a3bd6e4f25a0b62a1231ab19 (patch)
treea93976f787169ecb7e79c878eb49889623fdc2d2 /databases/c3p0
parent5d7062bca2a95d97e7c45c63ccb0ef15bf8ee24e (diff)
downloadports-b770aec54fcad334a3bd6e4f25a0b62a1231ab19.tar.gz
ports-b770aec54fcad334a3bd6e4f25a0b62a1231ab19.zip
Notes
Diffstat (limited to 'databases/c3p0')
-rw-r--r--databases/c3p0/Makefile11
-rw-r--r--databases/c3p0/distinfo4
-rw-r--r--databases/c3p0/pkg-plist172
3 files changed, 180 insertions, 7 deletions
diff --git a/databases/c3p0/Makefile b/databases/c3p0/Makefile
index f2901c5f3a58..33b45f021461 100644
--- a/databases/c3p0/Makefile
+++ b/databases/c3p0/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= c3p0
-PORTVERSION= 0.9.1.2
+PORTVERSION= 0.9.2
CATEGORIES= databases java
-MASTER_SITES= SF/c3p0/c3p0-bin/c3p0-${PORTVERSION}/
-DISTNAME= c3p0-${PORTVERSION}.bin
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-bin/${PORTNAME}-${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.bin
EXTRACT_SUFX= .tgz
MAINTAINER= olgeni@FreeBSD.org
@@ -13,13 +13,14 @@ COMMENT= A library for augmenting JDBC drivers with JNDI-bindable DataSources
USE_JAVA= yes
NO_BUILD= yes
JAVA_VERSION= 1.6+
-WRKSRC= ${WRKDIR}/c3p0-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-install:
- @${INSTALL_DATA} ${WRKSRC}/lib/c3p0-0.9.1.2.jar ${JAVAJARDIR}/c3p0.jar
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/doc && ${COPYTREE_SHARE} apidocs ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} apidocs-oracle-thin ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/arrow_sm.png ${WRKSRC}/doc/index.html ${DOCSDIR}
.endif
diff --git a/databases/c3p0/distinfo b/databases/c3p0/distinfo
index 3861a095c937..48c6037b4323 100644
--- a/databases/c3p0/distinfo
+++ b/databases/c3p0/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c3p0-0.9.1.2.bin.tgz) = 22da2faf98f54bc238672598edc9941c5280f03e35c7fb9906ada7839ac0e827
-SIZE (c3p0-0.9.1.2.bin.tgz) = 1259670
+SHA256 (c3p0-0.9.2.bin.tgz) = ae7907f4102fd035043d9c2faa53ba817b731ca15b2f7a0f8ff1c48fc631d62f
+SIZE (c3p0-0.9.2.bin.tgz) = 2006081
diff --git a/databases/c3p0/pkg-plist b/databases/c3p0/pkg-plist
index 36b29496d417..138b7aa653c1 100644
--- a/databases/c3p0/pkg-plist
+++ b/databases/c3p0/pkg-plist
@@ -1,3 +1,18 @@
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/allclasses-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/allclasses-noframe.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0/dbms/OracleUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0/dbms/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0/dbms/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0/dbms/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/constant-values.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/deprecated-list.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/help-doc.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/index-all.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/index.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/overview-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/package-list
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/resources/inherit.gif
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/stylesheet.css
%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-frame.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-noframe.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/AbstractConnectionCustomizer.html
@@ -21,14 +36,150 @@
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/SQLWarnings.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/UnifiedConnectionTester.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/WrapperConnectionPoolDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/C3P0Config.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/C3P0ConfigFinder.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/C3P0ConfigUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/C3P0ConfigXmlUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/DefaultC3P0ConfigFinder.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen/BeangenDataSourceGenerator.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen/JdbcProxyGenerator.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/filter/FilterDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/filter/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/filter/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/filter/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/AbstractIdentityTokenized.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/AbstractPoolBackedDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/AuthMaskingProperties.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0Defaults.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0ImplUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0JavaBeanObjectFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0PooledConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0PooledConnectionPool.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/C3P0PooledConnectionPoolManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/DbAuth.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/DefaultConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/DriverManagerDataSourceBase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/IdentityTokenResolvable.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/IdentityTokenized.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/IdentityTokenizedCoalesceChecker.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/JndiRefDataSourceBase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewPooledConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyCallableStatement.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyConnection.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyDatabaseMetaData.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyPreparedStatement.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyResultSet.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/NewProxyStatement.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/PoolBackedDataSourceBase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/ProxyResultSetDetachable.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/WrapperConnectionPoolDataSourceBase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss/C3P0PooledDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss/C3P0PooledDataSourceMBean.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/ActiveManagementCoordinator.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/C3P0RegistryManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/C3P0RegistryManagerMBean.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/DynamicPooledDataSourceManagerMBean.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/ManagementCoordinator.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/NullManagementCoordinator.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/PooledDataSourceManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/PooledDataSourceManagerMBean.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean/C3P0PooledDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean/C3P0PooledDataSourceMBean.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean/package-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-frame.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-summary.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/servlet/C3P0StatusServlet.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/servlet/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/servlet/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/servlet/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/DoubleMaxStatementCache.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GlobalMaxOnlyStatementCache.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GooGooStatementCache.ConnectionStatementManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GooGooStatementCache.Deathmarch.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GooGooStatementCache.DeathmarchConnectionStatementManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GooGooStatementCache.SimpleConnectionStatementManager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/GooGooStatementCache.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/PerConnectionMaxOnlyStatementCache.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/StatementCache.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/StatementCacheBenchmark.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/subst/C3P0Substitutions.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/subst/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/subst/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/subst/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/AlwaysFailConnectionTester.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/C3P0BenchmarkApp.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/ConnectionDispersionTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/FreezableDriverManagerDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/InterruptedBatchTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/JavaBeanRefTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/JndiBindTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/JndiLookupTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/ListTablesTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/LoadPoolBackedDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/OneThreadRepeatedInsertOrQueryTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/PSLoadPoolBackedDataSource.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/ProxyWrappersTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/RawConnectionOpTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/StatsTest.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/TestConnectionCustomizer.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/TestRefSerStuff.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/C3P0JUnitTestCaseBase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/ConnectionPropertiesResetJUnitTestCase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/MarshallUnmarshallDataSourcesJUnitTestCase.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/CloseReportingConnectionWrapper.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/ConnectionEventSupport.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/TestUtils.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/package-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/BasicResourcePoolFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/CannotAcquireResourceException.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/EventSupportingResourcePool.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePool.Manager.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePool.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePoolEvent.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePoolEventSupport.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePoolException.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePoolFactory.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/ResourcePoolListener.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/TimeoutException.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/package-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/package-summary.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool/package-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/constant-values.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/deprecated-list.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/help-doc.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/index-all.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/index.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-frame.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-summary.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/package-list
%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/inherit.gif
@@ -38,9 +189,30 @@
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%JAVAJARDIR%%/c3p0.jar
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/resources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/resourcepool
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/junit
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/subst
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/stmt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/servlet
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/mbean
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/management
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/jboss
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/impl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/filter
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/codegen
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/cfg
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2/c3p0
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange/v2
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com/mchange
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs/com
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/resources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0/dbms
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2/c3p0
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/com/mchange/v2
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/com/mchange
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin/com
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs-oracle-thin
%%PORTDOCS%%@dirrm %%DOCSDIR%%/apidocs
%%PORTDOCS%%@dirrm %%DOCSDIR%%