aboutsummaryrefslogtreecommitdiff
path: root/databases/cego
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-07-01 05:49:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-07-01 05:49:29 +0000
commit78deb649426afc557bb39102bfd2cd8fde8787c6 (patch)
tree08678fca823626968a73b18b04bcc4fd19a78720 /databases/cego
parent2e25ea11a0b2e15b698d252d204e9a9eeb77beb1 (diff)
Notes
Diffstat (limited to 'databases/cego')
-rw-r--r--databases/cego/Makefile27
-rw-r--r--databases/cego/distinfo3
-rw-r--r--databases/cego/pkg-descr13
-rw-r--r--databases/cego/pkg-plist33
4 files changed, 76 insertions, 0 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
new file mode 100644
index 000000000000..50d5039b1cf3
--- /dev/null
+++ b/databases/cego/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cego
+# Date created: Jun 12, 2010
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= cego
+PORTVERSION= 2.5.13
+CATEGORIES= databases
+MASTER_SITES= http://www.lemke-it.com/
+DISTNAME= cego-${PORTVERSION}
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= A relational and transactional database system
+
+LIB_DEPENDS= Base.1:${PORTSDIR}/devel/cego-base \
+ XML.1:${PORTSDIR}/devel/cego-xml
+
+LICENSE= GPLv2
+WRKSRC= ${WRKDIR}/cego
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf:262:env
+
+.include <bsd.port.mk>
diff --git a/databases/cego/distinfo b/databases/cego/distinfo
new file mode 100644
index 000000000000..1fe23a4b93bc
--- /dev/null
+++ b/databases/cego/distinfo
@@ -0,0 +1,3 @@
+MD5 (cego-2.5.13.tar.gz) = 163d35defe03fbffa46b215bbd4348be
+SHA256 (cego-2.5.13.tar.gz) = 93a0ef10d6790874b1087c78fcf0098d933e010b8f280e7f9a7feb7dae5fae9c
+SIZE (cego-2.5.13.tar.gz) = 634213
diff --git a/databases/cego/pkg-descr b/databases/cego/pkg-descr
new file mode 100644
index 000000000000..6d5fcd3e3f2d
--- /dev/null
+++ b/databases/cego/pkg-descr
@@ -0,0 +1,13 @@
+Cego is a Relational Database Management System (RDBMS). Cego
+supports transactional SQL query requests in a multithreaded
+architecture. For high availablility requirements, Cego supports a
+database shadowing feature. Several compute nodes can be defined in
+a Cego database configuration, where each node is able to manage a
+number of so called table sets. For each tableset, a backup node
+can be defined, which runs is recover mode for the corresponding
+tableset. If required, the tableset can be switched to the backup
+node and this node gets the active node for the tableset.
+
+Many more details are available at:
+
+WWW: http://www.lemke-it.com/
diff --git a/databases/cego/pkg-plist b/databases/cego/pkg-plist
new file mode 100644
index 000000000000..bc0e7c663f3f
--- /dev/null
+++ b/databases/cego/pkg-plist
@@ -0,0 +1,33 @@
+bin/cego
+bin/cgadm
+bin/cgblow
+bin/cgclt
+bin/cglog
+include/CegoBlob.h
+include/CegoCheckObject.h
+include/CegoContentObject.h
+include/CegoDataPointer.h
+include/CegoDataType.h
+include/CegoDbHandler.h
+include/CegoDecodableObject.h
+include/CegoField.h
+include/CegoFieldValue.h
+include/CegoJoinObject.h
+include/CegoKeyObject.h
+include/CegoModule.h
+include/CegoObject.h
+include/CegoOutput.h
+include/CegoProcObject.h
+include/CegoProcVar.h
+include/CegoTableObject.h
+include/CegoViewObject.h
+include/cgwrap.h
+lib/libcego.a
+lib/libcego.so.1
+lib/libcgwrap.a
+lib/libcgwrap.so.1
+share/licenses/cego-2.5.13/GPLv2
+share/licenses/cego-2.5.13/LICENSE
+share/licenses/cego-2.5.13/catalog.mk
+@dirrm share/licenses/cego-2.5.13
+@dirrm share/licenses