aboutsummaryrefslogtreecommitdiff
path: root/databases/clickhouse/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-11-21 09:13:56 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-11-21 09:13:56 +0000
commit6e1f55411238cd6c419bb1070f9576a052c77995 (patch)
tree0d36e9aee7be5edfbc8efc94a64b7f5dcfb954a4 /databases/clickhouse/Makefile
parentcb6b6b50f96010786c93454a099bfd2d0c5aecb4 (diff)
downloadports-6e1f55411238cd6c419bb1070f9576a052c77995.tar.gz
ports-6e1f55411238cd6c419bb1070f9576a052c77995.zip
Notes
Diffstat (limited to 'databases/clickhouse/Makefile')
-rw-r--r--databases/clickhouse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/clickhouse/Makefile b/databases/clickhouse/Makefile
index 7c8fb8f620bd..0bef34293504 100644
--- a/databases/clickhouse/Makefile
+++ b/databases/clickhouse/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= clickhouse
-PORTVERSION= 18.12.17
+PORTVERSION= 18.14.11
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -stable
-PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= proler@gmail.com
@@ -32,11 +31,12 @@ LIB_DEPENDS= libtcmalloc.so:devel/google-perftools \
libPocoNet.so:devel/poco \
libunwind.so:devel/libunwind \
librdkafka.so:net/librdkafka \
+ libcpuid.so:sysutils/libcpuid \
libgtest.so:devel/googletest
-#TODO: libcpuid.so:sysutils/libcpuid \ # /usr/local/include/libcpuid/libcpuid_types.h:61:29: error: typedef redefinition with different types ('long long' vs '__int64_t' (aka 'long'))
USES= compiler:c++14-lang cmake iconv mysql ssl readline shebangfix
USE_LDCONFIG= yes
+
CMAKE_ARGS= -DUNBUNDLED=1 \
-DUSE_STATIC_LIBRARIES=0 \
-DNO_WERROR=1 \