aboutsummaryrefslogtreecommitdiff
path: root/databases/clickhouse
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-16 07:36:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-16 07:36:34 +0000
commitf049ec1da768f880e546b06510f445be6592a26a (patch)
tree6e50530da7e50828d118178b4ea4c10a6e1183de /databases/clickhouse
parent210ebe6e0537e282730799c32354fcf3a125c51b (diff)
downloadports-f049ec1da768f880e546b06510f445be6592a26a.tar.gz
ports-f049ec1da768f880e546b06510f445be6592a26a.zip
Notes
Diffstat (limited to 'databases/clickhouse')
-rw-r--r--databases/clickhouse/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/databases/clickhouse/Makefile b/databases/clickhouse/Makefile
index f2951520dbc9..22f5c2a601a8 100644
--- a/databases/clickhouse/Makefile
+++ b/databases/clickhouse/Makefile
@@ -5,6 +5,7 @@ PORTNAME= clickhouse
PORTVERSION= 1.1.54362
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -stable
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= proler@gmail.com
@@ -17,10 +18,9 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only supported on amd64"
BUILD_DEPENDS= bash:shells/bash \
- sparsehash>=0:devel/sparsehash \
- cctz>=0:devel/cctz \
- libdouble-conversion>=0:devel/libdouble-conversion
-
+ sparsehash>=0:devel/sparsehash \
+ cctz>=0:devel/cctz \
+ libdouble-conversion>=0:devel/libdouble-conversion
LIB_DEPENDS= libtcmalloc.so:devel/google-perftools \
libodbc.so:databases/unixODBC \
libltdl.so:devel/libltdl \
@@ -36,7 +36,7 @@ LIB_DEPENDS= libtcmalloc.so:devel/google-perftools \
librdkafka.so:net/librdkafka \
libgtest.so:devel/googletest
-USES= compiler:c++14-lang cmake iconv mysql ssl readline
+USES= compiler:c++14-lang cmake iconv mysql python ssl readline shebangfix
USE_LDCONFIG= yes
CMAKE_ARGS= -DUNBUNDLED=1 \
-DUSE_STATIC_LIBRARIES=0 \
@@ -48,8 +48,12 @@ CMAKE_ARGS= -DUNBUNDLED=1 \
USE_GITHUB= yes
GH_ACCOUNT= yandex
GH_PROJECT= ClickHouse
-
USE_RC_SUBR= ${PORTNAME}
+SHEBANG_FILES= dbms/tests/performance/create_benchmark_page.py \
+ dbms/tests/external_dictionaries/generate_and_test.py \
+ dbms/tests/external_dictionaries/http_server.py \
+ dbms/tests/clickhouse-test
+
USERS= clickhouse
GROUPS= clickhouse
@@ -74,6 +78,8 @@ post-install:
@${RM} -r ${STAGEDIR}${PREFIX}/include/gtest
@${RM} ${STAGEDIR}${PREFIX}/lib/libgtest*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/share/clickhouse-test/external_dictionaries/dictionary_library/lib*.so
+
${INSTALL_DATA} ${STAGEDIR}${PREFIX}/etc/clickhouse-client/config.xml \
${STAGEDIR}${PREFIX}/etc/clickhouse-client/config.xml.sample
${INSTALL_DATA} ${STAGEDIR}${PREFIX}/etc/clickhouse-server/config.xml \