aboutsummaryrefslogtreecommitdiff
path: root/databases/clip/files
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-06-17 21:21:06 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-06-17 21:21:06 +0000
commit90a4183fcfc46b1eaefc8bac72c4bde6c2593424 (patch)
treecdcdaebe98ee0f743c9c8a12ede174c43a7de85a /databases/clip/files
parentb9d86aefb0256468821c93f209d11639412bd177 (diff)
downloadports-90a4183fcfc46b1eaefc8bac72c4bde6c2593424.tar.gz
ports-90a4183fcfc46b1eaefc8bac72c4bde6c2593424.zip
Notes
Diffstat (limited to 'databases/clip/files')
-rw-r--r--databases/clip/files/patch-cliplibs::clip-com::Makefile19
-rw-r--r--databases/clip/files/patch-cliplibs::clip-fcgi::Makefile10
-rw-r--r--databases/clip/files/patch-cliplibs::clip-oasis::Makefile20
-rw-r--r--databases/clip/files/patch-cliplibs::clip-oasis::nanfor::Makefile16
-rw-r--r--databases/clip/files/patch-cliplibs::clip-oasis::netto::Makefile16
-rw-r--r--databases/clip/files/patch-cliplibs::clip-txtprn::Makefile9
-rw-r--r--databases/clip/files/patch-prg::udb::Makefile29
7 files changed, 119 insertions, 0 deletions
diff --git a/databases/clip/files/patch-cliplibs::clip-com::Makefile b/databases/clip/files/patch-cliplibs::clip-com::Makefile
new file mode 100644
index 000000000000..3ebb1c9a0a3e
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-com::Makefile
@@ -0,0 +1,19 @@
+--- cliplibs/clip-com/Makefile Mon Jun 17 14:31:02 2002
++++ cliplibs/clip-com/Makefile Mon Jun 17 14:31:30 2002
+@@ -24,7 +24,7 @@
+ $(CLIPROOT)/bin/clip_makeslib $(TARGET) $(OBJS) $(LIBEZ)
+
+ $(LIBEZ):
+- cd libezV24 && make
++ cd libezV24 && $(MAKE)
+
+ com.o: com.c hashcode.h
+ $(CC) $(CFLAGS) $(CLIPINCLUDE) -c com.c
+@@ -42,5 +42,5 @@
+
+ clean distclean:
+ rm -rf *.o *.bak *.a *.so hashcode.h *.dll *.exe bzpref.h
+- -cd libezV24; make clean; rm *.a *.so *.so.* *.exe
+- -cd example; make clean
++ -cd libezV24; $(MAKE) clean; rm *.a *.so *.so.* *.exe
++ -cd example; $(MAKE) clean
diff --git a/databases/clip/files/patch-cliplibs::clip-fcgi::Makefile b/databases/clip/files/patch-cliplibs::clip-fcgi::Makefile
new file mode 100644
index 000000000000..b78290848705
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-fcgi::Makefile
@@ -0,0 +1,10 @@
+--- cliplibs/clip-fcgi/Makefile Mon Jun 17 14:31:04 2002
++++ cliplibs/clip-fcgi/Makefile Mon Jun 17 14:31:34 2002
+@@ -35,6 +35,6 @@
+
+ clean:
+ rm -rf *.o *.bak *.a *.so hashcode.h *.dll *.exe names.h
+- cd example && make clean
++ cd example && $(MAKE) clean
+
+ distclean: clean
diff --git a/databases/clip/files/patch-cliplibs::clip-oasis::Makefile b/databases/clip/files/patch-cliplibs::clip-oasis::Makefile
new file mode 100644
index 000000000000..7152fcfd86bc
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-oasis::Makefile
@@ -0,0 +1,20 @@
+--- cliplibs/clip-oasis/Makefile Mon Jun 17 14:31:04 2002
++++ cliplibs/clip-oasis/Makefile Mon Jun 17 14:31:45 2002
+@@ -1,11 +1,11 @@
+
+ all:
+- cd netto; make
+- cd nanfor; make
++ cd netto; $(MAKE)
++ cd nanfor; $(MAKE)
+ install:
+- cd netto; make install
+- cd nanfor; make install
++ cd netto; $(MAKE) install
++ cd nanfor; $(MAKE) install
+ clean:
+- cd netto; make clean
+- cd nanfor; make clean
++ cd netto; $(MAKE) clean
++ cd nanfor; $(MAKE) clean
+
diff --git a/databases/clip/files/patch-cliplibs::clip-oasis::nanfor::Makefile b/databases/clip/files/patch-cliplibs::clip-oasis::nanfor::Makefile
new file mode 100644
index 000000000000..ca36869dd182
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-oasis::nanfor::Makefile
@@ -0,0 +1,16 @@
+--- cliplibs/clip-oasis/nanfor/Makefile Mon Jun 17 14:31:02 2002
++++ cliplibs/clip-oasis/nanfor/Makefile Mon Jun 17 14:31:49 2002
+@@ -10,11 +10,11 @@
+ all: $(TARGET)
+
+ $(TARGET):
+- cd prg; make
++ cd prg; $(MAKE)
+ $(CLIPROOT)/bin/clip_makeslib $(TARGET) $(LIBS)
+
+ clean distclean:
+- cd prg; make clean
++ cd prg; $(MAKE) clean
+ rm -f $(LIBS) $(TARGET) $(RTARGET)
+
+ install: $(TARGET)
diff --git a/databases/clip/files/patch-cliplibs::clip-oasis::netto::Makefile b/databases/clip/files/patch-cliplibs::clip-oasis::netto::Makefile
new file mode 100644
index 000000000000..da209f1fea7e
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-oasis::netto::Makefile
@@ -0,0 +1,16 @@
+--- cliplibs/clip-oasis/netto/Makefile Mon Jun 17 14:31:04 2002
++++ cliplibs/clip-oasis/netto/Makefile Mon Jun 17 14:32:10 2002
+@@ -10,11 +10,11 @@
+ all: $(TARGET)
+
+ $(TARGET):
+- cd misc; make
++ cd misc; $(MAKE)
+ $(CLIPROOT)/bin/clip_makeslib $(TARGET) $(LIBS)
+
+ clean distclean*:
+- cd misc; make clean
++ cd misc; $(MAKE) clean
+ rm -f $(LIBS) $(TARGET) $(RTARGET)
+
+ install: $(TARGET)
diff --git a/databases/clip/files/patch-cliplibs::clip-txtprn::Makefile b/databases/clip/files/patch-cliplibs::clip-txtprn::Makefile
new file mode 100644
index 000000000000..f0feca7391ea
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs::clip-txtprn::Makefile
@@ -0,0 +1,9 @@
+--- cliplibs/clip-txtprn/Makefile Mon Jun 17 14:31:02 2002
++++ cliplibs/clip-txtprn/Makefile Mon Jun 17 14:32:20 2002
+@@ -29,5 +29,5 @@
+ cp install/*.ini $(CLIPROOT)/print
+
+ clean:
+- cd example; make clean
++ cd example; $(MAKE) clean
+ rm -rf *.o *.bak doc/*.bak install/*.bak *.a *.so *.dll *.exe
diff --git a/databases/clip/files/patch-prg::udb::Makefile b/databases/clip/files/patch-prg::udb::Makefile
new file mode 100644
index 000000000000..5e8e6890590b
--- /dev/null
+++ b/databases/clip/files/patch-prg::udb::Makefile
@@ -0,0 +1,29 @@
+--- prg/udb/Makefile Mon Jun 17 14:31:09 2002
++++ prg/udb/Makefile Mon Jun 17 14:32:30 2002
+@@ -13,7 +13,7 @@
+ commit:
+ ../_cvs commit
+ clean:
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+ cd include; rm -rf *.bak *.log
+ cd gbl01; rm -rf *.po *.bak *.log *.po *core core*
+ cd plugins; rm -rf *.po *.bak *.log *.po *core core*
+@@ -23,7 +23,7 @@
+ $(CLIP) $(CLIPFLAGS) -s -e -M test.prg $(CLIPLIBS) $(LIBS)
+
+ lib:
+- cd dict; make lib
++ cd dict; $(MAKE) lib
+
+ codb_mk: $(LIBS) codb_mk.prg
+ $(CLIP) $(CLIPFLAGS) -s -e -M codb_mk.prg $(CLIPLIBS) $(LIBS)
+@@ -35,7 +35,7 @@
+ # $(CLIP) $(CLIPFLAGS) codb_mk.prg
+
+ libclip-codb.a:
+- cd dict; make
++ cd dict; $(MAKE)
+
+ libclip-codb.so: $(ALIBS)
+ clip_makeslib libclip-codb.so $(ALIBS)