aboutsummaryrefslogtreecommitdiff
path: root/databases/couchdb2
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
commit5fb9edd6bda35148388cbd149c7fa48f4749f514 (patch)
treefd3fa9b642407455ac306d9a4732b8ea68fd8c43 /databases/couchdb2
parent3ca9aed4201adba81415517e7e132bd8f99b03f7 (diff)
downloadports-5fb9edd6bda35148388cbd149c7fa48f4749f514.tar.gz
ports-5fb9edd6bda35148388cbd149c7fa48f4749f514.zip
Multiple ports: improve regex compliance
These changes largely fall into just two categories: 1. Need textproc/gsed for GNU extensions 2. Extraneous escapes that can go away For #1, there's a further subdivision into those that require autoconf magic and those that can get away with BINARY_ALIAS=sed=${LOCALBASE}/bin/gsed. -CURRENT will soon gain GNU extensions, but these will take longer to get to all supported releases; we must switch them to gsed to ensure we're actually properly building them as intended. For #2, I've fixed these as I can and we should upstream these fixes. PORTREVISION is bumped for all of the above, because we will almost certainly build these differently when the replacements actually start working. These were all detected by the below-referenced exp-run [1]. The patch included forbids many ordinary characters from being escaped, since we'll later imbue those with special meanings. This has had the nice side effect of picking up various things that we didn't handle properly, e.g. \t and \r for tab and carriage return. PR: 229925 [1] Approved by: koobs (mentor) Approved by: portmgr (blanket: trivial build fixes) MFH: no (invasive risk) Differential Revision: https://reviews.freebsd.org/D25185
Notes
Notes: svn path=/head/; revision=538197
Diffstat (limited to 'databases/couchdb2')
-rw-r--r--databases/couchdb2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/couchdb2/Makefile b/databases/couchdb2/Makefile
index 46a9be5cdb6b..e62e2c28c711 100644
--- a/databases/couchdb2/Makefile
+++ b/databases/couchdb2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= couchdb2
DISTVERSION= 2.3.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
DISTNAME= apache-couchdb-${DISTVERSION}
@@ -60,8 +60,8 @@ post-patch:
-e 's,%%LOCALBASE%%,${LOCALBASE},g' \
-e 's,%%PORTNAME%%,${PORTNAME},g' \
-e 's,%%WWWDIR%%,${WWWDIR},g' \
- -e 's,\$COUCHDB_USER,${USERS},g' \
- -e 's,\$LOG_FILE,${LOGFILE},g' \
+ -e 's,$$COUCHDB_USER,${USERS},g' \
+ -e 's,$$LOG_FILE,${LOGFILE},g' \
${WRKSRC}/configure
pre-install: