aboutsummaryrefslogtreecommitdiff
path: root/databases/couchdb
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-04-21 15:43:03 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-04-21 15:43:03 +0000
commita31fffe789279133129b1301ed331603aeaea534 (patch)
tree4485e305dce9a7e8037955b689d2f3b629eb1b8f /databases/couchdb
parent5098fed9c7f5203dcccc45cb60da81dd2463d58c (diff)
downloadports-a31fffe789279133129b1301ed331603aeaea534.tar.gz
ports-a31fffe789279133129b1301ed331603aeaea534.zip
Notes
Diffstat (limited to 'databases/couchdb')
-rw-r--r--databases/couchdb/Makefile18
-rw-r--r--databases/couchdb/distinfo6
-rw-r--r--databases/couchdb/pkg-plist318
3 files changed, 211 insertions, 131 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 47fb055c0ec8..0926b4c1bf79 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= couchdb
-PORTVERSION= 0.9.0a
+PORTVERSION= 0.9.0
+PORTEPOCH= 1
CATEGORIES= databases
-MASTER_SITES= http://people.apache.org/~nslater/build/latest/
-DISTNAME= apache-couchdb-0.9.0a-incubating
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= couchdb/${PORTVERSION}
+DISTNAME= apache-couchdb-${PORTVERSION}
-MAINTAINER= jan@apache.org
+MAINTAINER= till@php.net
COMMENT= A document database server, accessible via a RESTful JSON API
LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
- js:${PORTSDIR}/lang/spidermonkey
+ js:${PORTSDIR}/lang/spidermonkey \
+ curl.5:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= ${LOCALBASE}/lib/erlang/usr/include/erl_driver.h:${PORTSDIR}/lang/erlang-lite
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -24,14 +27,13 @@ USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
--localstatedir=/var \
+ --disable-init
MAN1= couchdb.1 couchjs.1
-PLIST_SUB= COUCHVERSION=couch-${PORTVERSION}-incubating
-
post-patch:
.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e 's/install-data-am$$//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/install-data-am$$//' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/databases/couchdb/distinfo b/databases/couchdb/distinfo
index cae8166daed9..1df369ca9589 100644
--- a/databases/couchdb/distinfo
+++ b/databases/couchdb/distinfo
@@ -1,3 +1,3 @@
-MD5 (apache-couchdb-0.9.0a-incubating.tar.gz) = a4bee75260a7e89de600841f392b846c
-SHA256 (apache-couchdb-0.9.0a-incubating.tar.gz) = 790dd3f12051ff1e92f4f7cfd840cdfd4d4efd241e2ee56a706f195dd3e914d3
-SIZE (apache-couchdb-0.9.0a-incubating.tar.gz) = 567412
+MD5 (apache-couchdb-0.9.0.tar.gz) = 16526c807ae8a455a0a4feb50d0357eb
+SHA256 (apache-couchdb-0.9.0.tar.gz) = 8e18416179860f893dc31e81948869195a07cbd69a81966bb9631a0d3ab9f99c
+SIZE (apache-couchdb-0.9.0.tar.gz) = 737185
diff --git a/databases/couchdb/pkg-plist b/databases/couchdb/pkg-plist
index f482e88afd46..c2f20302c66a 100644
--- a/databases/couchdb/pkg-plist
+++ b/databases/couchdb/pkg-plist
@@ -1,111 +1,187 @@
bin/couchdb
bin/couchjs
-%%ETCDIR%%/couch.ini
+etc/couchdb/default.ini
+etc/couchdb/local.ini
etc/logrotate.d/couchdb
-etc/default/couchdb
-etc/rc.d/couchdb
lib/couchdb/bin/couchjs
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/cjson.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch.app
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_btree.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db_update_notifier.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_db_updater.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_doc.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_event_sup.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_file.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_ft_query.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_httpd.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_key_tree.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_log.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_query_servers.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_rep.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_server.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_server_sup.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_stream.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_util.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin/couch_view.beam
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/include/couch_db.hrl
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.a
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.la
-lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib/couch_erl_driver.so
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb.app
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_request.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_response.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_util.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_charref.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_app.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt_std.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_skel.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_sup.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochinum.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_http.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_multipart.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_socket_server.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochijson2.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt_records.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_headers.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochihex.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_echo.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_cookies.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochiweb_html.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/reloader.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochifmt.beam
-lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochijson.beam
-%%DATADIR%%/server/main.js
-%%DATADIR%%/www/browse/_create_document.html
-%%DATADIR%%/www/browse/_create_database.html
-%%DATADIR%%/www/browse/_delete_database.html
-%%DATADIR%%/www/browse/_compact_database.html
-%%DATADIR%%/www/browse/_delete_document.html
-%%DATADIR%%/www/browse/_save_view_as.html
-%%DATADIR%%/www/browse/database.html
-%%DATADIR%%/www/browse/document.html
-%%DATADIR%%/www/browse/index.html
-%%DATADIR%%/www/couch_tests.html
-%%DATADIR%%/www/favicon.ico
-%%DATADIR%%/www/image/add.gif
-%%DATADIR%%/www/image/apply.gif
-%%DATADIR%%/www/image/bg.png
-%%DATADIR%%/www/image/cancel.gif
-%%DATADIR%%/www/image/compact.gif
-%%DATADIR%%/www/image/delete-mini.gif
-%%DATADIR%%/www/image/delete.gif
-%%DATADIR%%/www/image/grippie.gif
-%%DATADIR%%/www/image/hgrad.gif
-%%DATADIR%%/www/image/load.gif
-%%DATADIR%%/www/image/logo.png
-%%DATADIR%%/www/image/order-asc.gif
-%%DATADIR%%/www/image/order-desc.gif
-%%DATADIR%%/www/image/path.gif
-%%DATADIR%%/www/image/progress.gif
-%%DATADIR%%/www/image/run-mini.gif
-%%DATADIR%%/www/image/run.gif
-%%DATADIR%%/www/image/running.gif
-%%DATADIR%%/www/image/save.gif
-%%DATADIR%%/www/image/spinner.gif
-%%DATADIR%%/www/image/test_failure.gif
-%%DATADIR%%/www/image/test_success.gif
-%%DATADIR%%/www/image/thead-key.gif
-%%DATADIR%%/www/image/thead.gif
-%%DATADIR%%/www/image/toggle-collapse.gif
-%%DATADIR%%/www/image/toggle-expand.gif
-%%DATADIR%%/www/image/twisty.gif
-%%DATADIR%%/www/index.html
-%%DATADIR%%/www/replicator.html
-%%DATADIR%%/www/script/browse.js
-%%DATADIR%%/www/script/couch.js
-%%DATADIR%%/www/script/couch_tests.js
-%%DATADIR%%/www/script/jquery.dialog.js
-%%DATADIR%%/www/script/jquery.suggest.js
-%%DATADIR%%/www/script/jquery.couch.js
-%%DATADIR%%/www/script/jquery.cookies.js
-%%DATADIR%%/www/script/jquery.resizer.js
-%%DATADIR%%/www/script/jquery.js
-%%DATADIR%%/www/script/json2.js
-%%DATADIR%%/www/script/pprint.js
-%%DATADIR%%/www/style/layout.css
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_sup.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_app.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_test.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_lib.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_lb.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse_http_client.beam
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse.app
+lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin/ibrowse.beam
+lib/couchdb/erlang/lib/couch-0.9.0/include/couch_db.hrl
+lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.la
+lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.so
+lib/couchdb/erlang/lib/couch-0.9.0/priv/lib/couch_erl_driver.a
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_os_process.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_server.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stream.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_updater.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_rep.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_log.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_update_notifier_sup.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_event_sup.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_config_writer.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_stats_handlers.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch.app
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_util.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_task_status.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_db_update_notifier.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_config.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_file.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_view.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_db.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_btree.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_rep_sup.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view_group.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_external_server.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stats_aggregator.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_stats_collector.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_ref_counter.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_query_servers.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_doc.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_server_sup.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_misc_handlers.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_external.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_httpd_show.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_external_manager.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_view_updater.beam
+lib/couchdb/erlang/lib/couch-0.9.0/ebin/couch_key_tree.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt_records.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochifmt_std.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochihex.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochijson.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochijson2.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochinum.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb.app
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_app.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_charref.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_cookies.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_echo.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_headers.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_html.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_http.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_multipart.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_request.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_response.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_skel.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_socket_server.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_sup.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/mochiweb_util.beam
+lib/couchdb/erlang/lib/mochiweb-r97/ebin/reloader.beam
+share/couchdb/server/main.js
+share/couchdb/www/_sidebar.html
+share/couchdb/www/config.html
+share/couchdb/www/couch_tests.html
+share/couchdb/www/database.html
+share/couchdb/www/dialog/_compact_database.html
+share/couchdb/www/dialog/_create_database.html
+share/couchdb/www/dialog/_create_document.html
+share/couchdb/www/dialog/_delete_database.html
+share/couchdb/www/dialog/_delete_document.html
+share/couchdb/www/dialog/_save_view_as.html
+share/couchdb/www/dialog/_upload_attachment.html
+share/couchdb/www/document.html
+share/couchdb/www/favicon.ico
+share/couchdb/www/image/add.png
+share/couchdb/www/image/apply.gif
+share/couchdb/www/image/bg.png
+share/couchdb/www/image/cancel.gif
+share/couchdb/www/image/compact.png
+share/couchdb/www/image/delete-mini.png
+share/couchdb/www/image/delete.png
+share/couchdb/www/image/grippie.gif
+share/couchdb/www/image/hgrad.gif
+share/couchdb/www/image/load.png
+share/couchdb/www/image/logo.png
+share/couchdb/www/image/order-asc.gif
+share/couchdb/www/image/order-desc.gif
+share/couchdb/www/image/path.gif
+share/couchdb/www/image/progress.gif
+share/couchdb/www/image/rarrow.png
+share/couchdb/www/image/run-mini.png
+share/couchdb/www/image/run.png
+share/couchdb/www/image/running.png
+share/couchdb/www/image/save.png
+share/couchdb/www/image/spinner.gif
+share/couchdb/www/image/test_failure.gif
+share/couchdb/www/image/test_success.gif
+share/couchdb/www/image/thead-key.gif
+share/couchdb/www/image/thead.gif
+share/couchdb/www/image/toggle-collapse.gif
+share/couchdb/www/image/toggle-expand.gif
+share/couchdb/www/image/twisty.gif
+share/couchdb/www/index.html
+share/couchdb/www/replicator.html
+share/couchdb/www/script/couch.js
+share/couchdb/www/script/couch_test_runner.js
+share/couchdb/www/script/couch_tests.js
+share/couchdb/www/script/futon.browse.js
+share/couchdb/www/script/futon.format.js
+share/couchdb/www/script/futon.js
+share/couchdb/www/script/jquery.cookies.js
+share/couchdb/www/script/jquery.couch.js
+share/couchdb/www/script/jquery.dialog.js
+share/couchdb/www/script/jquery.editinline.js
+share/couchdb/www/script/jquery.form.js
+share/couchdb/www/script/jquery.js
+share/couchdb/www/script/jquery.resizer.js
+share/couchdb/www/script/jquery.suggest.js
+share/couchdb/www/script/json2.js
+share/couchdb/www/script/test/view_include_docs.js
+share/couchdb/www/script/test/conflicts.js
+share/couchdb/www/script/test/show_documents.js
+share/couchdb/www/script/test/view_collation.js
+share/couchdb/www/script/test/utf8.js
+share/couchdb/www/script/test/design_docs.js
+share/couchdb/www/script/test/view_xml.js
+share/couchdb/www/script/test/design_options.js
+share/couchdb/www/script/test/uuids.js
+share/couchdb/www/script/test/etags_views.js
+share/couchdb/www/script/test/multiple_rows.js
+share/couchdb/www/script/test/design_paths.js
+share/couchdb/www/script/test/copy_doc.js
+share/couchdb/www/script/test/large_docs.js
+share/couchdb/www/script/test/recreate_doc.js
+share/couchdb/www/script/test/all_docs.js
+share/couchdb/www/script/test/config.js
+share/couchdb/www/script/test/attachment_views.js
+share/couchdb/www/script/test/lots_of_docs.js
+share/couchdb/www/script/test/view_sandboxing.js
+share/couchdb/www/script/test/etags_head.js
+share/couchdb/www/script/test/reduce.js
+share/couchdb/www/script/test/replication.js
+share/couchdb/www/script/test/stats.js
+share/couchdb/www/script/test/security_validation.js
+share/couchdb/www/script/test/compact.js
+share/couchdb/www/script/test/view_offsets.js
+share/couchdb/www/script/test/list_views.js
+share/couchdb/www/script/test/view_errors.js
+share/couchdb/www/script/test/attachments.js
+share/couchdb/www/script/test/reduce_false.js
+share/couchdb/www/script/test/attachment_paths.js
+share/couchdb/www/script/test/bulk_docs.js
+share/couchdb/www/script/test/rev_stemming.js
+share/couchdb/www/script/test/purge.js
+share/couchdb/www/script/test/invalid_docids.js
+share/couchdb/www/script/test/view_pagination.js
+share/couchdb/www/script/test/delayed_commits.js
+share/couchdb/www/script/test/view_conflicts.js
+share/couchdb/www/script/test/view_multi_key_all_docs.js
+share/couchdb/www/script/test/view_multi_key_temp.js
+share/couchdb/www/script/test/view_multi_key_design.js
+share/couchdb/www/script/test/basics.js
+share/couchdb/www/script/test/content_negotiation.js
+share/couchdb/www/status.html
+share/couchdb/www/style/layout.css
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.gz
%%PORTDOCS%%%%DOCSDIR%%/BUGS.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.gz
@@ -113,24 +189,26 @@ lib/couchdb/erlang/lib/mochiweb-r82/ebin/mochijson.beam
%%PORTDOCS%%%%DOCSDIR%%/README.gz
%%PORTDOCS%%%%DOCSDIR%%/THANKS.gz
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/www/style
-@dirrm %%DATADIR%%/www/script
-@dirrm %%DATADIR%%/www/image
-@dirrm %%DATADIR%%/www/browse
-@dirrm %%DATADIR%%/www
-@dirrm %%DATADIR%%/server
-@dirrm %%DATADIR%%
-@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv/lib
-@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/priv
-@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/include
-@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%/ebin
-@dirrm lib/couchdb/erlang/lib/mochiweb-r82/ebin
-@dirrm lib/couchdb/erlang/lib/mochiweb-r82
-@dirrm lib/couchdb/erlang/lib/%%COUCHVERSION%%
+@dirrm share/couchdb/www/style
+@dirrm share/couchdb/www/script/test
+@dirrm share/couchdb/www/script
+@dirrm share/couchdb/www/image
+@dirrm share/couchdb/www/dialog
+@dirrm share/couchdb/www
+@dirrm share/couchdb/server
+@dirrm share/couchdb
+@dirrm lib/couchdb/erlang/lib/couch-0.9.0/ebin
+@dirrm lib/couchdb/erlang/lib/couch-0.9.0/include
+@dirrm lib/couchdb/erlang/lib/couch-0.9.0/priv/lib
+@dirrm lib/couchdb/erlang/lib/couch-0.9.0/priv
+@dirrm lib/couchdb/erlang/lib/couch-0.9.0
+@dirrm lib/couchdb/erlang/lib/ibrowse-1.4.1/ebin
+@dirrm lib/couchdb/erlang/lib/ibrowse-1.4.1
+@dirrm lib/couchdb/erlang/lib/mochiweb-r97/ebin
+@dirrm lib/couchdb/erlang/lib/mochiweb-r97
@dirrm lib/couchdb/erlang/lib
@dirrm lib/couchdb/erlang
@dirrm lib/couchdb/bin
@dirrm lib/couchdb
-@dirrm etc/default
@dirrm etc/logrotate.d
-@dirrm %%ETCDIR%%
+@dirrm etc/couchdb