aboutsummaryrefslogtreecommitdiff
path: root/databases/credis
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2011-02-02 17:24:59 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2011-02-02 17:24:59 +0000
commit5b47f10e5df724da733a3b414145020d2a169fba (patch)
treedefcd425f1ff23dd985c9d005e3da92fc9106078 /databases/credis
parent7c3868246a75248b5ea92bbc78bdbab2a5729c70 (diff)
downloadports-5b47f10e5df724da733a3b414145020d2a169fba.tar.gz
ports-5b47f10e5df724da733a3b414145020d2a169fba.zip
Notes
Diffstat (limited to 'databases/credis')
-rw-r--r--databases/credis/Makefile21
-rw-r--r--databases/credis/distinfo2
-rw-r--r--databases/credis/files/patch-Makefile50
-rw-r--r--databases/credis/files/patch-credis.c12
-rw-r--r--databases/credis/pkg-descr3
-rw-r--r--databases/credis/pkg-plist6
6 files changed, 94 insertions, 0 deletions
diff --git a/databases/credis/Makefile b/databases/credis/Makefile
new file mode 100644
index 000000000000..7634995302fe
--- /dev/null
+++ b/databases/credis/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: credis
+# Date created: 2011-02-02
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= credis
+PORTVERSION= 0.2.3
+CATEGORIES= databases
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Library for communicating with Redis servers
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/databases/credis/distinfo b/databases/credis/distinfo
new file mode 100644
index 000000000000..204c198f84a0
--- /dev/null
+++ b/databases/credis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (credis-0.2.3.tar.gz) = d9ab904be07865bd159ab44ebc45ef1dae71071842a5b7dec321b09c13a770d0
+SIZE (credis-0.2.3.tar.gz) = 17265
diff --git a/databases/credis/files/patch-Makefile b/databases/credis/files/patch-Makefile
new file mode 100644
index 000000000000..e60106725ac2
--- /dev/null
+++ b/databases/credis/files/patch-Makefile
@@ -0,0 +1,50 @@
+--- Makefile.orig 2010-08-27 04:57:25.000000000 -0400
++++ Makefile 2011-02-02 11:38:11.000000000 -0500
+@@ -1,7 +1,21 @@
+-CFLAGS = -g -O2 -Wall
+-LDFLAGS =
++CFLAGS ?= -g -O2 -Wall
++LDFLAGS ?=
+ #CPPFLAGS = -DPRINTDEBUG
+
++VER_MAJOR = 0
++VER_MINOR = 2
++VER_PATCH = 3
++VER=$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)
++
++prefix ?= /usr/local
++libdir = $(prefix)/lib
++includedir = $(prefix)/include
++DESTDIR ?=
++INSTALL ?= /usr/bin/install -c
++MKDIR_P ?= /bin/mkdir -p
++CP ?= /bin/cp -f
++LN ?= /bin/ln -fs
++
+ # build shared lib under OS X or Linux
+ OS = $(shell uname -s)
+ ifeq ($(OS),Darwin)
+@@ -22,12 +36,19 @@
+ $(AR) -cvq $@ $^
+
+ libcredis.so: credis.o
+- $(CC) $(SHAREDLIB_LINK_OPTIONS)$@ -o $@ $^
++ $(CC) $(SHAREDLIB_LINK_OPTIONS)$@.$(VER_MAJOR) -o $@.$(VER) $^
++ $(LN) $@.$(VER) $@.$(VER_MAJOR)
++ $(LN) $@.$(VER_MAJOR) $@
+
+ credis.o: credis.c credis.h Makefile
+ $(CC) -c -fPIC $(CFLAGS) $(CPPFLAGS) -o $@ credis.c
+
+-install:
+- @echo "Installing library (to be done)"
++install: all installdirs
++ $(INSTALL) -m644 *.h $(DESTDIR)$(includedir)
++ $(CP) *.so* *.a $(DESTDIR)$(libdir)
++
++installdirs:
++ $(MKDIR_P) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++
+ clean:
+- rm -f *.o *~ $(TARGETS)
++ rm -f *.o *~ *.so* $(TARGETS)
diff --git a/databases/credis/files/patch-credis.c b/databases/credis/files/patch-credis.c
new file mode 100644
index 000000000000..2cc3accf657c
--- /dev/null
+++ b/databases/credis/files/patch-credis.c
@@ -0,0 +1,12 @@
+--- credis.c.orig 2011-02-02 09:38:06.000000000 -0500
++++ credis.c 2011-02-02 09:38:37.000000000 -0500
+@@ -34,6 +34,9 @@
+ #define WIN32_LEAN_AND_MEAN
+ #include <winsock2.h>
+ #else
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <fcntl.h>
diff --git a/databases/credis/pkg-descr b/databases/credis/pkg-descr
new file mode 100644
index 000000000000..819de2708a07
--- /dev/null
+++ b/databases/credis/pkg-descr
@@ -0,0 +1,3 @@
+Credis is a client library in plain C for communicating with Redis servers.
+
+WWW: http://code.google.com/p/credis/
diff --git a/databases/credis/pkg-plist b/databases/credis/pkg-plist
new file mode 100644
index 000000000000..60426048b139
--- /dev/null
+++ b/databases/credis/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+include/credis.h
+lib/libcredis.a
+lib/libcredis.so
+lib/libcredis.so.0
+lib/libcredis.so.%%VERSION%%