aboutsummaryrefslogtreecommitdiff
path: root/databases/db3/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-06 00:12:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-06 00:12:42 +0000
commit9acddbe8db1736adea6dccb1eb706a0ab3da43a7 (patch)
tree6420fc45879ef6da86024054eaf10734bd1f2c6f /databases/db3/Makefile
parent0f3ea1bafe063272405c67a4573bd5069d1db62a (diff)
downloadports-9acddbe8db1736adea6dccb1eb706a0ab3da43a7.tar.gz
ports-9acddbe8db1736adea6dccb1eb706a0ab3da43a7.zip
Notes
Diffstat (limited to 'databases/db3/Makefile')
-rw-r--r--databases/db3/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/databases/db3/Makefile b/databases/db3/Makefile
index 008e713a24ae..9b1b38ad72d4 100644
--- a/databases/db3/Makefile
+++ b/databases/db3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= db3
PORTVERSION= 3.3.11
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH?= 1
CATEGORIES= databases
#MASTER_SITES= http://www.sleepycat.com/update/snapshot/
@@ -39,9 +39,18 @@ INSTALL_TARGET= install_include install_lib install_utilities
.if !defined(NOPORTDOCS)
INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
PORTDOCS= *
+.endif
-post-install:
- ${RMDIR} ${DOCSDIR}/ref/splash
+.if defined(WITH_TCL_VER)
+.if ${WITH_TCL_VER} == 8.4 || ${WITH_TCL_VER} == 8.3
+CONFIGURE_ARGS+= --enable-tcl --with-tcl=${LOCALBASE}/lib/tcl${WITH_TCL_VER}
+LIB_DEPENDS+= tcl${WITH_TCL_VER:S/.//}.1:${PORTSDIR}/lang/tcl${WITH_TCL_VER:S/.//}
+PLIST_SUB+= WITHTCL=""
+.else
+IGNORE= "WITH_TCL_VER must be 8.4 or 8.3"
+.endif
+.else
+PLIST_SUB+= WITHTCL="@comment "
.endif
pre-patch:
@@ -51,4 +60,15 @@ post-patch:
@${CHMOD} 755 ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/../dist/configure
+post-configure:
+.if defined(WITH_TCL_VER)
+ @${REINPLACE_CMD} -e "s|TCFLAGS=.*|TCFLAGS=-I${LOCALBASE}/include/tcl${WITH_TCL_VER} -L${LOCALBASE}/lib/tcl${WITH_TCL_VER}|g" ${WRKSRC}/Makefile
+.endif
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/libdb_tcl-3.3.la
+.if !defined(NOPORTDOCS)
+ ${RMDIR} ${DOCSDIR}/ref/splash
+.endif
+
.include <bsd.port.mk>