aboutsummaryrefslogtreecommitdiff
path: root/databases/db41
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-10-09 14:26:34 +0000
committerMatthias Andree <mandree@FreeBSD.org>2010-10-09 14:26:34 +0000
commit18794da1c67833b425cb32391e01611725497d0d (patch)
treed072c88c90371a4f13613d3d17b49c222c544aa3 /databases/db41
parentf08cbd6639ff8218229c53284ea042da83622531 (diff)
downloadports-18794da1c67833b425cb32391e01611725497d0d.tar.gz
ports-18794da1c67833b425cb32391e01611725497d0d.zip
Notes
Diffstat (limited to 'databases/db41')
-rw-r--r--databases/db41/Makefile4
-rw-r--r--databases/db41/distinfo6
-rw-r--r--databases/db41/files/patch-upstream.4.1.25.120
-rw-r--r--databases/db41/files/patch-upstream.4.1.25.350
4 files changed, 72 insertions, 8 deletions
diff --git a/databases/db41/Makefile b/databases/db41/Makefile
index 56b4bf1d22bc..16df38d4b2c4 100644
--- a/databases/db41/Makefile
+++ b/databases/db41/Makefile
@@ -16,8 +16,8 @@ PKGNAMESUFFIX?=
DISTNAME?= db-${PORTVERSION}
DIST_SUBDIR= bdb
-PATCH_SITES= http://www.oracle.com/technology/products/berkeley-db/db/update/${PORTVERSION}/
-PATCHFILES= patch.${PORTVERSION}.1 patch.${PORTVERSION}.2 patch.${PORTVERSION}.3
+#PATCH_SITES= http://www.oracle.com/technology/products/berkeley-db/db/update/${PORTVERSION}/
+PATCHFILES= patch.${PORTVERSION}.2
PATCH_DIST_STRIP= -d ${WRKDIR}/${DISTNAME}
MAINTAINER= mandree@FreeBSD.org
diff --git a/databases/db41/distinfo b/databases/db41/distinfo
index 2718d3f4503c..d9152a0e08d7 100644
--- a/databases/db41/distinfo
+++ b/databases/db41/distinfo
@@ -1,12 +1,6 @@
MD5 (bdb/db-4.1.25.tar.gz) = d82ed75cb53b0daba4a7e959e8a6f86c
SHA256 (bdb/db-4.1.25.tar.gz) = 0d0644039b24f8eb823d0492f86bb8cd61fde36adbf85c52f4141fcbce05d9f3
SIZE (bdb/db-4.1.25.tar.gz) = 2901161
-MD5 (bdb/patch.4.1.25.1) = 1e073d12cd89f9345e281ca07368f74b
-SHA256 (bdb/patch.4.1.25.1) = c79fc5e3a0fd9622ca7a266c7c41ebb49c510fe83fe655b432cf5aefe4bafc6c
-SIZE (bdb/patch.4.1.25.1) = 610
MD5 (bdb/patch.4.1.25.2) = 5eedc6818783b4b89317d89d2babb6f7
SHA256 (bdb/patch.4.1.25.2) = 391e652b0b6a1e2410a8e4b8d7e0ed0d53c9af549a29754e04532f390bee8f5d
SIZE (bdb/patch.4.1.25.2) = 18100
-MD5 (bdb/patch.4.1.25.3) = bda83ce3ce18a3e9001d0c2eb90d9508
-SHA256 (bdb/patch.4.1.25.3) = e55642b62cdd571f715f9109f522e0be6258fbe85c770228d8d0e2d29c2cfe9c
-SIZE (bdb/patch.4.1.25.3) = 1641
diff --git a/databases/db41/files/patch-upstream.4.1.25.1 b/databases/db41/files/patch-upstream.4.1.25.1
new file mode 100644
index 000000000000..801e3350319d
--- /dev/null
+++ b/databases/db41/files/patch-upstream.4.1.25.1
@@ -0,0 +1,20 @@
+*** ../fileops/fop_util.c 8 Jan 2003 05:01:56 -0000 1.57
+--- ../fileops/fop_util.c 12 Jan 2003 19:44:29 -0000 1.58
+***************
+*** 40,46 ****
+ u_int32_t __lockval; \
+ \
+ if (LOCKING_ON((ENV))) { \
+! __lockval = 0; \
+ __dbt.data = &__lockval; \
+ __dbt.size = sizeof(__lockval); \
+ if ((ret = (ENV)->lock_get((ENV), (ID), \
+--- 40,46 ----
+ u_int32_t __lockval; \
+ \
+ if (LOCKING_ON((ENV))) { \
+! __lockval = 1; \
+ __dbt.data = &__lockval; \
+ __dbt.size = sizeof(__lockval); \
+ if ((ret = (ENV)->lock_get((ENV), (ID), \
+
diff --git a/databases/db41/files/patch-upstream.4.1.25.3 b/databases/db41/files/patch-upstream.4.1.25.3
new file mode 100644
index 000000000000..f31ebfdf1fb5
--- /dev/null
+++ b/databases/db41/files/patch-upstream.4.1.25.3
@@ -0,0 +1,50 @@
+*** ../mp/mp_fget.c.orig 2002-08-07 08:23:01.000000000 -0700
+--- ../mp/mp_fget.c 2006-05-30 20:32:20.000000000 -0700
+***************
+*** 506,513 ****
+ */
+ if (state != SECOND_MISS && bhp->ref == 1) {
+ bhp->priority = UINT32_T_MAX;
+! SH_TAILQ_REMOVE(&hp->hash_bucket, bhp, hq, __bh);
+! SH_TAILQ_INSERT_TAIL(&hp->hash_bucket, bhp, hq);
+ hp->hash_priority =
+ SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;
+ }
+--- 506,517 ----
+ */
+ if (state != SECOND_MISS && bhp->ref == 1) {
+ bhp->priority = UINT32_T_MAX;
+! /* Move the buffer if there are others in the bucket. */
+! if (SH_TAILQ_FIRST(&hp->hash_bucket, __bh) != bhp
+! || SH_TAILQ_NEXT(bhp, hq, __bh) != NULL) {
+! SH_TAILQ_REMOVE(&hp->hash_bucket, bhp, hq, __bh);
+! SH_TAILQ_INSERT_TAIL(&hp->hash_bucket, bhp, hq);
+! }
+ hp->hash_priority =
+ SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;
+ }
+*** ../mp/mp_fput.c.orig 2002-08-13 06:26:41.000000000 -0700
+--- ../mp/mp_fput.c 2006-05-30 20:55:11.000000000 -0700
+***************
+*** 166,171 ****
+--- 166,176 ----
+ * to the correct position in the list.
+ */
+ argbhp = bhp;
++ /* Move the buffer if there are others in the bucket. */
++ if (SH_TAILQ_FIRST(&hp->hash_bucket, __bh) == bhp
++ && SH_TAILQ_NEXT(bhp, hq, __bh) != NULL)
++ goto done;
++
+ SH_TAILQ_REMOVE(&hp->hash_bucket, argbhp, hq, __bh);
+
+ prev = NULL;
+***************
+*** 178,183 ****
+--- 183,189 ----
+ else
+ SH_TAILQ_INSERT_AFTER(&hp->hash_bucket, prev, argbhp, hq, __bh);
+
++ done:
+ /* Reset the hash bucket's priority. */
+ hp->hash_priority = SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;