aboutsummaryrefslogtreecommitdiff
path: root/databases/db48
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-06-06 18:56:28 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-06-06 18:56:28 +0000
commitdb4e6b5f816484cc0d8ae3d27887362ccf06f32a (patch)
tree4eebf09eaadd310ab2d42065006c10a9311df589 /databases/db48
parent58b9a5fa40cde4c64212c4d118277bec900acfd5 (diff)
downloadports-db4e6b5f816484cc0d8ae3d27887362ccf06f32a.tar.gz
ports-db4e6b5f816484cc0d8ae3d27887362ccf06f32a.zip
Fix stage-qa warnings
Remove trailing blank from MASTER_SITES Tabs to spaces in pkg-descr WWW: tag Rename patch to avoid special characters. Add LICENSE_FILE, USES=libtool:keepla Patch libtool install runs to use ${INSTALL} instead of cp -p Bump PORTREVISION (adding .so.0.0.0 files). PR: 189491 Submitted by: takefu@airport.fm Approved by: gslin@gslin.org (implicit)
Notes
Notes: svn path=/head/; revision=356832
Diffstat (limited to 'databases/db48')
-rw-r--r--databases/db48/Makefile13
-rw-r--r--databases/db48/files/patch-dist__configure (renamed from databases/db48/files/patch-dist::configure)0
-rw-r--r--databases/db48/pkg-descr2
-rw-r--r--databases/db48/pkg-plist2
4 files changed, 13 insertions, 4 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index cd8ce4345898..da7c2dd0d82c 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -3,17 +3,20 @@
PORTNAME= db48
PORTVERSION= 4.8.30.0
+PORTREVISION= 1
CATEGORIES= databases
-MASTER_SITES= http://download.oracle.com/berkeley-db/
+MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
DISTNAME= db-${PORTVERSION:R}
DIST_SUBDIR= bdb
MAINTAINER= gslin@gslin.org
-COMMENT= The Berkeley DB package, revision 4.8
-
# I allow all freebsd committer to do changes to this package without
# my permission.
+COMMENT= The Berkeley DB package, revision 4.8
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE
BDBVER= ${PORTVERSION:R:R}
CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
@@ -21,12 +24,16 @@ CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
--libdir=${PREFIX}/lib/${PORTNAME} \
--bindir=${PREFIX}/bin/${PORTNAME}
CONFIGURE_SCRIPT= ../dist/configure
+USES= libtool:keepla
GNU_CONFIGURE= yes
INSTALL_TARGET= install_include install_lib install_utilities
LIBTOOLFILES= ${CONFIGURE_SCRIPT}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_LDCONFIG= yes
+post-patch:
+ ${REINPLACE_CMD} -Ee 's|--mode=install cp -p|--mode=install ${INSTALL} -s|;' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
.for i in libdb libdb_cxx
${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${STAGEDIR}${PREFIX}/lib
diff --git a/databases/db48/files/patch-dist::configure b/databases/db48/files/patch-dist__configure
index 2dac99fc909d..2dac99fc909d 100644
--- a/databases/db48/files/patch-dist::configure
+++ b/databases/db48/files/patch-dist__configure
diff --git a/databases/db48/pkg-descr b/databases/db48/pkg-descr
index 171a54c0e062..73d50d96a37a 100644
--- a/databases/db48/pkg-descr
+++ b/databases/db48/pkg-descr
@@ -8,4 +8,4 @@ administration. As a developer, you can focus on your application and
be confident that Oracle Berkeley DB will manage your persistence
needs.
-WWW: http://www.oracle.com/us/products/database/berkeley-db/db/
+WWW: http://www.oracle.com/us/products/database/berkeley-db/db/
diff --git a/databases/db48/pkg-plist b/databases/db48/pkg-plist
index 501b0160d4d0..1ccdb229b667 100644
--- a/databases/db48/pkg-plist
+++ b/databases/db48/pkg-plist
@@ -31,6 +31,7 @@ lib/db48/libdb-4.8.a
lib/db48/libdb-4.8.la
lib/db48/libdb-4.8.so
lib/db48/libdb-4.8.so.0
+lib/db48/libdb-4.8.so.0.0.0
lib/db48/libdb-4.so
lib/db48/libdb.a
lib/db48/libdb.so
@@ -38,6 +39,7 @@ lib/db48/libdb_cxx-4.8.a
lib/db48/libdb_cxx-4.8.la
lib/db48/libdb_cxx-4.8.so
lib/db48/libdb_cxx-4.8.so.0
+lib/db48/libdb_cxx-4.8.so.0.0.0
lib/db48/libdb_cxx-4.so
lib/db48/libdb_cxx.a
lib/db48/libdb_cxx.so