aboutsummaryrefslogtreecommitdiff
path: root/databases/dbconnect/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-21 17:43:46 +0000
commit14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3 (patch)
tree761cd23e07e2b5224d73f540985d84eede599029 /databases/dbconnect/Makefile
parent7ef963090c1ba3fae0e4ab7630e60ff49fe6a9f0 (diff)
downloadports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.tar.gz
ports-14bc5a6c1142609693b3dcef0cd7e6a4b4755cb3.zip
Notes
Diffstat (limited to 'databases/dbconnect/Makefile')
-rw-r--r--databases/dbconnect/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/databases/dbconnect/Makefile b/databases/dbconnect/Makefile
index 694407447b2f..d860c7b4d8b6 100644
--- a/databases/dbconnect/Makefile
+++ b/databases/dbconnect/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: dbconnect
-# Date created: Jul 23, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= dbconnect
PORTVERSION= 0.3.5
@@ -23,14 +18,14 @@ USE_LDCONFIG= yes
CXXFLAGS+= ${PTHREAD_CFLAGS} -fPIC -DFREEBSD
LDFLAG+= ${PTHREAD_LIBS}
-OPTIONS= MYSQL "With MySQL driver" on \
- PGSQL "With PostgreSQL driver" off
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-.if !defined(WITHOUT_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= YES
CONFIGURE_ARGS+= --enable-mysql=yes \
--with-mysql_include=${LOCALBASE}/include/mysql \
@@ -40,7 +35,7 @@ PLIST_SUB+= MYSQL=""
PLIST_SUB+= MYSQL="@comment "
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-pgsql=yes \
--with-pgsql_include=${LOCALBASE}/include \
@@ -65,4 +60,4 @@ do-install:
$${libname}.so); \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>