aboutsummaryrefslogtreecommitdiff
path: root/databases/dbdesigner
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-18 21:29:51 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-18 21:29:51 +0000
commit15ea9efb38d4d12eb44a69f6aee394eac0325e72 (patch)
tree12e475f7512715a37365ea5eadee51c2545625d4 /databases/dbdesigner
parent704ef6b8f8d8406a85a45bf6988ce35fa915bc5d (diff)
downloadports-15ea9efb38d4d12eb44a69f6aee394eac0325e72.tar.gz
ports-15ea9efb38d4d12eb44a69f6aee394eac0325e72.zip
Notes
Diffstat (limited to 'databases/dbdesigner')
-rw-r--r--databases/dbdesigner/Makefile37
-rw-r--r--databases/dbdesigner/distinfo1
-rw-r--r--databases/dbdesigner/files/patch-dbdesign-Makefile.in14
-rw-r--r--databases/dbdesigner/files/patch-dbdesign-dbdesign.cpp12
-rw-r--r--databases/dbdesigner/files/patch-dbdesign-dbdesign.h11
-rw-r--r--databases/dbdesigner/pkg-comment1
-rw-r--r--databases/dbdesigner/pkg-descr18
-rw-r--r--databases/dbdesigner/pkg-plist20
8 files changed, 114 insertions, 0 deletions
diff --git a/databases/dbdesigner/Makefile b/databases/dbdesigner/Makefile
new file mode 100644
index 000000000000..45bbe3736db9
--- /dev/null
+++ b/databases/dbdesigner/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: dbdesigner
+# Date created: 18 May 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbdesigner
+PORTVERSION= 0.p2
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-p2
+
+MAINTAINER= anders@FreeBSD.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_KDELIBS_VER=2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DOCS= AUTHORS BUGS COPYING ChangeLog TODO
+
+pre-configure:
+ ${PERL} -pi -e "s@#define KDEDIR.*@#define KDEDIR \"${LOCALBASE}\"@" \
+ ${WRKSRC}/dbdesign/dbdesign.h
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/dbdesigner/distinfo b/databases/dbdesigner/distinfo
new file mode 100644
index 000000000000..87d39be793b8
--- /dev/null
+++ b/databases/dbdesigner/distinfo
@@ -0,0 +1 @@
+MD5 (dbdesigner-p2.tar.gz) = 5e27f2ea47c590780650211b175dcf93
diff --git a/databases/dbdesigner/files/patch-dbdesign-Makefile.in b/databases/dbdesigner/files/patch-dbdesign-Makefile.in
new file mode 100644
index 000000000000..63fae8b63816
--- /dev/null
+++ b/databases/dbdesigner/files/patch-dbdesign-Makefile.in
@@ -0,0 +1,14 @@
+--- dbdesign/Makefile.in.orig Wed Jun 13 22:44:04 2001
++++ dbdesign/Makefile.in Sat May 18 18:05:43 2002
+@@ -740,7 +742,10 @@
+ echo '#include "metaseqedit.moc"' >> metaseqedit.cpp
+
+ metaseqedit.h: $(srcdir)/metaseqedit.ui
+- $(UIC) -o metaseqedit.h $(srcdir)/metaseqedit.ui
++ $(UIC) -o metaseqedittemp.h $(srcdir)/metaseqedit.ui
++ echo '#include <knuminput.h>' > metaseqedit.h
++ cat metaseqedittemp.h >> metaseqedit.h
++ rm -f metaseqedittemp.h
+
+ metaseqedit.moc: metaseqedit.h
+ $(MOC) metaseqedit.h -o metaseqedit.moc
diff --git a/databases/dbdesigner/files/patch-dbdesign-dbdesign.cpp b/databases/dbdesigner/files/patch-dbdesign-dbdesign.cpp
new file mode 100644
index 000000000000..138f59fc76eb
--- /dev/null
+++ b/databases/dbdesigner/files/patch-dbdesign-dbdesign.cpp
@@ -0,0 +1,12 @@
+--- dbdesign/dbdesign.cpp.orig Wed Jun 13 22:27:17 2001
++++ dbdesign/dbdesign.cpp Sat May 18 17:02:04 2002
+@@ -270,7 +270,8 @@
+ */
+
+ int DbDesign::refreshPlugins(){
+- QString path = QString(getenv("KDEDIR")) + "/" + KStandardDirs::kde_default("data") + "/dbdesign/plugins/";
++ QString kdeprefix = QString(KDEDIR);
++ QString path = kdeprefix + "/" + KStandardDirs::kde_default("data") + "/dbdesign/plugins/";
+ QDir pldir(path, "*plug.so", QDir::IgnoreCase | QDir::Name, QDir::Files);
+ bool foundstd = false;
+ void* h;
diff --git a/databases/dbdesigner/files/patch-dbdesign-dbdesign.h b/databases/dbdesigner/files/patch-dbdesign-dbdesign.h
new file mode 100644
index 000000000000..bc61cfcd53db
--- /dev/null
+++ b/databases/dbdesigner/files/patch-dbdesign-dbdesign.h
@@ -0,0 +1,11 @@
+--- dbdesign/dbdesign.h.orig Wed Jun 13 22:27:17 2001
++++ dbdesign/dbdesign.h Sat May 18 16:07:25 2002
+@@ -18,6 +18,8 @@
+ #ifndef DBDESIGN_H
+ #define DBDESIGN_H
+
++#define KDEDIR "/usr/local"
++
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
diff --git a/databases/dbdesigner/pkg-comment b/databases/dbdesigner/pkg-comment
new file mode 100644
index 000000000000..8a345af834ff
--- /dev/null
+++ b/databases/dbdesigner/pkg-comment
@@ -0,0 +1 @@
+A visual database design tool
diff --git a/databases/dbdesigner/pkg-descr b/databases/dbdesigner/pkg-descr
new file mode 100644
index 000000000000..2aa95e44f021
--- /dev/null
+++ b/databases/dbdesigner/pkg-descr
@@ -0,0 +1,18 @@
+If you need to build complex SQL databases you will find DbDesigner quite a
+useful tool. It allows you to construct your DB in an intuitive and easy to use
+environment, where you have a visual representation of the tables and relations
+contained in your project. You can quickly see the fields in a table or how
+each table relates to the others. After you are finished, DbDesigner can export
+the schema of the database into an .sql script, or directly connect to a
+database backend and build it there. It can also import already existing
+databases from .sql scripts or db backends. Of course, it can save your project
+into its native format (XML) so all information is kept (for example you can't
+save the positions of the tables in the workspace into an .sql script). Due to
+its plugin architecture, DbDesigner is easily extensible to work with many
+database servers. By default it comes with 2 plugins: one for PostgreSQL and
+the other for MySQL. On the other hand, if you are building complex databases
+you might have already seen products like this one.
+
+WWW: http://dbdesigner.sourceforge.net/
+
+- Anders Nordby <anders@FreeBSD.org>
diff --git a/databases/dbdesigner/pkg-plist b/databases/dbdesigner/pkg-plist
new file mode 100644
index 000000000000..69002fbdb275
--- /dev/null
+++ b/databases/dbdesigner/pkg-plist
@@ -0,0 +1,20 @@
+bin/dbdesign
+share/applnk/Applications/dbdesign.desktop
+share/apps/dbdesign/dbdesignui.rc
+share/apps/dbdesign/plugins/libmysqlplug.la
+share/apps/dbdesign/plugins/libmysqlplug.so
+share/apps/dbdesign/plugins/libmysqlplug.so.1
+share/apps/dbdesign/plugins/libnullplug.la
+share/apps/dbdesign/plugins/libnullplug.so
+share/apps/dbdesign/plugins/libnullplug.so.1
+share/apps/dbdesign/plugins/libpgsqlplug.la
+share/apps/dbdesign/plugins/libpgsqlplug.so
+share/apps/dbdesign/plugins/libpgsqlplug.so.1
+@dirrm share/apps/dbdesign/plugins
+@dirrm share/apps/dbdesign
+%%PORTDOCS%%share/doc/dbdesigner/AUTHORS
+%%PORTDOCS%%share/doc/dbdesigner/BUGS
+%%PORTDOCS%%share/doc/dbdesigner/COPYING
+%%PORTDOCS%%share/doc/dbdesigner/ChangeLog
+%%PORTDOCS%%share/doc/dbdesigner/TODO
+%%PORTDOCS%%@dirrm share/doc/dbdesigner