aboutsummaryrefslogtreecommitdiff
path: root/databases/dbh10/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2003-03-28 09:46:52 +0000
committerKevin Lo <kevlo@FreeBSD.org>2003-03-28 09:46:52 +0000
commit8f2801ea957f6ea57a93654810f0e142690da54b (patch)
tree91fe0d54849db022a8cf9c606b742ff4072b5ee7 /databases/dbh10/Makefile
parent96d08dc66c57524cd25ef4d2433e5af3c28425f6 (diff)
downloadports-8f2801ea957f6ea57a93654810f0e142690da54b.tar.gz
ports-8f2801ea957f6ea57a93654810f0e142690da54b.zip
Notes
Diffstat (limited to 'databases/dbh10/Makefile')
-rw-r--r--databases/dbh10/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/databases/dbh10/Makefile b/databases/dbh10/Makefile
index 90c4aa386d43..1c9bdc9f9b3f 100644
--- a/databases/dbh10/Makefile
+++ b/databases/dbh10/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= dbh
-PORTVERSION= 1.0.11
-PORTREVISION= 1
+PORTVERSION= 1.0.14
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +17,17 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Disk Based Hashtables
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libdir[)]/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>