aboutsummaryrefslogtreecommitdiff
path: root/databases/dbh
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-08-21 00:28:52 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-08-21 00:28:52 +0000
commit3e5c3fadd5fa236336bc523e2907c54e1aca10fc (patch)
treeab2ebe96515dbc0d61cc94d157aa78858cd10ded /databases/dbh
parent09d3135796f55a6141c49352dd9574e25a730a75 (diff)
downloadports-3e5c3fadd5fa236336bc523e2907c54e1aca10fc.tar.gz
ports-3e5c3fadd5fa236336bc523e2907c54e1aca10fc.zip
Notes
Diffstat (limited to 'databases/dbh')
-rw-r--r--databases/dbh/Makefile44
-rw-r--r--databases/dbh/distinfo6
-rw-r--r--databases/dbh/files/patch-ltmain.sh12
-rw-r--r--databases/dbh/pkg-plist28
4 files changed, 72 insertions, 18 deletions
diff --git a/databases/dbh/Makefile b/databases/dbh/Makefile
index 1984d721528e..64e99d322ee8 100644
--- a/databases/dbh/Makefile
+++ b/databases/dbh/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= dbh
-PORTVERSION= 4.5.0
-PORTREVISION= 0
+PORTVERSION= 4.6.0
CATEGORIES= databases
-MASTER_SITES= SF
+MASTER_SITES= http://svn.foo-projects.org/svn/xffm/RELEASES/tarballs/ \
+ SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= frederic@culot.org
COMMENT= Disk Based Hashtables
CONFLICTS= dbh-[0-3]*
@@ -21,4 +21,40 @@ USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAN1= dbh.1 dbh.h.1
+MAN3= dbh_close.3 dbh_create.3 dbh_destroy.3 dbh_erase.3 \
+ dbh_exit_fanout.3 dbh_exit_sweep.3 dbh_fanout.3 dbh_find.3 \
+ dbh_foreach_fanout.3 dbh_foreach_sweep.3 dbh_genkey.3 \
+ dbh_genkey2.3 dbh_load.3 dbh_load_address.3 \
+ dbh_load_child.3 dbh_load_parent.3 dbh_macros.3 \
+ dbh_open.3 dbh_open_ro.3 dbh_orderkey.3 dbh_prune.3 \
+ dbh_regen_fanout.3 dbh_regen_sweep.3 dbh_set_data.3 \
+ dbh_set_key.3 dbh_set_recordsize.3 dbh_set_size.3 \
+ dbh_settempdir.3 dbh_sweep.3 dbh_unerase.3 \
+ dbh_unprune.3 dbh_update.3 dbh_writeheader.3
+
+OPTIONS= GTKDOC "Enable GTK html documentation" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GTKDOC)
+CONFIGURE_ARGS+= --enable-gtk-doc-html
+PLIST_SUB= GTKDOC=""
+.else
+CONFIGURE_ARGS+= --disable-gtk-doc-html
+PLIST_SUB= GTKDOC="@comment "
+.endif
+
+post-patch:
+# Needed to remove gtk-doc installation.
+.if !defined(WITH_GTKDOC)
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS = src man\).*|\1|' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} '*.c' ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/dbh/distinfo b/databases/dbh/distinfo
index 2347307e67ae..751e7994a209 100644
--- a/databases/dbh/distinfo
+++ b/databases/dbh/distinfo
@@ -1,3 +1,3 @@
-MD5 (dbh-4.5.0.tar.gz) = 52b4b0d5ee0513dc796e989220c11bc6
-SHA256 (dbh-4.5.0.tar.gz) = 85c5a90b83032f7eddaebb445b38c6dfc0ae5cc202be8028bd0b554bd0b567bb
-SIZE (dbh-4.5.0.tar.gz) = 365506
+MD5 (dbh-4.6.0.tar.gz) = db086eea7a2690a816613a5f7c7b671a
+SHA256 (dbh-4.6.0.tar.gz) = d2269e8d98aeaf8e196b502592f78c1748f556dac90abdbb36cd1e2748617c2f
+SIZE (dbh-4.6.0.tar.gz) = 414337
diff --git a/databases/dbh/files/patch-ltmain.sh b/databases/dbh/files/patch-ltmain.sh
index 5fa6b3314380..246ab504a085 100644
--- a/databases/dbh/files/patch-ltmain.sh
+++ b/databases/dbh/files/patch-ltmain.sh
@@ -1,14 +1,14 @@
---- ltmain.sh.orig Tue Oct 31 11:13:51 2006
-+++ ltmain.sh Tue Oct 31 11:14:02 2006
-@@ -6103,10 +6103,12 @@
+--- ltmain.sh.orig 2010-08-20 10:37:34.875162866 +0200
++++ ltmain.sh 2010-08-20 10:38:15.964421976 +0200
+@@ -2077,10 +2077,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ func_basename "$file"
+ name="$func_basename_result"
instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
+ func_show_eval "$install_prog $instname $destdir/$name" 'exit $?'
+ fi
# Maybe install the static library, too.
diff --git a/databases/dbh/pkg-plist b/databases/dbh/pkg-plist
index 081deee34e69..9b03278d675e 100644
--- a/databases/dbh/pkg-plist
+++ b/databases/dbh/pkg-plist
@@ -1,9 +1,27 @@
@comment $FreeBSD$
-include/dbh.h
-include/dbh_config.h
-include/dbh_functions.h
-lib/libdbh-4.5.so
-lib/libdbh-4.5.so.4
+include/dbh/dbh.h
+lib/libdbh-2.so
+lib/libdbh-2.so.1
lib/libdbh.a
lib/libdbh.so
libdata/pkgconfig/dbh.pc
+%%GTKDOC%%share/gtk-doc/html/dbh/DBH.html
+%%GTKDOC%%share/gtk-doc/html/dbh/Makefile.am
+%%GTKDOC%%share/gtk-doc/html/dbh/calc.png
+%%GTKDOC%%share/gtk-doc/html/dbh/ch01.html
+%%GTKDOC%%share/gtk-doc/html/dbh/dbh.devhelp
+%%GTKDOC%%share/gtk-doc/html/dbh/dbh.devhelp2
+%%GTKDOC%%share/gtk-doc/html/dbh/home.png
+%%GTKDOC%%share/gtk-doc/html/dbh/index.html
+%%GTKDOC%%share/gtk-doc/html/dbh/index.sgml
+%%GTKDOC%%share/gtk-doc/html/dbh/left.png
+%%GTKDOC%%share/gtk-doc/html/dbh/right.png
+%%GTKDOC%%share/gtk-doc/html/dbh/style.css
+%%GTKDOC%%share/gtk-doc/html/dbh/up.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/filesystem.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_hash.c
+%%GTKDOC%%@dirrm share/gtk-doc/html/dbh
+%%GTKDOC%%@dirrmtry share/gtk-doc/html
+%%GTKDOC%%@dirrmtry share/gtk-doc
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm include/dbh