aboutsummaryrefslogtreecommitdiff
path: root/databases/dbtool
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2015-04-14 20:21:24 +0000
committerMikhail Teterin <mi@FreeBSD.org>2015-04-14 20:21:24 +0000
commitb42b1458a87ffa5014ca3ced5554fb379ef12cd1 (patch)
treeb160752973693f65e1a8df31f98e99f35af23344 /databases/dbtool
parent85d317948539aece08a1ca19bd638a3cea564302 (diff)
downloadports-b42b1458a87ffa5014ca3ced5554fb379ef12cd1.tar.gz
ports-b42b1458a87ffa5014ca3ced5554fb379ef12cd1.zip
Notes
Diffstat (limited to 'databases/dbtool')
-rw-r--r--databases/dbtool/Makefile30
-rw-r--r--databases/dbtool/distinfo4
2 files changed, 13 insertions, 21 deletions
diff --git a/databases/dbtool/Makefile b/databases/dbtool/Makefile
index 20b9fa48564f..06c2ca386c31 100644
--- a/databases/dbtool/Makefile
+++ b/databases/dbtool/Makefile
@@ -2,22 +2,21 @@
# $FreeBSD$
PORTNAME= dbtool
-PORTVERSION= 1.7
-PORTREVISION= 5
+PORTVERSION= 1.8
CATEGORIES= databases
MASTER_SITES= http://www.daemon.de/idisk/Apps/dbtool/
MAINTAINER= ports@FreeBSD.org
COMMENT= Store and retrieve data in a key/value format in a hash database
+LICENSE= GPLv2
+
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
OPTIONS_DEFINE= BDB EXAMPLES
EXAMPLES_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-LICENSE= GPLv2
-
GNU_CONFIGURE= yes
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -27,6 +26,7 @@ REINPLACE_ARGS= -i ""
SH2BASH= samples/account-db/accdb
UB2PFX= samples/locate/locate samples/locate/updatedb
+EXTRACT_AFTER_ARGS+= --no-same-permissions --no-same-owner --exclude '*~'
.include <bsd.port.options.mk>
@@ -41,23 +41,15 @@ CONFIGURE_ARGS+= --without-berkeley
.endif
post-patch:
- ${REINPLACE_CMD} -e 's,==,=,g' ${WRKSRC}/configure
-.for file in dbtool.cc engine.cc engine.h
- ${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/${file}
-.endfor
+ ${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/dbtool.cc ${WRKSRC}/engine.cc ${WRKSRC}/engine.h
.if ${PORT_OPTIONS:MEXAMPLES}
-.for file in ${SH2BASH}
- ${REINPLACE_CMD} -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ${WRKSRC}/${file}
-.endfor
-.for file in ${UB2PFX}
- ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/${file}
- @${RM} ${WRKSRC}/${file}.orig
- @${RM} ${WRKSRC}/${file}~
-.endfor
-.endif
+ ${REINPLACE_CMD} -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ${SH2BASH:S|^|${WRKSRC}/|}
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${UB2PFX:S|^|${WRKSRC}/|}
+ ${RM} ${UB2PFX:C|.*|${WRKSRC}/&.orig|}
post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${CP} -Rp ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
+ #@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/databases/dbtool/distinfo b/databases/dbtool/distinfo
index 284e9d647667..aaf85aafec17 100644
--- a/databases/dbtool/distinfo
+++ b/databases/dbtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dbtool-1.7.tar.gz) = 90e813b57f4d5f3714c3c54c95982b3fc9c1f6b011cade19e101045eb3f1e7a9
-SIZE (dbtool-1.7.tar.gz) = 124794
+SHA256 (dbtool-1.8.tar.gz) = a66e1150cce006daecedd9a592efe75fa19c642addad97ec117f1a2219c4f079
+SIZE (dbtool-1.8.tar.gz) = 133262