aboutsummaryrefslogtreecommitdiff
path: root/databases/dbtool
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-10-16 19:09:52 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-10-16 19:09:52 +0000
commit84e539d876e4bc379cb7bbc8f4d356c351d6d6f0 (patch)
tree86646bbd1d5033880e63a8c6ad2d388ff3402d49 /databases/dbtool
parentf880925a412d78dffe891a1028fc61349025e98a (diff)
downloadports-84e539d876e4bc379cb7bbc8f4d356c351d6d6f0.tar.gz
ports-84e539d876e4bc379cb7bbc8f4d356c351d6d6f0.zip
Notes
Diffstat (limited to 'databases/dbtool')
-rw-r--r--databases/dbtool/Makefile59
-rw-r--r--databases/dbtool/distinfo4
-rw-r--r--databases/dbtool/files/patch-samples_locate_locate16
-rw-r--r--databases/dbtool/files/patch-samples_locate_updatedb16
-rw-r--r--databases/dbtool/pkg-plist9
5 files changed, 30 insertions, 74 deletions
diff --git a/databases/dbtool/Makefile b/databases/dbtool/Makefile
index 06c2ca386c31..639381849915 100644
--- a/databases/dbtool/Makefile
+++ b/databases/dbtool/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dbtool
-PORTVERSION= 1.8
+PORTVERSION= 1.9.1
CATEGORIES= databases
MASTER_SITES= http://www.daemon.de/idisk/Apps/dbtool/
@@ -10,46 +10,43 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Store and retrieve data in a key/value format in a hash database
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-OPTIONS_DEFINE= BDB EXAMPLES
-
-EXAMPLES_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-
+USES= gmake shebangfix
+SHEBANG_FILES= samples/account-db/accdb
+bash_OLD_CMD= /bin/sh
GNU_CONFIGURE= yes
-CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-USES= gmake
-REINPLACE_ARGS= -i ""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-SH2BASH= samples/account-db/accdb
-UB2PFX= samples/locate/locate samples/locate/updatedb
-EXTRACT_AFTER_ARGS+= --no-same-permissions --no-same-owner --exclude '*~'
+PORTEXAMPLES= *
+PLIST_FILES= bin/dbtool man/man1/dbtool.1.gz
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= EXAMPLES
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= BDB GDBM
+OPTIONS_DEFAULT= GDBM
-.if ${PORT_OPTIONS:MBDB}
-USE_BDB= 48+
-CPPFLAGS+= -I${BDB_INCLUDE_DIR}
-LIBS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
-CONFIGURE_ARGS+= --with-berkeley
-.else
-LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
-CONFIGURE_ARGS+= --without-berkeley
-.endif
+BACKEND_DESC= Database backend
+BDB_USE= bdb=yes
+BDB_CONFIGURE_ON= --with-berkeley \
+ --with-bdb-include-dir=${BDB_INCLUDE_DIR} \
+ --with-bdb-lib-dir=${BDB_LIB_DIR}
+EXAMPLES_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+GDBM_LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
+GDBM_CONFIGURE_ON= --with-gdbm \
+ --with-gdbm-dir=${LOCALBASE}
post-patch:
- ${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/dbtool.cc ${WRKSRC}/engine.cc ${WRKSRC}/engine.h
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${REINPLACE_CMD} -e "s|/bin/sh|${LOCALBASE}/bin/bash|" ${SH2BASH:S|^|${WRKSRC}/|}
- ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${UB2PFX:S|^|${WRKSRC}/|}
- ${RM} ${UB2PFX:C|.*|${WRKSRC}/&.orig|}
-
-post-install:
- #@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${REINPLACE_CMD} -e \
+ '/try_libs=/s|"-ldb_cxx.*"|"-ldb_cxx"| ; \
+ /try_headers=/s|"db.*"|"db_cxx.h"|' ${WRKSRC}/configure
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/databases/dbtool/distinfo b/databases/dbtool/distinfo
index aaf85aafec17..95eeb28e2660 100644
--- a/databases/dbtool/distinfo
+++ b/databases/dbtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dbtool-1.8.tar.gz) = a66e1150cce006daecedd9a592efe75fa19c642addad97ec117f1a2219c4f079
-SIZE (dbtool-1.8.tar.gz) = 133262
+SHA256 (dbtool-1.9.1.tar.gz) = afd3fa03d4b69f25c689817dc1b6ac452eb16ed4b9712c20695b3b4d13a5e647
+SIZE (dbtool-1.9.1.tar.gz) = 965751
diff --git a/databases/dbtool/files/patch-samples_locate_locate b/databases/dbtool/files/patch-samples_locate_locate
deleted file mode 100644
index 159506e8502f..000000000000
--- a/databases/dbtool/files/patch-samples_locate_locate
+++ /dev/null
@@ -1,16 +0,0 @@
---- samples/locate/locate.orig Sat Apr 20 17:14:18 2002
-+++ samples/locate/locate Sun Mar 23 12:25:01 2003
-@@ -12,10 +12,10 @@
- #
- # $Id: locate,v 1.3 2001/06/26 23:00:02 scip Exp $
-
--dbtool="/usr/bin/dbtool";
-+dbtool="%%PREFIX%%/bin/dbtool";
- find="/usr/bin/find";
--db="/var/local/locate.db";
--sort="/bin/sort";
-+db="/var/db/locate.db";
-+sort="/usr/bin/sort";
- regex=$1;
-
- if [ "x$regex" != "x" ]; then
diff --git a/databases/dbtool/files/patch-samples_locate_updatedb b/databases/dbtool/files/patch-samples_locate_updatedb
deleted file mode 100644
index 5d9efbc15b47..000000000000
--- a/databases/dbtool/files/patch-samples_locate_updatedb
+++ /dev/null
@@ -1,16 +0,0 @@
---- samples/locate/updatedb.orig Sat Apr 20 17:14:18 2002
-+++ samples/locate/updatedb Sun Mar 23 12:24:47 2003
-@@ -11,10 +11,10 @@
- # $Id: updatedb,v 1.2 2001/06/26 23:00:02 scip Exp $
- #
-
--dbtool="/usr/bin/dbtool";
-+dbtool="%%PREFIX%%/bin/dbtool";
- find="/usr/bin/find";
--db="/var/local/locate.db";
--egrep="/bin/egrep";
-+db="/var/db/locate.db";
-+egrep="/usr/bin/egrep";
- cp="/bin/cp"
-
- $cp /dev/null $db;
diff --git a/databases/dbtool/pkg-plist b/databases/dbtool/pkg-plist
deleted file mode 100644
index f450d419deba..000000000000
--- a/databases/dbtool/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/dbtool
-man/man1/dbtool.1.gz
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/account-db/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/account-db/accdb
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/locate/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/locate/locate
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/locate/updatedb
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uback/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README