aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /databases/evolution-data-server/Makefile
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Notes
Diffstat (limited to 'databases/evolution-data-server/Makefile')
-rw-r--r--databases/evolution-data-server/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index e1b229ce08ba..1c90f48bbc35 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/databases/evolution-data-server/Makefile,v 1.164 2009/01/10 01:59:21 mezz Exp $
+# $MCom: ports/databases/evolution-data-server/Makefile,v 1.168 2009/03/17 13:17:16 kwm Exp $
#
PORTNAME= evolution-data-server
-PORTVERSION= 2.24.5
+PORTVERSION= 2.26.0
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,6 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= The data backends for the Evolution integrated mail/PIM suite
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ ical.43:${PORTSDIR}/devel/libical \
nss3.1:${PORTSDIR}/security/nss \
tasn1.4:${PORTSDIR}/security/libtasn1 \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
@@ -39,9 +40,10 @@ CONFIGURE_ARGS= --enable-static \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-PLIST_SUB= VERSION="2.24" EVO_VERSION="1.2"
+PLIST_SUB= VERSION="2.26" EVO_VERSION="1.2"
#OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
+OPTIONS= WEATHER "Enable weather calendar backend" on
.include <bsd.port.pre.mk>
@@ -49,7 +51,6 @@ PLIST_SUB= VERSION="2.24" EVO_VERSION="1.2"
HEIMDAL_HOME?= ${LOCALBASE}
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --with-krb5-includes=${HEIMDAL_HOME}/include
-KRB5_LIB= `${HEIMDAL_HOME}/bin/krb5-config gssapi --libs`
.elif !defined(NO_KERBEROS)
CONFIGURE_ARGS+= --with-krb5=/usr
KRB5_LIB= `/usr/bin/krb5-config gssapi --libs`
@@ -62,6 +63,15 @@ KRB5_LIB= `/usr/bin/krb5-config gssapi --libs`
PLIST_SUB+= IMAP4="@comment "
#.endif
+.if defined(WITH_WEATHER)
+LIB_DEPENDS+= gweather.1:${PORTSDIR}/net/libgweather
+CONFIGURE_ARGS+= --with-weather
+PLIST_SUB+= WEATHER=""
+.else
+CONFIGURE_ARGS+= --without-weather
+PLIST_SUB+= WEATHER="@comment "
+.endif
+
EDS_BDB_MSG= "!!!WARNING!!!: Berkeley Database version is ${BDB_VER}. If this is an upgrade, you may experience problems if you or any other Evolution-data-server users were previously using BDB_VER 41."
pre-everything::