aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /databases/evolution-data-server/files
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'databases/evolution-data-server/files')
-rw-r--r--databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c17
-rw-r--r--databases/evolution-data-server/files/patch-addressbook_backends_groupwise_e-book-backend-groupwise.c47
-rw-r--r--databases/evolution-data-server/files/patch-addressbook_backends_ldap_e-book-backend-ldap.c52
-rw-r--r--databases/evolution-data-server/files/patch-calendar_backends_groupwise_e-cal-backend-groupwise.c16
-rw-r--r--databases/evolution-data-server/files/patch-camel-groupwise-folder.c30
-rw-r--r--databases/evolution-data-server/files/patch-camel-groupwise-utils.c25
-rw-r--r--databases/evolution-data-server/files/patch-camel_Makefile.in11
-rw-r--r--databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c20
-rw-r--r--databases/evolution-data-server/files/patch-configure15
-rw-r--r--databases/evolution-data-server/files/patch-libedataserverui_e-name-selector-entry.c11
-rw-r--r--databases/evolution-data-server/files/patch-servers-exchange-storage-e-folder-exchange.c17
-rw-r--r--databases/evolution-data-server/files/patch-servers-groupwise-e-gw-connection.c12
-rw-r--r--databases/evolution-data-server/files/patch-servers-groupwise-e-gw-item.c12
13 files changed, 17 insertions, 268 deletions
diff --git a/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c b/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c
index 7383f939f4cd..b39a8fe3cc88 100644
--- a/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c
+++ b/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c
@@ -1,6 +1,6 @@
---- libedataserver/e-msgport.c.orig Thu Dec 2 22:33:06 2004
-+++ libedataserver/e-msgport.c Wed Mar 9 14:31:46 2005
-@@ -921,9 +921,18 @@
+--- libedataserver/e-msgport.c.orig Sat Dec 10 07:31:28 2005
++++ libedataserver/e-msgport.c Mon Dec 19 02:19:10 2005
+@@ -1069,9 +1069,18 @@ thread_dispatch(void *din)
void e_thread_put(EThread *e, EMsg *msg)
{
pthread_t id;
@@ -19,14 +19,14 @@
/* the caller forgot to tell us what to do, well, we can't do anything can we */
if (e->received == NULL) {
-@@ -962,13 +971,14 @@
+@@ -1110,13 +1119,14 @@ void e_thread_put(EThread *e, EMsg *msg)
e_msgport_put(e->server_port, msg);
if (e->waiting == 0
&& g_list_length(e->id_list) < e->queue_limit
- && pthread_create(&id, NULL, thread_dispatch, e) == 0) {
+ && pthread_create(&id, &attr, thread_dispatch, e) == 0) {
struct _thread_info *info = g_malloc0(sizeof(*info));
- t(printf("created NEW thread %ld\n", id));
+ t(printf("created NEW thread %" G_GUINT64_FORMAT "\n", e_util_pthread_id(id)));
info->id = id;
info->busy = TRUE;
e->id_list = g_list_append(e->id_list, info);
@@ -35,14 +35,15 @@
pthread_mutex_unlock(&e->mutex);
return;
}
-@@ -977,12 +987,13 @@
- if (e->id == E_THREAD_NONE) {
+@@ -1125,13 +1135,14 @@ void e_thread_put(EThread *e, EMsg *msg)
+ if (!e->have_thread) {
int err;
- if ((err = pthread_create(&e->id, NULL, thread_dispatch, e)) != 0) {
+ if ((err = pthread_create(&e->id, &attr, thread_dispatch, e)) != 0) {
g_warning("Could not create dispatcher thread, message queued?: %s", strerror(err));
- e->id = E_THREAD_NONE;
+ } else {
+ e->have_thread = TRUE;
}
}
diff --git a/databases/evolution-data-server/files/patch-addressbook_backends_groupwise_e-book-backend-groupwise.c b/databases/evolution-data-server/files/patch-addressbook_backends_groupwise_e-book-backend-groupwise.c
deleted file mode 100644
index 2f3d3d6ff5bb..000000000000
--- a/databases/evolution-data-server/files/patch-addressbook_backends_groupwise_e-book-backend-groupwise.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- addressbook/backends/groupwise/e-book-backend-groupwise.c.orig Fri Sep 2 16:37:43 2005
-+++ addressbook/backends/groupwise/e-book-backend-groupwise.c Thu Nov 10 09:55:01 2005
-@@ -2010,6 +2010,7 @@
- if (enable_debug)
- printf ("\nread contacts from cache for the ids found in summary\n");
- for (i = 0; i < ids->len; i ++) {
-+ EContact *contact;
- char *uid = g_ptr_array_index (ids, i);
-
- g_mutex_lock (closure->mutex);
-@@ -2019,8 +2020,7 @@
- if (stopped)
- break;
-
-- EContact *contact =
-- e_book_backend_cache_get_contact (priv->cache, uid);
-+ contact = e_book_backend_cache_get_contact (priv->cache, uid);
- e_data_book_view_notify_update (book_view, contact);
- g_object_unref (contact);
- }
-@@ -2697,6 +2697,13 @@
- EBookBackendGroupwisePrivate *priv = ebgw->priv;
- EBookBackendCache *cache = priv->cache;
-
-+ struct timeval start, end;
-+ unsigned long diff;
-+ const char *cache_file_name;
-+ struct stat buf;
-+ time_t mod_time;
-+
-+
- if (enable_debug)
- printf("\nupdating GroupWise system address book cache \n");
-
-@@ -2741,12 +2748,6 @@
- server_last_sequence, server_last_po_rebuild_time);
- return TRUE;
- }
--
-- struct timeval start, end;
-- unsigned long diff;
-- const char *cache_file_name;
-- struct stat buf;
-- time_t mod_time;
-
- if (enable_debug)
- gettimeofday(&start, NULL);
diff --git a/databases/evolution-data-server/files/patch-addressbook_backends_ldap_e-book-backend-ldap.c b/databases/evolution-data-server/files/patch-addressbook_backends_ldap_e-book-backend-ldap.c
index c8262746ec0f..51f468867330 100644
--- a/databases/evolution-data-server/files/patch-addressbook_backends_ldap_e-book-backend-ldap.c
+++ b/databases/evolution-data-server/files/patch-addressbook_backends_ldap_e-book-backend-ldap.c
@@ -11,55 +11,3 @@
E_STRING_PROP (E_CONTACT_SPOUSE, "spouseName"),
E_STRING_PROP (E_CONTACT_NOTE, "note"),
E_COMPLEX_PROP (E_CONTACT_ANNIVERSARY, "anniversary", anniversary_populate, anniversary_ber, anniversary_compare),
-@@ -1698,8 +1698,9 @@
-
- msg_type = ldap_msgtype (res);
- if (msg_type == LDAP_RES_SEARCH_ENTRY) {
-+ LDAPMessage *e;
- g_static_rec_mutex_lock (&eds_ldap_handler_lock);
-- LDAPMessage *e = ldap_first_entry(ldap, res);
-+ e = ldap_first_entry(ldap, res);
- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-
- if (!e) {
-@@ -1908,13 +1909,14 @@
- the op after either */
- msg_type = ldap_msgtype (res);
- if (msg_type == LDAP_RES_SEARCH_ENTRY) {
-- g_static_rec_mutex_lock (&eds_ldap_handler_lock);
-- LDAPMessage *e = ldap_first_entry (bl->priv->ldap, res);
-- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
--
- EContact *contact;
- char *vcard;
-
-+ LDAPMessage *e;
-+ g_static_rec_mutex_lock (&eds_ldap_handler_lock);
-+ e = ldap_first_entry (bl->priv->ldap, res);
-+ g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-+
- if (!e) {
- g_warning ("uh, this shouldn't happen");
- e_data_book_respond_get_contact (op->book,
-@@ -3470,8 +3472,9 @@
- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-
- while (NULL != e) {
-+ EContact *contact;
- g_static_rec_mutex_lock (&eds_ldap_handler_lock);
-- EContact *contact = build_contact_from_entry (ldap, e, NULL);
-+ contact = build_contact_from_entry (ldap, e, NULL);
- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-
- e_data_book_view_notify_update (view, contact);
-@@ -3709,8 +3712,9 @@
- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-
- while (e != NULL) {
-+ EContact *contact;
- g_static_rec_mutex_lock (&eds_ldap_handler_lock);
-- EContact *contact = build_contact_from_entry (ldap, e, NULL);
-+ contact = build_contact_from_entry (ldap, e, NULL);
- g_static_rec_mutex_unlock (&eds_ldap_handler_lock);
-
- contact_list_op->contacts = g_list_prepend (contact_list_op->contacts, contact);
diff --git a/databases/evolution-data-server/files/patch-calendar_backends_groupwise_e-cal-backend-groupwise.c b/databases/evolution-data-server/files/patch-calendar_backends_groupwise_e-cal-backend-groupwise.c
deleted file mode 100644
index 1f3e165afca9..000000000000
--- a/databases/evolution-data-server/files/patch-calendar_backends_groupwise_e-cal-backend-groupwise.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- calendar/backends/groupwise/e-cal-backend-groupwise.c.orig Mon Oct 3 11:05:43 2005
-+++ calendar/backends/groupwise/e-cal-backend-groupwise.c Thu Nov 10 10:09:35 2005
-@@ -322,11 +322,12 @@
-
- for (; item_list != NULL; item_list = g_list_next(item_list)) {
- EGwItem *item = NULL;
-- item = E_GW_ITEM(item_list->data);
- ECalComponent *modified_comp = NULL, *cache_comp = NULL;
- char *cache_comp_str = NULL;
- const char *uid, *rid = NULL;
- int r_key;
-+
-+ item = E_GW_ITEM(item_list->data);
-
- modified_comp = e_gw_item_to_cal_component (item, cbgw);
- if (!modified_comp) {
diff --git a/databases/evolution-data-server/files/patch-camel-groupwise-folder.c b/databases/evolution-data-server/files/patch-camel-groupwise-folder.c
deleted file mode 100644
index 52e4ec88d080..000000000000
--- a/databases/evolution-data-server/files/patch-camel-groupwise-folder.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- camel/providers/groupwise/camel-groupwise-folder.c.orig Mon Oct 3 14:10:05 2005
-+++ camel/providers/groupwise/camel-groupwise-folder.c Thu Nov 10 05:26:17 2005
-@@ -1032,9 +1032,9 @@
- char *temp_date = NULL;
- const char *id;
- GSList *recp_list = NULL;
-- status_flags = 0;
- CamelStream *cache_stream;
- CamelMimeMessage *mail_msg = NULL;
-+ status_flags = 0;
-
- id = e_gw_item_get_id (temp_item);
-
-@@ -1768,6 +1768,7 @@
- const char *old_uid = (const char*)uids->pdata[index];
- char **tmp;
- guint32 temp_flags = 0;
-+ CamelGroupwiseMessageInfo *dest_info;
- CamelGroupwiseMessageInfo *src_info = (CamelGroupwiseMessageInfo *)camel_folder_summary_uid (source->summary, (const char*)uids->pdata[index]);
-
- /* we don't want to blindly copy the info: reset some flags not suitable for destination*/
-@@ -1776,7 +1777,7 @@
- else if (!strcmp(destination->full_name, JUNK_FOLDER))
- camel_folder_set_message_flags (source, old_uid, CAMEL_MESSAGE_JUNK, CAMEL_GW_MESSAGE_JUNK);
-
-- CamelGroupwiseMessageInfo *dest_info = (CamelGroupwiseMessageInfo *)camel_message_info_clone((CamelMessageInfo *)src_info);
-+ dest_info = (CamelGroupwiseMessageInfo *)camel_message_info_clone((CamelMessageInfo *)src_info);
- tmp = g_strsplit (old_uid, ":", -1);
- dest_info->info.uid = g_strdup_printf ("%s:%s",tmp[0], dest_container_id);
- temp_flags = camel_folder_get_message_flags (source, (const char *)uids->pdata[index]);
diff --git a/databases/evolution-data-server/files/patch-camel-groupwise-utils.c b/databases/evolution-data-server/files/patch-camel-groupwise-utils.c
deleted file mode 100644
index 5478bec69c84..000000000000
--- a/databases/evolution-data-server/files/patch-camel-groupwise-utils.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- camel/providers/groupwise/camel-groupwise-utils.c.orig Mon Oct 3 11:05:45 2005
-+++ camel/providers/groupwise/camel-groupwise-utils.c Thu Nov 10 05:36:51 2005
-@@ -339,8 +339,9 @@
- attachment->name = g_strdup (filename ? filename : "");
- if (!g_ascii_strncasecmp (attachment->contentType, RFC_822, strlen (RFC_822))) {
- char *temp_id = NULL, *id = NULL;
-+ int len;
- temp_id = (char *)camel_medium_get_header (CAMEL_MEDIUM ((CamelMimeMessage *)dw), "Message-Id");
-- int len = strlen (temp_id);
-+ len = strlen (temp_id);
-
- id = (char *)g_malloc0 (len-1);
- id = memcpy(id, temp_id+2, len-3);
-@@ -430,9 +431,10 @@
- dw = camel_medium_get_content_object (CAMEL_MEDIUM (part));
- if (type->subtype && !strcmp (type->subtype, "alternative")) {
- CamelMimePart *temp_part;
-+ CamelDataWrapper *temp_dw;
- CamelStreamMem *temp_content = (CamelStreamMem *)camel_stream_mem_new ();
- temp_part = camel_multipart_get_part ((CamelMultipart *)dw, 1);
-- CamelDataWrapper *temp_dw = camel_data_wrapper_new ();
-+ temp_dw = camel_data_wrapper_new ();
- if (temp_part) {
- is_alternative = TRUE;
- temp_dw = camel_medium_get_content_object (CAMEL_MEDIUM (temp_part));
diff --git a/databases/evolution-data-server/files/patch-camel_Makefile.in b/databases/evolution-data-server/files/patch-camel_Makefile.in
deleted file mode 100644
index 8a2d2fdf6151..000000000000
--- a/databases/evolution-data-server/files/patch-camel_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- camel/Makefile.in.orig Tue Nov 29 11:14:05 2005
-+++ camel/Makefile.in Tue Nov 29 11:14:32 2005
-@@ -508,7 +508,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- weatherdatadir = @weatherdatadir@
--SUBDIRS = . providers tests
-+SUBDIRS = . providers
- @OS_WIN32_FALSE@LIBCAMEL_PLATFORM_DEP_SOURCES = \
- @OS_WIN32_FALSE@ camel-lock-client.c \
- @OS_WIN32_FALSE@ camel-stream-process.c
diff --git a/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c b/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c
deleted file mode 100644
index 00ea9a3d6b55..000000000000
--- a/databases/evolution-data-server/files/patch-camel_providers_imap_camel-imap-utils.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- camel/providers/imap/camel-imap-utils.c.orig Tue Nov 29 03:03:43 2005
-+++ camel/providers/imap/camel-imap-utils.c Sun Dec 4 23:13:35 2005
-@@ -371,7 +371,7 @@ imap_parse_list_response (CamelImapStore
- return FALSE;
-
- if (folder) {
-- char *astring;
-+ char *astring, *mailbox;
-
- /* get the folder name */
- word = imap_next_word (word);
-@@ -380,8 +380,6 @@ imap_parse_list_response (CamelImapStore
- return FALSE;
-
- *folder = astring;
--
-- char *mailbox;
-
- mailbox = imap_mailbox_decode (astring, strlen (astring));
- g_free (astring);
diff --git a/databases/evolution-data-server/files/patch-configure b/databases/evolution-data-server/files/patch-configure
index fe88433c1287..91d8b09b92a8 100644
--- a/databases/evolution-data-server/files/patch-configure
+++ b/databases/evolution-data-server/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig Fri Jul 29 17:13:44 2005
-+++ configure Fri Jul 29 17:15:52 2005
-@@ -23461,6 +23461,13 @@
- DL_LIB=''
+--- configure.orig Sun Dec 25 01:57:35 2005
++++ configure Sun Dec 25 01:58:23 2005
+@@ -23542,6 +23542,14 @@
SOFTOKN3_LIB=''
+ LIBEXECDIR_IN_SERVER_FILE='../../../libexec'
;;
+*freebsd*)
+ os_win32=no
@@ -10,11 +10,12 @@
+ SOCKET_LIBS=''
+ DL_LIB=''
+ SOFTOKN3_LIB='-lsoftokn3'
++ LIBEXECDIR_IN_SERVER_FILE="$libexecdir"
+ ;;
*) os_win32=no
NO_UNDEFINED=''
SOCKET_LIBS=''
-@@ -27135,7 +27142,7 @@
+@@ -27317,7 +27325,7 @@
#include <sys/socket.h>
#include <netinet/in.h>
#include <netdb.h>
@@ -23,7 +24,7 @@
int
main ()
-@@ -27873,7 +27880,7 @@
+@@ -27565,7 +27573,7 @@
LDFLAGS_save="$LDFLAGS"
mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
@@ -32,7 +33,7 @@
echo "$as_me:$LINENO: checking for Kerberos 5" >&5
echo $ECHO_N "checking for Kerberos 5... $ECHO_C" >&6
if test "${ac_cv_lib_kerberos5+set}" = set; then
-@@ -31176,7 +31183,7 @@
+@@ -31483,7 +31491,7 @@
imagesdir="$datadir/pixmaps/evolution-data-server-$BASE_VERSION"
diff --git a/databases/evolution-data-server/files/patch-libedataserverui_e-name-selector-entry.c b/databases/evolution-data-server/files/patch-libedataserverui_e-name-selector-entry.c
deleted file mode 100644
index 19b5c0581307..000000000000
--- a/databases/evolution-data-server/files/patch-libedataserverui_e-name-selector-entry.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libedataserverui/e-name-selector-entry.c.orig Mon Oct 3 11:05:48 2005
-+++ libedataserverui/e-name-selector-entry.c Thu Nov 10 10:23:46 2005
-@@ -1112,7 +1112,7 @@
- const gchar *text;
- gint index_start, index_end;
- gint selection_start, selection_end;
-- gunichar str_context [2], str_b_context [2];;
-+ gunichar str_context [2], str_b_context [2];
- gint len;
- gint i;
- gboolean already_selected = FALSE;
diff --git a/databases/evolution-data-server/files/patch-servers-exchange-storage-e-folder-exchange.c b/databases/evolution-data-server/files/patch-servers-exchange-storage-e-folder-exchange.c
deleted file mode 100644
index e366b774de97..000000000000
--- a/databases/evolution-data-server/files/patch-servers-exchange-storage-e-folder-exchange.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- servers/exchange/storage/e-folder-exchange.c.orig Mon Oct 3 11:05:51 2005
-+++ servers/exchange/storage/e-folder-exchange.c Thu Nov 10 05:04:23 2005
-@@ -744,11 +744,13 @@
- void
- e_folder_exchange_unsubscribe (EFolder *folder)
- {
-+ E2kContext *ctx;
-+
- g_return_if_fail (E_IS_FOLDER_EXCHANGE (folder));
-
- /* FIXME : This is a hack as of now. The free_folder in mail-stub
- gets called when we are in offline and the context is NULL then. */
-- E2kContext *ctx = E_FOLDER_EXCHANGE_CONTEXT (folder);
-+ ctx = E_FOLDER_EXCHANGE_CONTEXT (folder);
- if (ctx) {
- e2k_context_unsubscribe (E_FOLDER_EXCHANGE_CONTEXT (folder),
- E_FOLDER_EXCHANGE_URI (folder));
diff --git a/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-connection.c b/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-connection.c
deleted file mode 100644
index faa3ce120218..000000000000
--- a/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-connection.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- servers/groupwise/e-gw-connection.c.orig Mon Oct 3 11:05:51 2005
-+++ servers/groupwise/e-gw-connection.c Thu Nov 10 00:32:44 2005
-@@ -1979,8 +1979,8 @@
- EGwConnectionPrivate *priv;
- SoupSoapParameter *param, *subparam, *second_level_child;
- char *id, *name;
-- g_return_val_if_fail (E_IS_GW_CONNECTION (cnc), E_GW_CONNECTION_STATUS_INVALID_OBJECT);
- static GStaticMutex connecting = G_STATIC_MUTEX_INIT;
-+ g_return_val_if_fail (E_IS_GW_CONNECTION (cnc), E_GW_CONNECTION_STATUS_INVALID_OBJECT);
-
- priv = cnc->priv;
- g_static_mutex_lock (&connecting);
diff --git a/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-item.c b/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-item.c
deleted file mode 100644
index 89201b2e7cb5..000000000000
--- a/databases/evolution-data-server/files/patch-servers-groupwise-e-gw-item.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- servers/groupwise/e-gw-item.c.orig Mon Oct 3 14:46:42 2005
-+++ servers/groupwise/e-gw-item.c Thu Nov 10 04:56:48 2005
-@@ -3019,8 +3019,8 @@
-
- /*attachments*/
- if (priv->attach_list) {
-- soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
- GSList *al ;
-+ soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
- for (al = priv->attach_list ; al != NULL ; al = al->next) {
- EGwItemAttachment *attachment = (EGwItemAttachment *)al->data ;
- add_attachment_to_soap_message (attachment, msg) ;