aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-05-17 21:28:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-05-17 21:28:59 +0000
commit8e4282ffe63ea028c7fb47ddca3a33fb2de11b10 (patch)
tree20f89221f13a3554807c823b94c32e2ce26d93fa /databases/evolution-data-server
parent640e99a0f6887cb0f070643d171169e1da4f49d4 (diff)
Catch up with libxml2 api breakage in 2.9.x
Notes
Notes: svn path=/head/; revision=354374
Diffstat (limited to 'databases/evolution-data-server')
-rw-r--r--databases/evolution-data-server/Makefile2
-rw-r--r--databases/evolution-data-server/files/patch-support-libxml2-2.9118
2 files changed, 119 insertions, 1 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index c6fc89909e55..355d60d4b793 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -4,7 +4,7 @@
PORTNAME= evolution-data-server
PORTVERSION= 2.32.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/databases/evolution-data-server/files/patch-support-libxml2-2.9 b/databases/evolution-data-server/files/patch-support-libxml2-2.9
new file mode 100644
index 000000000000..9d8711600e5c
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-support-libxml2-2.9
@@ -0,0 +1,118 @@
+From 679b10d75730e81fa268e11cfda289a27fd3e306 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Mon, 13 Aug 2012 09:50:50 -0400
+Subject: Bug 681321 - Support both old and new-buf libxml2 APIs
+
+libxml2 changed the API for xmlOutputBuffer incompatibly.
+See https://mail.gnome.org/archives/desktop-devel-list/2012-August/msg00004.html
+
+diff --git a/calendar/backends/caldav/e-cal-backend-caldav.c b/calendar/backends/caldav/e-cal-backend-caldav.c
+index 0219b34..f96907e 100644
+--- calendar/backends/caldav/e-cal-backend-caldav.c
++++ calendar/backends/caldav/e-cal-backend-caldav.c
+@@ -1188,6 +1188,19 @@ caldav_authenticate (ECalBackendCalDAV *cbdav,
+ return success;
+ }
+
++static gconstpointer
++compat_libxml_output_buffer_get_content (xmlOutputBufferPtr buf,
++ gsize *out_len)
++{
++#ifdef LIBXML2_NEW_BUFFER
++ *out_len = xmlOutputBufferGetSize (buf);
++ return xmlOutputBufferGetContent (buf);
++#else
++ *out_len = buf->buffer->use;
++ return buf->buffer->content;
++#endif
++}
++
+ /* Returns whether calendar changed on the server. This works only when server
+ * supports 'getctag' extension. */
+ static gboolean
+@@ -1198,6 +1211,8 @@ check_calendar_changed_on_server (ECalBackendCalDAV *cbdav)
+ xmlDocPtr doc;
+ xmlNodePtr root, node;
+ xmlNsPtr ns, nsdav;
++ gconstpointer buf_content;
++ gsize buf_size;
+ gboolean result = TRUE;
+
+ g_return_val_if_fail (cbdav != NULL, TRUE);
+@@ -1230,11 +1245,11 @@ check_calendar_changed_on_server (ECalBackendCalDAV *cbdav)
+ soup_message_headers_append (message->request_headers,
+ "Depth", "0");
+
++ buf_content = compat_libxml_output_buffer_get_content (buf, &buf_size);
+ soup_message_set_request (message,
+ "application/xml",
+ SOUP_MEMORY_COPY,
+- (gchar *) buf->buffer->content,
+- buf->buffer->use);
++ buf_content, buf_size);
+
+ /* Send the request now */
+ send_and_handle_redirection (cbdav->priv->session, message, NULL);
+@@ -1299,6 +1314,8 @@ caldav_server_list_objects (ECalBackendCalDAV *cbdav,
+ xmlDocPtr doc;
+ xmlNsPtr nsdav;
+ xmlNsPtr nscd;
++ gconstpointer buf_content;
++ gsize buf_size;
+ gboolean result;
+
+ /* Allocate the soup message */
+@@ -1378,11 +1395,11 @@ caldav_server_list_objects (ECalBackendCalDAV *cbdav,
+ soup_message_headers_append (message->request_headers,
+ "Depth", "1");
+
++ buf_content = compat_libxml_output_buffer_get_content (buf, &buf_size);
+ soup_message_set_request (message,
+ "application/xml",
+ SOUP_MEMORY_COPY,
+- (gchar *) buf->buffer->content,
+- buf->buffer->use);
++ buf_content, buf_size);
+
+ /* Send the request now */
+ send_and_handle_redirection (cbdav->priv->session, message, NULL);
+@@ -1795,6 +1812,8 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
+ xmlDocPtr doc;
+ xmlNodePtr root, node;
+ xmlNsPtr nsdav;
++ gconstpointer buf_content;
++ gsize buf_size;
+ gchar *owner = NULL;
+
+ g_return_val_if_fail (E_IS_CAL_BACKEND_CALDAV (cbdav), FALSE);
+@@ -1820,11 +1839,11 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
+ soup_message_headers_append (message->request_headers, "User-Agent", "Evolution/" VERSION);
+ soup_message_headers_append (message->request_headers, "Depth", "0");
+
++ buf_content = compat_libxml_output_buffer_get_content (buf, &buf_size);
+ soup_message_set_request (message,
+ "application/xml",
+ SOUP_MEMORY_COPY,
+- (gchar *) buf->buffer->content,
+- buf->buffer->use);
++ buf_content, buf_size);
+
+ /* Send the request now */
+ send_and_handle_redirection (cbdav->priv->session, message, NULL);
+@@ -1870,11 +1889,11 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
+ soup_message_headers_append (message->request_headers, "User-Agent", "Evolution/" VERSION);
+ soup_message_headers_append (message->request_headers, "Depth", "0");
+
++ buf_content = compat_libxml_output_buffer_get_content (buf, &buf_size);
+ soup_message_set_request (message,
+- "application/xml",
+- SOUP_MEMORY_COPY,
+- (gchar *) buf->buffer->content,
+- buf->buffer->use);
++ "application/xml",
++ SOUP_MEMORY_COPY,
++ buf_content, buf_size);
+
+ /* Send the request now */
+ send_and_handle_redirection (cbdav->priv->session, message, NULL);
+