aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /databases/evolution-data-server
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'databases/evolution-data-server')
-rw-r--r--databases/evolution-data-server/Makefile9
-rw-r--r--databases/evolution-data-server/distinfo5
-rw-r--r--databases/evolution-data-server/files/patch-calendar_libedata-cal_e-cal-backend-intervaltree.c11
-rw-r--r--databases/evolution-data-server/pkg-plist247
4 files changed, 128 insertions, 144 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index b43017790b9f..45d60670b64d 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/databases/evolution-data-server/Makefile,v 1.8 2010/06/24 10:03:53 kwm Exp $
+# $MCom: ports/databases/evolution-data-server/Makefile,v 1.203 2010/11/15 17:19:55 kwm Exp $
#
PORTNAME= evolution-data-server
-PORTVERSION= 2.30.3
+PORTVERSION= 2.32.1
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,6 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= The data backends for the Evolution integrated mail/PIM suite
LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gdata.7:${PORTSDIR}/devel/libgdata \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
ical.44:${PORTSDIR}/devel/libical \
nss3.1:${PORTSDIR}/security/nss \
@@ -29,6 +30,7 @@ USE_BISON= build
USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intlhack ltverhack ltasneededhack gconf2 \
libxml2
+GNOME_DESKTOP_VERSION=2
USE_OPENLDAP= yes
USE_AUTOTOOLS= libtool:22
USE_BDB= 41+
@@ -40,7 +42,7 @@ CONFIGURE_ARGS= --enable-static \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-PLIST_SUB= VERSION="2.30" EVO_VERSION="1.2"
+PLIST_SUB= VERSION="2.32" EVO_VERSION="1.2"
#OPTIONS= IMAP4 "Enable experimental IMAP4 backend" off
OPTIONS= WEATHER "Enable weather calendar backend" on
@@ -84,7 +86,6 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g ; \
s|heimlibs=".*"|heimlibs="${KRB5_LIB}"|g ; \
- s|LIBEDATASERVER_CURRENT=13|LIBEDATASERVER_CURRENT=11|g ; \
s|-Wl,--no-undefined||g ; \
s|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
diff --git a/databases/evolution-data-server/distinfo b/databases/evolution-data-server/distinfo
index adccd4efda6d..d510805ec313 100644
--- a/databases/evolution-data-server/distinfo
+++ b/databases/evolution-data-server/distinfo
@@ -1,3 +1,2 @@
-MD5 (gnome2/evolution-data-server-2.30.3.tar.bz2) = 095bac0a80043d57d00f64319f3cbdbb
-SHA256 (gnome2/evolution-data-server-2.30.3.tar.bz2) = 3773e677ab3b9ff5564a26409ec6b00bc1bd68baf58a8781109866a7e29df890
-SIZE (gnome2/evolution-data-server-2.30.3.tar.bz2) = 4652416
+SHA256 (gnome2/evolution-data-server-2.32.1.tar.bz2) = de6a724504a9d72ca550a5a157df1e27dbb951a673f281106171c2345912fc79
+SIZE (gnome2/evolution-data-server-2.32.1.tar.bz2) = 4290087
diff --git a/databases/evolution-data-server/files/patch-calendar_libedata-cal_e-cal-backend-intervaltree.c b/databases/evolution-data-server/files/patch-calendar_libedata-cal_e-cal-backend-intervaltree.c
new file mode 100644
index 000000000000..573eb5312a37
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-calendar_libedata-cal_e-cal-backend-intervaltree.c
@@ -0,0 +1,11 @@
+--- calendar/libedata-cal/e-cal-backend-intervaltree.c.orig 2010-09-19 18:17:35.000000000 +0000
++++ calendar/libedata-cal/e-cal-backend-intervaltree.c 2010-09-19 18:17:44.000000000 +0000
+@@ -26,7 +26,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "e-cal-backend-intervaltree.h"
+
diff --git a/databases/evolution-data-server/pkg-plist b/databases/evolution-data-server/pkg-plist
index 8d112f6add3a..982014ecc1af 100644
--- a/databases/evolution-data-server/pkg-plist
+++ b/databases/evolution-data-server/pkg-plist
@@ -1,5 +1,4 @@
include/evolution-data-server-%%VERSION%%/camel/camel-address.h
-include/evolution-data-server-%%VERSION%%/camel/camel-arg.h
include/evolution-data-server-%%VERSION%%/camel/camel-block-file.h
include/evolution-data-server-%%VERSION%%/camel/camel-certdb.h
include/evolution-data-server-%%VERSION%%/camel/camel-charset-map.h
@@ -8,14 +7,9 @@ include/evolution-data-server-%%VERSION%%/camel/camel-data-cache.h
include/evolution-data-server-%%VERSION%%/camel/camel-data-wrapper.h
include/evolution-data-server-%%VERSION%%/camel/camel-db.h
include/evolution-data-server-%%VERSION%%/camel/camel-debug.h
-include/evolution-data-server-%%VERSION%%/camel/camel-digest-folder.h
-include/evolution-data-server-%%VERSION%%/camel/camel-digest-store.h
-include/evolution-data-server-%%VERSION%%/camel/camel-digest-summary.h
include/evolution-data-server-%%VERSION%%/camel/camel-disco-diary.h
include/evolution-data-server-%%VERSION%%/camel/camel-disco-folder.h
include/evolution-data-server-%%VERSION%%/camel/camel-disco-store.h
-include/evolution-data-server-%%VERSION%%/camel/camel-exception-list.def
-include/evolution-data-server-%%VERSION%%/camel/camel-exception.h
include/evolution-data-server-%%VERSION%%/camel/camel-file-utils.h
include/evolution-data-server-%%VERSION%%/camel/camel-filter-driver.h
include/evolution-data-server-%%VERSION%%/camel/camel-filter-search.h
@@ -26,7 +20,6 @@ include/evolution-data-server-%%VERSION%%/camel/camel-folder.h
include/evolution-data-server-%%VERSION%%/camel/camel-gpg-context.h
include/evolution-data-server-%%VERSION%%/camel/camel-html-parser.h
include/evolution-data-server-%%VERSION%%/camel/camel-http-stream.h
-include/evolution-data-server-%%VERSION%%/camel/camel-i18n.h
include/evolution-data-server-%%VERSION%%/camel/camel-iconv.h
include/evolution-data-server-%%VERSION%%/camel/camel-index.h
include/evolution-data-server-%%VERSION%%/camel/camel-internet-address.h
@@ -36,6 +29,7 @@ include/evolution-data-server-%%VERSION%%/camel/camel-lock-client.h
include/evolution-data-server-%%VERSION%%/camel/camel-lock-helper.h
include/evolution-data-server-%%VERSION%%/camel/camel-lock.h
include/evolution-data-server-%%VERSION%%/camel/camel-medium.h
+include/evolution-data-server-%%VERSION%%/camel/camel-mempool.h
include/evolution-data-server-%%VERSION%%/camel/camel-mime-filter-basic.h
include/evolution-data-server-%%VERSION%%/camel/camel-mime-filter-bestenc.h
include/evolution-data-server-%%VERSION%%/camel/camel-mime-filter-canon.h
@@ -65,15 +59,14 @@ include/evolution-data-server-%%VERSION%%/camel/camel-multipart-encrypted.h
include/evolution-data-server-%%VERSION%%/camel/camel-multipart-signed.h
include/evolution-data-server-%%VERSION%%/camel/camel-multipart.h
include/evolution-data-server-%%VERSION%%/camel/camel-net-utils.h
-include/evolution-data-server-%%VERSION%%/camel/camel-news-address.h
include/evolution-data-server-%%VERSION%%/camel/camel-nntp-address.h
include/evolution-data-server-%%VERSION%%/camel/camel-object.h
+include/evolution-data-server-%%VERSION%%/camel/camel-object-bag.h
include/evolution-data-server-%%VERSION%%/camel/camel-offline-folder.h
include/evolution-data-server-%%VERSION%%/camel/camel-offline-journal.h
include/evolution-data-server-%%VERSION%%/camel/camel-offline-store.h
include/evolution-data-server-%%VERSION%%/camel/camel-operation.h
include/evolution-data-server-%%VERSION%%/camel/camel-partition-table.h
-include/evolution-data-server-%%VERSION%%/camel/camel-process.h
include/evolution-data-server-%%VERSION%%/camel/camel-provider.h
include/evolution-data-server-%%VERSION%%/camel/camel-sasl-anonymous.h
include/evolution-data-server-%%VERSION%%/camel/camel-sasl-cram-md5.h
@@ -109,7 +102,6 @@ include/evolution-data-server-%%VERSION%%/camel/camel-tcp-stream.h
include/evolution-data-server-%%VERSION%%/camel/camel-text-index.h
include/evolution-data-server-%%VERSION%%/camel/camel-transport.h
include/evolution-data-server-%%VERSION%%/camel/camel-trie.h
-include/evolution-data-server-%%VERSION%%/camel/camel-types.h
include/evolution-data-server-%%VERSION%%/camel/camel-uid-cache.h
include/evolution-data-server-%%VERSION%%/camel/camel-url-scanner.h
include/evolution-data-server-%%VERSION%%/camel/camel-url.h
@@ -119,10 +111,6 @@ include/evolution-data-server-%%VERSION%%/camel/camel-vee-store.h
include/evolution-data-server-%%VERSION%%/camel/camel-vee-summary.h
include/evolution-data-server-%%VERSION%%/camel/camel-vtrash-folder.h
include/evolution-data-server-%%VERSION%%/camel/camel.h
-include/evolution-data-server-%%VERSION%%/google/libgdata-google/gdata-google-service.h
-include/evolution-data-server-%%VERSION%%/google/libgdata/gdata-entry.h
-include/evolution-data-server-%%VERSION%%/google/libgdata/gdata-feed.h
-include/evolution-data-server-%%VERSION%%/google/libgdata/gdata-service-iface.h
include/evolution-data-server-%%VERSION%%/groupwise/e-gw-connection.h
include/evolution-data-server-%%VERSION%%/groupwise/e-gw-container.h
include/evolution-data-server-%%VERSION%%/groupwise/e-gw-filter.h
@@ -170,6 +158,7 @@ include/evolution-data-server-%%VERSION%%/libedata-book/e-data-book.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-cache.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-factory.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-file-store.h
+include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-intervaltree.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-sexp.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-store.h
include/evolution-data-server-%%VERSION%%/libedata-cal/e-cal-backend-sync.h
@@ -184,26 +173,23 @@ include/evolution-data-server-%%VERSION%%/libedataserver/e-account-list.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-account.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-categories.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-data-server-util.h
+include/evolution-data-server-%%VERSION%%/libedataserver/e-debug-log.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-flag.h
-include/evolution-data-server-%%VERSION%%/libedataserver/e-iconv.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-iterator.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-list-iterator.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-list.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-memory.h
-include/evolution-data-server-%%VERSION%%/libedataserver/e-msgport.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-proxy.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-sexp.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-source-group.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-source-list.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-source.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-time-utils.h
-include/evolution-data-server-%%VERSION%%/libedataserver/e-trie.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-uid.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-url.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-xml-hash-utils.h
include/evolution-data-server-%%VERSION%%/libedataserver/e-xml-utils.h
include/evolution-data-server-%%VERSION%%/libedataserver/eds-version.h
-include/evolution-data-server-%%VERSION%%/libedataserver/md5-utils.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-book-auth-util.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-category-completion.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-categories-dialog.h
@@ -217,7 +203,6 @@ include/evolution-data-server-%%VERSION%%/libedataserverui/e-name-selector-model
include/evolution-data-server-%%VERSION%%/libedataserverui/e-name-selector.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-passwords.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-source-combo-box.h
-include/evolution-data-server-%%VERSION%%/libedataserverui/e-source-option-menu.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-source-selector-dialog.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-source-selector.h
include/evolution-data-server-%%VERSION%%/libedataserverui/e-tree-model-generator.h
@@ -284,9 +269,6 @@ lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendcontacts.so
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendfile.a
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendfile.la
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendfile.so
-lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgoogle.a
-lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgoogle.la
-lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgoogle.so
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgroupwise.a
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgroupwise.la
lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendgroupwise.so
@@ -299,11 +281,11 @@ lib/evolution-data-server-%%EVO_VERSION%%/extensions/libecalbackendhttp.so
lib/libcamel-%%EVO_VERSION%%.a
lib/libcamel-%%EVO_VERSION%%.la
lib/libcamel-%%EVO_VERSION%%.so
-lib/libcamel-%%EVO_VERSION%%.so.14
+lib/libcamel-%%EVO_VERSION%%.so.19
lib/libcamel-provider-%%EVO_VERSION%%.a
lib/libcamel-provider-%%EVO_VERSION%%.la
lib/libcamel-provider-%%EVO_VERSION%%.so
-lib/libcamel-provider-%%EVO_VERSION%%.so.14
+lib/libcamel-provider-%%EVO_VERSION%%.so.19
lib/libebackend-%%EVO_VERSION%%.a
lib/libebackend-%%EVO_VERSION%%.la
lib/libebackend-%%EVO_VERSION%%.so
@@ -311,39 +293,31 @@ lib/libebackend-%%EVO_VERSION%%.so.0
lib/libebook-%%EVO_VERSION%%.a
lib/libebook-%%EVO_VERSION%%.la
lib/libebook-%%EVO_VERSION%%.so
-lib/libebook-%%EVO_VERSION%%.so.9
+lib/libebook-%%EVO_VERSION%%.so.10
lib/libecal-%%EVO_VERSION%%.a
lib/libecal-%%EVO_VERSION%%.la
lib/libecal-%%EVO_VERSION%%.so
-lib/libecal-%%EVO_VERSION%%.so.7
+lib/libecal-%%EVO_VERSION%%.so.8
lib/libedata-book-%%EVO_VERSION%%.a
lib/libedata-book-%%EVO_VERSION%%.la
lib/libedata-book-%%EVO_VERSION%%.so
-lib/libedata-book-%%EVO_VERSION%%.so.2
+lib/libedata-book-%%EVO_VERSION%%.so.8
lib/libedata-cal-%%EVO_VERSION%%.a
lib/libedata-cal-%%EVO_VERSION%%.la
lib/libedata-cal-%%EVO_VERSION%%.so
-lib/libedata-cal-%%EVO_VERSION%%.so.7
+lib/libedata-cal-%%EVO_VERSION%%.so.10
lib/libedataserver-%%EVO_VERSION%%.a
lib/libedataserver-%%EVO_VERSION%%.la
lib/libedataserver-%%EVO_VERSION%%.so
-lib/libedataserver-%%EVO_VERSION%%.so.11
+lib/libedataserver-%%EVO_VERSION%%.so.14
lib/libedataserverui-%%EVO_VERSION%%.a
lib/libedataserverui-%%EVO_VERSION%%.la
lib/libedataserverui-%%EVO_VERSION%%.so
-lib/libedataserverui-%%EVO_VERSION%%.so.8
+lib/libedataserverui-%%EVO_VERSION%%.so.11
lib/libegroupwise-%%EVO_VERSION%%.a
lib/libegroupwise-%%EVO_VERSION%%.la
lib/libegroupwise-%%EVO_VERSION%%.so
lib/libegroupwise-%%EVO_VERSION%%.so.13
-lib/libgdata-%%EVO_VERSION%%.a
-lib/libgdata-%%EVO_VERSION%%.la
-lib/libgdata-%%EVO_VERSION%%.so
-lib/libgdata-%%EVO_VERSION%%.so.1
-lib/libgdata-google-%%EVO_VERSION%%.a
-lib/libgdata-google-%%EVO_VERSION%%.la
-lib/libgdata-google-%%EVO_VERSION%%.so
-lib/libgdata-google-%%EVO_VERSION%%.so.1
libdata/pkgconfig/camel-%%EVO_VERSION%%.pc
libdata/pkgconfig/camel-provider-%%EVO_VERSION%%.pc
libdata/pkgconfig/evolution-data-server-%%EVO_VERSION%%.pc
@@ -355,8 +329,6 @@ libdata/pkgconfig/libedata-cal-%%EVO_VERSION%%.pc
libdata/pkgconfig/libedataserver-%%EVO_VERSION%%.pc
libdata/pkgconfig/libedataserverui-%%EVO_VERSION%%.pc
libdata/pkgconfig/libegroupwise-%%EVO_VERSION%%.pc
-libdata/pkgconfig/libgdata-%%EVO_VERSION%%.pc
-libdata/pkgconfig/libgdata-google-%%EVO_VERSION%%.pc
libexec/camel-index-control-%%EVO_VERSION%%
libexec/camel-lock-helper-%%EVO_VERSION%%
libexec/e-addressbook-factory
@@ -364,6 +336,86 @@ libexec/e-calendar-factory
share/dbus-1/services/org.gnome.evolution.dataserver.AddressBook.service
share/dbus-1/services/org.gnome.evolution.dataserver.Calendar.service
share/doc/camel/Addresses.html
+share/doc/camel/CamelAddress.html
+share/doc/camel/CamelCertDB.html
+share/doc/camel/CamelCipherContext.html
+share/doc/camel/CamelDataCache.html
+share/doc/camel/CamelDataWrapper.html
+share/doc/camel/CamelDiscoDiary.html
+share/doc/camel/CamelDiscoFolder.html
+share/doc/camel/CamelDiscoStore.html
+share/doc/camel/CamelFilterDriver.html
+share/doc/camel/CamelFolder.html
+share/doc/camel/CamelFolderSearch.html
+share/doc/camel/CamelFolderSummary.html
+share/doc/camel/CamelGpgContext.html
+share/doc/camel/CamelHttpStream.html
+share/doc/camel/CamelIndex.html
+share/doc/camel/CamelInternetAddress.html
+share/doc/camel/CamelKeyFile.html
+share/doc/camel/CamelKeyTable.html
+share/doc/camel/CamelMedium.html
+share/doc/camel/CamelMimeFilter.html
+share/doc/camel/CamelMimeFilterBasic.html
+share/doc/camel/CamelMimeFilterBestenc.html
+share/doc/camel/CamelMimeFilterCRLF.html
+share/doc/camel/CamelMimeFilterCanon.html
+share/doc/camel/CamelMimeFilterCharset.html
+share/doc/camel/CamelMimeFilterEnriched.html
+share/doc/camel/CamelMimeFilterFrom.html
+share/doc/camel/CamelMimeFilterGZip.html
+share/doc/camel/CamelMimeFilterHTML.html
+share/doc/camel/CamelMimeFilterIndex.html
+share/doc/camel/CamelMimeFilterLinewrap.html
+share/doc/camel/CamelMimeFilterPgp.html
+share/doc/camel/CamelMimeFilterProgress.html
+share/doc/camel/CamelMimeFilterSave.html
+share/doc/camel/CamelMimeFilterToHTML.html
+share/doc/camel/CamelMimeFilterWindows.html
+share/doc/camel/CamelMimeFilterYenc.html
+share/doc/camel/CamelMimeMessage.html
+share/doc/camel/CamelMimeParser.html
+share/doc/camel/CamelMimePart.html
+share/doc/camel/CamelMultipart.html
+share/doc/camel/CamelMultipartEncrypted.html
+share/doc/camel/CamelMultipartSigned.html
+share/doc/camel/CamelNNTPAddress.html
+share/doc/camel/CamelObject.html
+share/doc/camel/CamelOfflineFolder.html
+share/doc/camel/CamelOfflineJournal.html
+share/doc/camel/CamelOfflineStore.html
+share/doc/camel/CamelSMIMEContext.html
+share/doc/camel/CamelSasl.html
+share/doc/camel/CamelSaslAnonymous.html
+share/doc/camel/CamelSaslCramMd5.html
+share/doc/camel/CamelSaslDigestMd5.html
+share/doc/camel/CamelSaslGssapi.html
+share/doc/camel/CamelSaslLogin.html
+share/doc/camel/CamelSaslNTLM.html
+share/doc/camel/CamelSaslPOPB4SMTP.html
+share/doc/camel/CamelSaslPlain.html
+share/doc/camel/CamelSeekableStream.html
+share/doc/camel/CamelSeekableSubstream.html
+share/doc/camel/CamelService.html
+share/doc/camel/CamelSession.html
+share/doc/camel/CamelStore.html
+share/doc/camel/CamelStoreSummary.html
+share/doc/camel/CamelStream.html
+share/doc/camel/CamelStreamBuffer.html
+share/doc/camel/CamelStreamFilter.html
+share/doc/camel/CamelStreamFs.html
+share/doc/camel/CamelStreamMem.html
+share/doc/camel/CamelStreamNull.html
+share/doc/camel/CamelStreamProcess.html
+share/doc/camel/CamelStreamVFS.html
+share/doc/camel/CamelTcpStream.html
+share/doc/camel/CamelTcpStreamRaw.html
+share/doc/camel/CamelTextIndexName.html
+share/doc/camel/CamelTransport.html
+share/doc/camel/CamelVTrashFolder.html
+share/doc/camel/CamelVeeFolder.html
+share/doc/camel/CamelVeeStore.html
+share/doc/camel/CamelVeeSummary.html
share/doc/camel/ClassTree.html
share/doc/camel/Crypto.html
share/doc/camel/Deprecated.html
@@ -382,99 +434,14 @@ share/doc/camel/api-index-2.24.html
share/doc/camel/api-index-2.26.html
share/doc/camel/api-index-2.28.html
share/doc/camel/api-index-2.30.html
+share/doc/camel/api-index-2.32.html
share/doc/camel/api-index-deprecated.html
share/doc/camel/api-index-full.html
-share/doc/camel/camel-CamelAddress.html
-share/doc/camel/camel-CamelCertDB.html
-share/doc/camel/camel-CamelCipherContext.html
share/doc/camel/camel-CamelDB.html
-share/doc/camel/camel-CamelDataCache.html
-share/doc/camel/camel-CamelDataWrapper.html
-share/doc/camel/camel-CamelDigestFolder.html
-share/doc/camel/camel-CamelDigestStore.html
-share/doc/camel/camel-CamelDigestSummary.html
-share/doc/camel/camel-CamelDiscoDiary.html
-share/doc/camel/camel-CamelDiscoFolder.html
-share/doc/camel/camel-CamelDiscoStore.html
-share/doc/camel/camel-CamelFilterDriver.html
-share/doc/camel/camel-CamelFolder.html
-share/doc/camel/camel-CamelFolderSearch.html
-share/doc/camel/camel-CamelFolderSummary.html
-share/doc/camel/camel-CamelGpgContext.html
-share/doc/camel/camel-CamelHttpStream.html
-share/doc/camel/camel-CamelIndex.html
-share/doc/camel/camel-CamelInternetAddress.html
-share/doc/camel/camel-CamelKeyFile.html
-share/doc/camel/camel-CamelKeyTable.html
-share/doc/camel/camel-CamelMedium.html
-share/doc/camel/camel-CamelMimeFilter.html
-share/doc/camel/camel-CamelMimeFilterBasic.html
-share/doc/camel/camel-CamelMimeFilterBestenc.html
-share/doc/camel/camel-CamelMimeFilterCRLF.html
-share/doc/camel/camel-CamelMimeFilterCanon.html
-share/doc/camel/camel-CamelMimeFilterCharset.html
-share/doc/camel/camel-CamelMimeFilterEnriched.html
-share/doc/camel/camel-CamelMimeFilterFrom.html
-share/doc/camel/camel-CamelMimeFilterGZip.html
-share/doc/camel/camel-CamelMimeFilterHTML.html
-share/doc/camel/camel-CamelMimeFilterIndex.html
-share/doc/camel/camel-CamelMimeFilterLinewrap.html
-share/doc/camel/camel-CamelMimeFilterPgp.html
-share/doc/camel/camel-CamelMimeFilterProgress.html
-share/doc/camel/camel-CamelMimeFilterSave.html
-share/doc/camel/camel-CamelMimeFilterToHTML.html
-share/doc/camel/camel-CamelMimeFilterWindows.html
-share/doc/camel/camel-CamelMimeFilterYenc.html
-share/doc/camel/camel-CamelMimeMessage.html
-share/doc/camel/camel-CamelMimeParser.html
-share/doc/camel/camel-CamelMimePart.html
share/doc/camel/camel-CamelMsgPort.html
-share/doc/camel/camel-CamelMultipart.html
-share/doc/camel/camel-CamelMultipartEncrypted.html
-share/doc/camel/camel-CamelMultipartSigned.html
-share/doc/camel/camel-CamelNNTPAddress.html
-share/doc/camel/camel-CamelNewsAddress.html
-share/doc/camel/camel-CamelObject.html
-share/doc/camel/camel-CamelOfflineFolder.html
-share/doc/camel/camel-CamelOfflineJournal.html
-share/doc/camel/camel-CamelOfflineStore.html
-share/doc/camel/camel-CamelSMIMEContext.html
-share/doc/camel/camel-CamelSasl.html
-share/doc/camel/camel-CamelSaslAnonymous.html
-share/doc/camel/camel-CamelSaslCramMd5.html
-share/doc/camel/camel-CamelSaslDigestMd5.html
-share/doc/camel/camel-CamelSaslGssapi.html
-share/doc/camel/camel-CamelSaslLogin.html
-share/doc/camel/camel-CamelSaslNTLM.html
-share/doc/camel/camel-CamelSaslPOPB4SMTP.html
-share/doc/camel/camel-CamelSaslPlain.html
-share/doc/camel/camel-CamelSeekableStream.html
-share/doc/camel/camel-CamelSeekableSubstream.html
-share/doc/camel/camel-CamelService.html
-share/doc/camel/camel-CamelSession.html
-share/doc/camel/camel-CamelStore.html
-share/doc/camel/camel-CamelStoreSummary.html
-share/doc/camel/camel-CamelStream.html
-share/doc/camel/camel-CamelStreamBuffer.html
-share/doc/camel/camel-CamelStreamFilter.html
-share/doc/camel/camel-CamelStreamFs.html
-share/doc/camel/camel-CamelStreamMem.html
-share/doc/camel/camel-CamelStreamNull.html
-share/doc/camel/camel-CamelStreamProcess.html
-share/doc/camel/camel-CamelStreamVFS.html
-share/doc/camel/camel-CamelTcpStream.html
-share/doc/camel/camel-CamelTcpStreamRaw.html
share/doc/camel/camel-CamelTcpStreamSSL.html
-share/doc/camel/camel-CamelTextIndexName.html
-share/doc/camel/camel-CamelTransport.html
-share/doc/camel/camel-CamelVTrashFolder.html
-share/doc/camel/camel-CamelVeeFolder.html
-share/doc/camel/camel-CamelVeeStore.html
-share/doc/camel/camel-CamelVeeSummary.html
-share/doc/camel/camel-camel-arg.html
share/doc/camel/camel-camel-charset-map.html
share/doc/camel/camel-camel-debug.html
-share/doc/camel/camel-camel-exception.html
share/doc/camel/camel-camel-file-utils.html
share/doc/camel/camel-camel-filter-search.html
share/doc/camel/camel-camel-folder-thread.html
@@ -483,14 +450,14 @@ share/doc/camel/camel-camel-junk-plugin.html
share/doc/camel/camel-camel-list-utils.html
share/doc/camel/camel-camel-lock-client.html
share/doc/camel/camel-camel-lock.html
+share/doc/camel/camel-camel-mempool.html
share/doc/camel/camel-camel-mime-utils.html
share/doc/camel/camel-camel-movemail.html
share/doc/camel/camel-camel-net-utils.html
share/doc/camel/camel-camel-operation.html
-share/doc/camel/camel-camel-process.html
share/doc/camel/camel-camel-provider.html
-share/doc/camel/camel-camel-search-sql.html
share/doc/camel/camel-camel-search-sql-sexp.html
+share/doc/camel/camel-camel-search-sql.html
share/doc/camel/camel-camel-string-utils.html
share/doc/camel/camel-camel-trie.html
share/doc/camel/camel-camel-uid-cache.html
@@ -512,6 +479,7 @@ share/doc/libebackend/api-index-2.24.html
share/doc/libebackend/api-index-2.26.html
share/doc/libebackend/api-index-2.28.html
share/doc/libebackend/api-index-2.30.html
+share/doc/libebackend/api-index-deprecated.html
share/doc/libebackend/ch01.html
share/doc/libebackend/home.png
share/doc/libebackend/index.html
@@ -539,6 +507,8 @@ share/doc/libebook/api-index-2.24.html
share/doc/libebook/api-index-2.26.html
share/doc/libebook/api-index-2.28.html
share/doc/libebook/api-index-2.30.html
+share/doc/libebook/api-index-2.32.html
+share/doc/libebook/api-index-deprecated.html
share/doc/libebook/api-index-full.html
share/doc/libebook/ch01.html
share/doc/libebook/home.png
@@ -563,6 +533,8 @@ share/doc/libecal/api-index-2.24.html
share/doc/libecal/api-index-2.26.html
share/doc/libecal/api-index-2.28.html
share/doc/libecal/api-index-2.30.html
+share/doc/libecal/api-index-2.32.html
+share/doc/libecal/api-index-deprecated.html
share/doc/libecal/api-index-full.html
share/doc/libecal/ch01.html
share/doc/libecal/home.png
@@ -594,6 +566,8 @@ share/doc/libedata-book/api-index-2.24.html
share/doc/libedata-book/api-index-2.26.html
share/doc/libedata-book/api-index-2.28.html
share/doc/libedata-book/api-index-2.30.html
+share/doc/libedata-book/api-index-2.32.html
+share/doc/libedata-book/api-index-deprecated.html
share/doc/libedata-book/api-index-full.html
share/doc/libedata-book/ch01.html
share/doc/libedata-book/home.png
@@ -620,6 +594,8 @@ share/doc/libedata-cal/api-index-2.24.html
share/doc/libedata-cal/api-index-2.26.html
share/doc/libedata-cal/api-index-2.28.html
share/doc/libedata-cal/api-index-2.30.html
+share/doc/libedata-cal/api-index-2.32.html
+share/doc/libedata-cal/api-index-deprecated.html
share/doc/libedata-cal/api-index-full.html
share/doc/libedata-cal/ch01.html
share/doc/libedata-cal/home.png
@@ -631,6 +607,7 @@ share/doc/libedata-cal/libedata-cal-ECalBackendLoaderFactory.html
share/doc/libedata-cal/libedata-cal-ECalBackendStore.html
share/doc/libedata-cal/libedata-cal-EDataCalFactory.html
share/doc/libedata-cal/libedata-cal-EDataCalView.html
+share/doc/libedata-cal/libedata-cal-EIntervalTree.html
share/doc/libedata-cal/libedata-cal-e-cal-backend-util.html
share/doc/libedata-cal/libedata-cal.devhelp
share/doc/libedata-cal/libedata-cal.devhelp2
@@ -651,6 +628,8 @@ share/doc/libedataserver/api-index-2.24.html
share/doc/libedataserver/api-index-2.26.html
share/doc/libedataserver/api-index-2.28.html
share/doc/libedataserver/api-index-2.30.html
+share/doc/libedataserver/api-index-2.32.html
+share/doc/libedataserver/api-index-deprecated.html
share/doc/libedataserver/api-index-full.html
share/doc/libedataserver/ch01.html
share/doc/libedataserver/home.png
@@ -662,16 +641,13 @@ share/doc/libedataserver/libedataserver-EProxy.html
share/doc/libedataserver/libedataserver-ESExp.html
share/doc/libedataserver/libedataserver-Version-Information.html
share/doc/libedataserver/libedataserver-e-categories.html
-share/doc/libedataserver/libedataserver-e-iconv.html
+share/doc/libedataserver/libedataserver-e-debug-log.html
share/doc/libedataserver/libedataserver-e-memory.html
-share/doc/libedataserver/libedataserver-e-msgport.html
share/doc/libedataserver/libedataserver-e-time-utils.html
-share/doc/libedataserver/libedataserver-e-trie.html
share/doc/libedataserver/libedataserver-e-uid.html
share/doc/libedataserver/libedataserver-e-url.html
share/doc/libedataserver/libedataserver-e-util.html
share/doc/libedataserver/libedataserver-e-xml-hash-utils.html
-share/doc/libedataserver/libedataserver-md5-utils.html
share/doc/libedataserver/libedataserver.devhelp
share/doc/libedataserver/libedataserver.devhelp2
share/doc/libedataserver/right.png
@@ -686,7 +662,6 @@ share/doc/libedataserverui/ENameSelectorEntry.html
share/doc/libedataserverui/ENameSelectorList.html
share/doc/libedataserverui/ENameSelectorModel.html
share/doc/libedataserverui/ESourceComboBox.html
-share/doc/libedataserverui/ESourceOptionMenu.html
share/doc/libedataserverui/ESourceSelector.html
share/doc/libedataserverui/ESourceSelectorDialog.html
share/doc/libedataserverui/ETreeModelGenerator.html
@@ -696,6 +671,8 @@ share/doc/libedataserverui/api-index-2.24.html
share/doc/libedataserverui/api-index-2.26.html
share/doc/libedataserverui/api-index-2.28.html
share/doc/libedataserverui/api-index-2.30.html
+share/doc/libedataserverui/api-index-2.32.html
+share/doc/libedataserverui/api-index-deprecated.html
share/doc/libedataserverui/api-index-full.html
share/doc/libedataserverui/ch01.html
share/doc/libedataserverui/home.png
@@ -705,7 +682,6 @@ share/doc/libedataserverui/left.png
share/doc/libedataserverui/libedataserverui-ECategoryCompletion.html
share/doc/libedataserverui/libedataserverui-ECellRendererColor.html
share/doc/libedataserverui/libedataserverui-e-book-auth-util.html
-share/doc/libedataserverui/libedataserverui-e-data-server-ui-marshal.html
share/doc/libedataserverui/libedataserverui-e-passwords.html
share/doc/libedataserverui/libedataserverui.devhelp
share/doc/libedataserverui/libedataserverui.devhelp2
@@ -839,9 +815,6 @@ share/pixmaps/evolution-data-server/category_time-and-expenses_16.png
@dirrm include/evolution-data-server-%%VERSION%%/libebook
@dirrm include/evolution-data-server-%%VERSION%%/libebackend
@dirrm include/evolution-data-server-%%VERSION%%/groupwise
-@dirrm include/evolution-data-server-%%VERSION%%/google/libgdata-google
-@dirrm include/evolution-data-server-%%VERSION%%/google/libgdata
-@dirrm include/evolution-data-server-%%VERSION%%/google
@dirrm include/evolution-data-server-%%VERSION%%/camel
@dirrm include/evolution-data-server-%%VERSION%%
@dirrmtry share/locale/zh_HK/LC_MESSAGES