aboutsummaryrefslogtreecommitdiff
path: root/databases/fastdb
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2013-06-28 01:58:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2013-06-28 01:58:35 +0000
commit7cec717c1936024c29287fc9a5d746ce18f4895a (patch)
tree0b275f11b01e955210b9289e5b161bc9dcdc6f98 /databases/fastdb
parent09415ca5154c4df3aa0f87ae7989bb13aff35b75 (diff)
downloadports-7cec717c1936024c29287fc9a5d746ce18f4895a.tar.gz
ports-7cec717c1936024c29287fc9a5d746ce18f4895a.zip
Notes
Diffstat (limited to 'databases/fastdb')
-rw-r--r--databases/fastdb/Makefile14
-rw-r--r--databases/fastdb/distinfo4
-rw-r--r--databases/fastdb/files/patch-makefile12
3 files changed, 11 insertions, 19 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 8a780701abbd..340bae3397f2 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -1,13 +1,8 @@
-# ex:ts=8
-# New ports collection makefile for: fastdb
-# Date created: Mar 2, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fastdb
-PORTVERSION= 3.70
+PORTVERSION= 3.73
CATEGORIES= databases
MASTER_SITES= SF
@@ -22,15 +17,12 @@ MAKE_ENV= OSTYPE="${OPSYS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= makefile
USE_LDCONFIG= yes
+USE_DOS2UNIX= ${MAKEFILE}
PORTDOCS= FastDB.htm
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-BROKEN= does not compile
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/databases/fastdb/distinfo b/databases/fastdb/distinfo
index 73fad53f8713..a8f07887c00a 100644
--- a/databases/fastdb/distinfo
+++ b/databases/fastdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fastdb-3.70.tar.gz) = 0fda8b01ab47e415d0db750f2701bd22da5a4dde1ac1a72be83b3116bb1e8792
-SIZE (fastdb-3.70.tar.gz) = 1633823
+SHA256 (fastdb-3.73.tar.gz) = d3483c65393ffa7a49efb27c0ad009c7637dadf7888fee47064bd1e719150656
+SIZE (fastdb-3.73.tar.gz) = 3279291
diff --git a/databases/fastdb/files/patch-makefile b/databases/fastdb/files/patch-makefile
index 4d48060557ff..b24adb927a6e 100644
--- a/databases/fastdb/files/patch-makefile
+++ b/databases/fastdb/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig 2009-12-15 00:07:00.000000000 +0800
-+++ makefile 2010-08-16 13:53:31.000000000 +0800
+--- makefile.orig 2012-09-12 03:22:51.000000000 +0800
++++ makefile 2013-06-28 09:55:32.000000000 +0800
@@ -38,8 +38,8 @@
THRLIBS=
SUFF=
@@ -19,7 +19,7 @@
+CC = ${CXX}
# DEFS macro is deprecatred, edit config.h file instead
- DEFS = -Wno-invalid-offsetof
+ DEFS = -Wno-invalid-offsetof -Wno-write-strings
ifeq ($(DEBUG), 1)
-CFLAGS = -c -Iinc -Wall -O0 -g -fPIC $(DEFS) $(TFLAGS)
@@ -40,7 +40,7 @@
AR = ar
ARFLAGS = -cru
-@@ -433,16 +433,15 @@
+@@ -439,16 +439,15 @@
install: subsql cleanupsem inspectsem installlib
mkdir -p $(BINSPATH)
@@ -58,11 +58,11 @@
+ ${BSD_INSTALL_DATA} $(INCS) $(INCSPATH)
mkdir -p $(LIBSPATH)
- cp $(FASTDB_LIB) $(CLI_LIB) $(FASTDB_SHARED) $(CLI_SHARED) $(LIBSPATH)
-+ ${BSD_INSTALL_PROGRAM} $(FASTDB_LIB) $(CLI_LIB) $(FASTDB_SHARED) $(CLI_SHARED) $(LIBSPATH)
++ ${BSD_INSTALL_DATA} $(FASTDB_LIB) $(CLI_LIB) $(FASTDB_SHARED) $(CLI_SHARED) $(LIBSPATH)
(cd $(LIBSPATH) && ln -f -s $(FASTDB_SHARED) libfastdb$(SUFF).so \
&& ln -f -s $(CLI_SHARED) libcli$(SUFF).so)
if [ -f $(JNI_LIB) ]; then cp $(JNI_LIB) $(LIBSPATH); \
-@@ -450,7 +449,7 @@
+@@ -456,7 +455,7 @@
uninstall:
rm -fr $(INCSPATH)