aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird-client/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-17 16:02:37 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-17 16:02:37 +0000
commit2c50aa03a973fd9d8739cfae36e421706a0ac592 (patch)
tree68f55f78d32700dd675036e8242cc50837cdbff0 /databases/firebird-client/Makefile
parent63305e301c6efa0b7b9edddbcf0436920739b615 (diff)
downloadports-2c50aa03a973fd9d8739cfae36e421706a0ac592.tar.gz
ports-2c50aa03a973fd9d8739cfae36e421706a0ac592.zip
Notes
Diffstat (limited to 'databases/firebird-client/Makefile')
-rw-r--r--databases/firebird-client/Makefile81
1 files changed, 9 insertions, 72 deletions
diff --git a/databases/firebird-client/Makefile b/databases/firebird-client/Makefile
index 37c91e1cdc08..8e3dbe715a05 100644
--- a/databases/firebird-client/Makefile
+++ b/databases/firebird-client/Makefile
@@ -1,82 +1,19 @@
-# New ports collection makefile for: Firebird
-# Date created: 20 December 2000
-# Whom: Geoffrey C. Speicher <geoff@sea-incorporated.com>
+# New ports collection makefile for: firebird-client
+# Date created: 2005 Mar 03
+# Whom: Renato Botelho <renato@galle.com.br>
#
# $FreeBSD$
#
PORTNAME= firebird
-PORTVERSION= 1.5.2
-CATEGORIES= databases
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=firebird
-DISTNAME= firebird-1.5.2.4731
+PKGNAMESUFFIX= -client
-MAINTAINER= freebsd@galle.com.br
-COMMENT= The open-source InterBase(tm) 6.0 spin-off (Classic version)
+COMMENT= The open-source InterBase(tm) 6.0 spin-off (client)
-USE_BISON= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
-USE_AUTOCONF_VER= 259
-USE_GCC= 3.4
+MASTERDIR= ${.CURDIR}/../firebird-server
-PLIST_SUB= FIREBIRD_VERSION=${PORTVERSION}
+PLIST= ${PKGDIR}/pkg-plist.client
-# Don't use ld for linking, use gcc
-LD= gcc
+CLIENT_ONLY= yes
-CONFLICTS= firebird-devel-[0-9]*
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/firebird/lib
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-USE_REINPLACE= yes
-
-ONLY_FOR_ARCHS= i386
-
-.include <bsd.port.pre.mk>
-
-pre-everything::
- @${ECHO_MSG} "NOTE: If the work directory is on an NFS mount, you will"
- @${ECHO_MSG} "require NFS client locking support for the build to"
- @${ECHO_MSG} "succeed. Currently this is only available on FreeBSD 5.0"
- @${ECHO_MSG} "or greater."
- @${ECHO_MSG}
- @${ECHO_MSG} "WARNING: The on-disk structure of the databases has"
- @${ECHO_MSG} "changed since version 1.0.x."
- @${ECHO_MSG} "Cancel this installation now and backup your databases"
- @${ECHO_MSG} "if you have not already done so."
-.if !defined(BATCH)
- @sleep 10
-.endif
-
-patch-autotools:
- @${DO_NADA}
-
-run-autotools:
- @${DO_NADA}
-
-do-configure:
- @(cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} MAKE=${GMAKE} \
- ${AUTOTOOLS_VARS} ./autogen.sh --prefix=${PREFIX}/firebird \
- --with-lock-manager --with-editline)
-
-do-build:
- @( \
- ${SED} 's|%%PREFIX%%|${PREFIX}|g' ${MSG_FILE} > ${PKGMESSAGE}; \
- cd ${WRKSRC}; \
- ${SETENV} CC=${CC} CXX=${CXX} ${GMAKE} all; \
- )
-
-post-install:
- @( \
- ${INSTALL_DATA} ${FILESDIR}/RELNOTES ${PREFIX}/firebird; \
- ${CAT} ${PKGMESSAGE}; \
- )
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"