aboutsummaryrefslogtreecommitdiff
path: root/databases/flamerobin
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-04-04 16:37:29 +0000
committerRene Ladan <rene@FreeBSD.org>2019-04-04 16:37:29 +0000
commitcc5fe2dd620082c6185b6968505daa180908270f (patch)
tree4cee0f81cfd6da29fc9cf44ab5caf8f38bcb7006 /databases/flamerobin
parent94667a5ac650f84230ad89c0926d95d39bdf63ac (diff)
downloadports-cc5fe2dd620082c6185b6968505daa180908270f.tar.gz
ports-cc5fe2dd620082c6185b6968505daa180908270f.zip
Notes
Diffstat (limited to 'databases/flamerobin')
-rw-r--r--databases/flamerobin/Makefile38
-rw-r--r--databases/flamerobin/distinfo2
-rw-r--r--databases/flamerobin/files/patch-clang-git-03e89f337
-rw-r--r--databases/flamerobin/files/patch-configure18
-rw-r--r--databases/flamerobin/files/pkg-message.in9
-rw-r--r--databases/flamerobin/pkg-descr4
-rw-r--r--databases/flamerobin/pkg-plist40
7 files changed, 0 insertions, 448 deletions
diff --git a/databases/flamerobin/Makefile b/databases/flamerobin/Makefile
deleted file mode 100644
index 0b29599f9f0d..000000000000
--- a/databases/flamerobin/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# Created by: dindin
-# $FreeBSD$
-
-PORTNAME= flamerobin
-PORTVERSION= 0.9.2
-PORTREVISION= 6
-CATEGORIES= databases
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GUI administration tool for firebird database
-
-DEPRECATED= Abandonware since 2009, does not work with newer version of wxGTK
-EXPIRATION_DATE= 2019-03-24
-
-LICENSE= expat
-LICENSE_NAME= FlameRobin Expat
-LICENSE_FILE= ${WRKSRC}/docs/fr_license.html
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-
-USES= compiler firebird
-GNU_CONFIGURE= yes
-USE_WX= 2.8
-WX_COMPS= wx contrib
-WX_CONF_ARGS= absolute
-WX_PREMK= yes
-
-SUB_FILES= pkg-message
-
-.include <bsd.port.pre.mk>
-
-# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
-.if ${COMPILER_TYPE} == gcc
-CONFIGURE_ARGS= --disable-precomp-headers
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/databases/flamerobin/distinfo b/databases/flamerobin/distinfo
deleted file mode 100644
index 490a6a0b2cf4..000000000000
--- a/databases/flamerobin/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (flamerobin-0.9.2-src.tar.gz) = b674a1de1c632c834e904a17e576498850e7b81cc5c4d42e8cafd8a6dd020c90
-SIZE (flamerobin-0.9.2-src.tar.gz) = 901908
diff --git a/databases/flamerobin/files/patch-clang-git-03e89f b/databases/flamerobin/files/patch-clang-git-03e89f
deleted file mode 100644
index 82af967e254c..000000000000
--- a/databases/flamerobin/files/patch-clang-git-03e89f
+++ /dev/null
@@ -1,337 +0,0 @@
---- src/gui/controls/DBHTreeControl.cpp
-+++ src/gui/controls/DBHTreeControl.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -261,6 +261,8 @@
- id = ART_View; break;
- case ntViews:
- id = ART_Views; break;
-+ default:
-+ break;
- }
- return getImageIndex(id);
- }
---- src/gui/CreateIndexDialog.cpp
-+++ src/gui/CreateIndexDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -209,6 +209,7 @@
- class TableIndicesHandler: public URIHandler
- {
- public:
-+ TableIndicesHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/gui/ExecuteSqlFrame.cpp
-+++ src/gui/ExecuteSqlFrame.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -2749,6 +2749,7 @@
- class DropColumnHandler: public URIHandler
- {
- public:
-+ DropColumnHandler() {};
- bool handleURI(URI& uri);
- private:
- static const DropColumnHandler handlerInstance;
-@@ -2806,6 +2807,7 @@
- class DropColumnsHandler: public URIHandler
- {
- public:
-+ DropColumnsHandler() {};
- bool handleURI(URI& uri);
- private:
- static const DropColumnsHandler handlerInstance;
-@@ -2842,6 +2844,7 @@
- class DropObjectHandler: public URIHandler
- {
- public:
-+ DropObjectHandler() {};
- bool handleURI(URI& uri);
- private:
- static const DropObjectHandler handlerInstance;
-@@ -2878,6 +2881,7 @@
- class EditDDLHandler: public URIHandler
- {
- public:
-+ EditDDLHandler() {};
- bool handleURI(URI& uri);
- private:
- static const EditDDLHandler handlerInstance;
-@@ -2919,6 +2923,7 @@
- class EditProcedureHandler: public URIHandler
- {
- public:
-+ EditProcedureHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -2947,6 +2952,7 @@
- class AlterViewHandler: public URIHandler
- {
- public:
-+ AlterViewHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -2973,6 +2979,7 @@
- class EditTriggerHandler: public URIHandler
- {
- public:
-+ EditTriggerHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -2999,6 +3006,7 @@
- class EditGeneratorValueHandler: public URIHandler
- {
- public:
-+ EditGeneratorValueHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -3041,6 +3049,7 @@
- class EditExceptionHandler: public URIHandler
- {
- public:
-+ EditExceptionHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -3067,6 +3076,7 @@
- class IndexActionHandler: public URIHandler
- {
- public:
-+ IndexActionHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -3113,6 +3123,7 @@
- class ActivateTriggersHandler: public URIHandler
- {
- public:
-+ ActivateTriggersHandler() {};
- bool handleURI(URI& uri);
- private:
- static const ActivateTriggersHandler handlerInstance;
-@@ -3160,6 +3171,7 @@
- class ActivateTriggerHandler: public URIHandler
- {
- public:
-+ ActivateTriggerHandler() {};
- bool handleURI(URI& uri);
- private:
- static const ActivateTriggerHandler handlerInstance;
---- src/gui/FieldPropertiesDialog.cpp
-+++ src/gui/FieldPropertiesDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -816,6 +816,7 @@
- class ColumnPropertiesHandler: public URIHandler
- {
- public:
-+ ColumnPropertiesHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/gui/MetadataItemPropertiesFrame.cpp
-+++ src/gui/MetadataItemPropertiesFrame.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -360,6 +360,8 @@
- case ntDatabase:
- case ntRole:
- pages.push_back(wxT("DDL"));
-+ default:
-+ break;
- };
- wxString page = loadEntireFile(config().getHtmlTemplatesPath()
- + wxT("header.html"));
-@@ -1290,6 +1292,7 @@
- class PageHandler: public URIHandler
- {
- public:
-+ PageHandler() {};
- bool handleURI(URI& uri);
- private:
- static const PageHandler handlerInstance; // singleton; registers itself on creation.
-@@ -1327,6 +1330,7 @@
- class PropertiesHandler: public URIHandler
- {
- public:
-+ PropertiesHandler() {};
- bool handleURI(URI& uri);
- private:
- static const PropertiesHandler handlerInstance; // singleton; registers itself on creation.
---- src/gui/PrivilegesDialog.cpp
-+++ src/gui/PrivilegesDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -583,6 +583,7 @@
- class ManagePrivilegesHandler: public URIHandler
- {
- public:
-+ ManagePrivilegesHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/gui/ReorderFieldsDialog.cpp
-+++ src/gui/ReorderFieldsDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -215,6 +215,7 @@
- class ReorderFieldsHandler: public URIHandler
- {
- public:
-+ ReorderFieldsHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/gui/TriggerWizardDialog.cpp
-+++ src/gui/TriggerWizardDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -178,6 +178,7 @@
- class CreateTriggerHandler: public URIHandler
- {
- public:
-+ CreateTriggerHandler() {};
- bool handleURI(URI& uri);
- private:
- static const CreateTriggerHandler handlerInstance;
---- src/gui/UserDialog.cpp
-+++ src/gui/UserDialog.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -222,6 +222,7 @@
- class UserPropertiesHandler: public URIHandler
- {
- public:
-+ UserPropertiesHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
-@@ -300,6 +301,7 @@
- class DropUserHandler: public URIHandler
- {
- public:
-+ DropUserHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/addconstrainthandler.cpp
-+++ src/addconstrainthandler.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -51,6 +51,8 @@
- class AddConstraintHandler: public URIHandler
- {
- public:
-+ AddConstraintHandler() {};
-+
- bool handleURI(URI& uri);
- private:
- static const AddConstraintHandler handlerInstance; // singleton; registers itself on creation.
---- src/databasehandler.cpp
-+++ src/databasehandler.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -46,6 +46,7 @@
- class DatabaseInfoHandler: public URIHandler
- {
- public:
-+ DatabaseInfoHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
---- src/images.cpp
-+++ src/images.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -68,6 +68,8 @@
- return wxArtProvider::GetIcon(ART_Trigger, wxART_OTHER, sz);
- case ntView:
- return wxArtProvider::GetIcon(ART_View, wxART_OTHER, sz);
-+ default:
-+ break;
- }
- return wxArtProvider::GetIcon(ART_FlameRobin, wxART_OTHER, sz);
- }
---- src/objectdescriptionhandler.cpp
-+++ src/objectdescriptionhandler.cpp
-@@ -1,5 +1,5 @@
- /*
-- Copyright (c) 2004-2009 The FlameRobin Development Team
-+ Copyright (c) 2004-2011 The FlameRobin Development Team
-
- Permission is hereby granted, free of charge, to any person obtaining
- a copy of this software and associated documentation files (the
-@@ -46,6 +46,7 @@
- class ObjectDescriptionHandler: public URIHandler
- {
- public:
-+ ObjectDescriptionHandler() {};
- bool handleURI(URI& uri);
- private:
- // singleton; registers itself on creation.
diff --git a/databases/flamerobin/files/patch-configure b/databases/flamerobin/files/patch-configure
deleted file mode 100644
index 3eb574c21e61..000000000000
--- a/databases/flamerobin/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig 2008-10-22 09:36:24.000000000 +0000
-+++ configure
-@@ -7361,6 +7361,7 @@ EOF
- ;;
-
- powerpc-apple-macos* | \
-+ *-*-dragonfly* | \
- *-*-freebsd* | *-*-openbsd* | *-*-netbsd* | *-*-k*bsd*-gnu | \
- *-*-mirbsd* | \
- *-*-sunos4* | \
-@@ -7404,6 +7405,7 @@ echo "$as_me: error: unknown system type
- SONAME_FLAG=
-
- case "${BAKEFILE_HOST}" in
-+ *-*-dragonfly | \
- *-*-linux* | *-*-freebsd* | *-*-openbsd* | *-*-netbsd* | \
- *-*-k*bsd*-gnu | *-*-mirbsd* )
- if test "x$SUNCXX" = "xyes"; then
diff --git a/databases/flamerobin/files/pkg-message.in b/databases/flamerobin/files/pkg-message.in
deleted file mode 100644
index 95198980a4c8..000000000000
--- a/databases/flamerobin/files/pkg-message.in
+++ /dev/null
@@ -1,9 +0,0 @@
-###############################################################################
-
-FlameRobin was installed
-
-For additonal documentation read manpage flamerobin(1) and docs in
-%%PREFIX%%/share/flamerobin/docs/ . Also you can view same docs from
-flamerobin's help menu.
-
-###############################################################################
diff --git a/databases/flamerobin/pkg-descr b/databases/flamerobin/pkg-descr
deleted file mode 100644
index 137cc118c25e..000000000000
--- a/databases/flamerobin/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Nice and very useful firebird database administration
-tool with many features.
-
-WWW: http://www.flamerobin.org/
diff --git a/databases/flamerobin/pkg-plist b/databases/flamerobin/pkg-plist
deleted file mode 100644
index 68cf2cd4070b..000000000000
--- a/databases/flamerobin/pkg-plist
+++ /dev/null
@@ -1,40 +0,0 @@
-bin/flamerobin
-man/man1/flamerobin.1.gz
-%%DATADIR%%/conf-defs/db_settings.confdef
-%%DATADIR%%/conf-defs/fr_settings.confdef
-%%DATADIR%%/docs/fr_license.html
-%%DATADIR%%/docs/fr_manual.html
-%%DATADIR%%/docs/fr_whatsnew.html
-%%DATADIR%%/docs/html.css
-%%DATADIR%%/html-templates/ALLloading.html
-%%DATADIR%%/html-templates/DATABASE.html
-%%DATADIR%%/html-templates/DATABASEtriggers.html
-%%DATADIR%%/html-templates/DDL.html
-%%DATADIR%%/html-templates/DOMAIN.html
-%%DATADIR%%/html-templates/EXCEPTION.html
-%%DATADIR%%/html-templates/FUNCTION.html
-%%DATADIR%%/html-templates/GENERATOR.html
-%%DATADIR%%/html-templates/PROCEDURE.html
-%%DATADIR%%/html-templates/PROCEDUREprivileges.html
-%%DATADIR%%/html-templates/ROLE.html
-%%DATADIR%%/html-templates/ROLEprivileges.html
-%%DATADIR%%/html-templates/SERVER.html
-%%DATADIR%%/html-templates/TABLE.html
-%%DATADIR%%/html-templates/TABLEconstraints.html
-%%DATADIR%%/html-templates/TABLEindices.html
-%%DATADIR%%/html-templates/TABLEprivileges.html
-%%DATADIR%%/html-templates/TABLEtriggers.html
-%%DATADIR%%/html-templates/TRIGGER.html
-%%DATADIR%%/html-templates/VIEW.html
-%%DATADIR%%/html-templates/VIEWprivileges.html
-%%DATADIR%%/html-templates/VIEWtriggers.html
-%%DATADIR%%/html-templates/compute.png
-%%DATADIR%%/html-templates/dependencies.html
-%%DATADIR%%/html-templates/drop.png
-%%DATADIR%%/html-templates/header.html
-%%DATADIR%%/html-templates/ok.png
-%%DATADIR%%/html-templates/ok2.png
-%%DATADIR%%/html-templates/redx.png
-%%DATADIR%%/html-templates/view.png
-share/applications/flamerobin.desktop
-share/pixmaps/flamerobin.png