aboutsummaryrefslogtreecommitdiff
path: root/databases/fpc-oracle
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-06-21 16:52:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-06-21 16:52:57 +0000
commitb06153abd6cff3313971e58ae665e96b0bf447bf (patch)
treed671f1e410fe2766e67c77bc1573fd986720b550 /databases/fpc-oracle
parentacca2dab6cf8bdfcdf61189c830d87fae34e8118 (diff)
downloadports-b06153abd6cff3313971e58ae665e96b0bf447bf.tar.gz
ports-b06153abd6cff3313971e58ae665e96b0bf447bf.zip
Notes
Diffstat (limited to 'databases/fpc-oracle')
-rw-r--r--databases/fpc-oracle/Makefile68
-rw-r--r--databases/fpc-oracle/distinfo3
-rw-r--r--databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc10
-rw-r--r--databases/fpc-oracle/pkg-descr8
-rw-r--r--databases/fpc-oracle/pkg-plist3
5 files changed, 7 insertions, 85 deletions
diff --git a/databases/fpc-oracle/Makefile b/databases/fpc-oracle/Makefile
index 11ab8768a07d..afab56fc3a54 100644
--- a/databases/fpc-oracle/Makefile
+++ b/databases/fpc-oracle/Makefile
@@ -5,70 +5,16 @@
# $FreeBSD$
#
-PORTNAME= oracle
-PORTVERSION= 1.0.10
CATEGORIES= databases lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= freepascal
-PKGNAMEPREFIX= fpc-
-DISTNAME= fpc-${PORTVERSION}.ELF
-EXTRACT_SUFX= .tar
+PKGNAMESUFFIX= -oracle
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acardenas@bsd.org.pe
COMMENT= Free Pascal interface to Oracle
-.include <bsd.port.pre.mk>
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ ${ORACLE8_LIB}/env_rdbms.mk:${PORTSDIR}/databases/oracle8-client
-ORACLE7_LIB= ${LOCALBASE}/oracle7/rdbms/lib
-BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- ${ORACLE7_LIB}/libnlsrtl3.a:${PORTSDIR}/databases/oracle7-client
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-.if ${OSVERSION} < 470000
-EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
-TAR= ${LOCALBASE}/bin/gtar
-.endif
-USE_GMAKE= yes
-ONLY_FOR_ARCHS= i386
+ORACLE8_LIB= ${LOCALBASE}/oracle8-client/rdbms/lib
+MASTERDIR= ${.CURDIR}/../../lang/fpc
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-
-MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
- FPC=${LOCALBASE}/bin/ppc386 \
- INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
- INSTALL_BINDIR=${PREFIX}/bin \
- GCCLIBDIR=/usr/lib \
- RELEASE=1
-
-do-extract:
-# unpack distribution
- @${MKDIR} ${WRKSRC}
- @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
-# unpack sources distribution
- @${MKDIR} ${WRKSRC}/sources
- @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
-# further extract base sources
-#
-# postgres sources
- @${TAR} zxf ${WRKSRC}/sources/unitsoraclesrc.tar.gz \
- --directory ${WRKSRC}
-
-post-patch:
-# change to alter amount of optimization
- @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
- "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
-
- ${REINPLACE_CMD} 's|/usr/local/oracle8cli/lib|${ORACLE7_LIB}|g' \
- ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle/Makefile.fpc
-
-do-build:
- cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle && \
- ${GMAKE} ${MAKE_ENV} all
-
-do-install:
- cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle && \
- ${GMAKE} ${MAKE_ENV} install
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/fpc-oracle/distinfo b/databases/fpc-oracle/distinfo
deleted file mode 100644
index fb00975ada0c..000000000000
--- a/databases/fpc-oracle/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
-SHA256 (fpc-1.0.10.ELF.tar) = 318bab9d1269dffcc5fe737d224fca939c5f130f34f12d166319b3d1ba776bfb
-SIZE (fpc-1.0.10.ELF.tar) = 17448960
diff --git a/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc b/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc
deleted file mode 100644
index a2913d74f42f..000000000000
--- a/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc
+++ /dev/null
@@ -1,10 +0,0 @@
---- share/src/fpc-1.0.10/packages/base/oracle/Makefile.fpc.bak Sun Apr 6 07:44:46 2003
-+++ share/src/fpc-1.0.10/packages/base/oracle/Makefile.fpc Thu Jan 8 22:16:08 2004
-@@ -21,5 +21,5 @@
-
- # in libdir variable must be path to libraries
- # libclntsh.*,libnlsrtl3.*
--#[compiler]
--#libdir=/usr/local/oracle8cli/lib
-+[compiler]
-+libdir=/usr/local/oracle8cli/lib
diff --git a/databases/fpc-oracle/pkg-descr b/databases/fpc-oracle/pkg-descr
deleted file mode 100644
index b2339e674843..000000000000
--- a/databases/fpc-oracle/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Oracle is part of the base packages of Free Pascal, a 32-bit
-Turbo Pascal/Delphi compatible compiler. Oracle provides an
-interface to Oracle databases.
-
-WWW: http://www.freepascal.org/
-
---
-John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/databases/fpc-oracle/pkg-plist b/databases/fpc-oracle/pkg-plist
deleted file mode 100644
index 5f3c88c894d2..000000000000
--- a/databases/fpc-oracle/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-lib/fpc/%%PORTVERSION%%/units/freebsd/oracle/Package.fpc
-lib/fpc/%%PORTVERSION%%/units/freebsd/oracle/oraoci.ppu
-@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/oracle