aboutsummaryrefslogtreecommitdiff
path: root/databases/fpc-postgres
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 01:04:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 01:04:40 +0000
commit6ca3f3b90c8206e75044115fd3936ee91a1a1fd8 (patch)
treef5e0b9391043274da3a0631c3dc59e3311458a0d /databases/fpc-postgres
parent2717e46c960589233a78eb87bb92f44a09fefae0 (diff)
downloadports-6ca3f3b90c8206e75044115fd3936ee91a1a1fd8.tar.gz
ports-6ca3f3b90c8206e75044115fd3936ee91a1a1fd8.zip
Notes
Diffstat (limited to 'databases/fpc-postgres')
-rw-r--r--databases/fpc-postgres/Makefile77
-rw-r--r--databases/fpc-postgres/distinfo1
-rw-r--r--databases/fpc-postgres/pkg-descr8
-rw-r--r--databases/fpc-postgres/pkg-plist6
4 files changed, 92 insertions, 0 deletions
diff --git a/databases/fpc-postgres/Makefile b/databases/fpc-postgres/Makefile
new file mode 100644
index 000000000000..c77df44c8c0c
--- /dev/null
+++ b/databases/fpc-postgres/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 28 November 2001
+# Whom: John Merryweather Cooper et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgres
+PORTVERSION= 1.0.10
+CATEGORIES= databases
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal interface to PostGreSQL
+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql72
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# postgres sources
+ @${TAR} zxf ${WRKSRC}/sources/unitspostgressrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/postgres && \
+ ${GMAKE} ${MAKE_ENV} all
+
+do-install:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/postgres && \
+ ${GMAKE} ${MAKE_ENV} install
+
+.include <bsd.port.post.mk>
diff --git a/databases/fpc-postgres/distinfo b/databases/fpc-postgres/distinfo
new file mode 100644
index 000000000000..cdc32c64a7d3
--- /dev/null
+++ b/databases/fpc-postgres/distinfo
@@ -0,0 +1 @@
+MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
diff --git a/databases/fpc-postgres/pkg-descr b/databases/fpc-postgres/pkg-descr
new file mode 100644
index 000000000000..a3d5e3e7fd2d
--- /dev/null
+++ b/databases/fpc-postgres/pkg-descr
@@ -0,0 +1,8 @@
+Postgres is part of the base packages of Free Pascal, a 32-bit
+Turbo Pascal/Delphi compatible compiler. Postgres provides an
+interface to PostGreSQL.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/databases/fpc-postgres/pkg-plist b/databases/fpc-postgres/pkg-plist
new file mode 100644
index 000000000000..2ee576a195d6
--- /dev/null
+++ b/databases/fpc-postgres/pkg-plist
@@ -0,0 +1,6 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/postgres/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/postgres/dllist.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/postgres/dllist.ppu
+lib/fpc/%%PORTVERSION%%/units/freebsd/postgres/postgres.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/postgres/postgres.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/postgres