aboutsummaryrefslogtreecommitdiff
path: root/databases/freetds/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-09-25 23:02:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-09-25 23:02:28 +0000
commit0e791fb6555a66bb44f9b77032156b0556fe523f (patch)
treee2b12c4602cfa4066aa792bc6e12504dfdf6358d /databases/freetds/Makefile
parent6931e94f43fdf49c999a2c571dc0e3e64193aaee (diff)
downloadports-0e791fb6555a66bb44f9b77032156b0556fe523f.tar.gz
ports-0e791fb6555a66bb44f9b77032156b0556fe523f.zip
Diffstat (limited to 'databases/freetds/Makefile')
-rw-r--r--databases/freetds/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 9fad2460c26c..6053db9202a5 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -1,7 +1,7 @@
# Created by: Domas Mituzas <midom@dammit.lt>
PORTNAME= freetds
-PORTVERSION= 1.2.21
+PORTVERSION= 1.3.3
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= https://www.freetds.org/files/stable/ \
@@ -60,11 +60,12 @@ post-extract:
@cd ${WRKSRC}/src/pool && ${LN} -s pool.conf pool.conf.sample
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.am" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|/freetds.conf|/freetds.conf.sample|g ; \
+ @${REINPLACE_CMD} -e 's|/freetds.conf|/freetds.conf.sample|g ; \
s|/locales.conf|/locales.conf.sample|g ; \
- s|/pool.conf|/pool.conf.sample|g ; \
- s| common.h||g'
+ s| common.h||g' \
+ ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's|/pool.conf|/pool.conf.sample|g' \
+ ${WRKSRC}/src/pool/Makefile.am
@${REINPLACE_CMD} -e 's|\($$with_iodbc/include\)|\1/libiodbc|g' \
${WRKSRC}/configure.ac