aboutsummaryrefslogtreecommitdiff
path: root/databases/freetds/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-09 11:47:59 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-09 11:47:59 +0000
commit3abab89bf0a5371ad5c54b3a40e4f5fd9c28cb4d (patch)
tree6ce2603e96f7dc8065282e6d2b60fef97ab57880 /databases/freetds/Makefile
parent4f413291cdd6484be846cf16a7b0d21a2d241a96 (diff)
downloadports-3abab89bf0a5371ad5c54b3a40e4f5fd9c28cb4d.tar.gz
ports-3abab89bf0a5371ad5c54b3a40e4f5fd9c28cb4d.zip
Notes
Diffstat (limited to 'databases/freetds/Makefile')
-rw-r--r--databases/freetds/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index df63d1736e08..766e5f8ffb33 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= freetds
-PORTVERSION= 0.91.112.0.0
+PORTVERSION= 0.95.0
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ftp://ftp.freetds.org/pub/freetds/stable/
@@ -14,14 +14,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
-PORTSCOUT= skipv:0.92.48,0.92.49,0.92.51,0.92.52,0.92.53,0.92.54,0.92.55,0.92.59,0.92.63,0.92.79,0.92.405
TDS_VER?= 5.0
-USES= autoreconf iconv gmake pkgconfig libtool:keepla tar:bzip2
+USES= autoreconf iconv gmake libtool:keepla pkgconfig readline tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-LIBS+= -lgcrypt
+LIBS+= -lgcrypt -lpthread
CONFIGURE_ARGS= --with-tdsver=${TDS_VER} --sysconfdir=${ETCDIR} \
--enable-sybase-compat --enable-msdblib
USE_LDCONFIG= yes
@@ -70,10 +69,5 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/interfaces ${STAGEDIR}${ETCDIR}/interfaces.sample
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/doc/doc/${PORTNAME}-${PORTVERSION} && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.endif
.include <bsd.port.mk>