aboutsummaryrefslogtreecommitdiff
path: root/databases/gdbm/Makefile
diff options
context:
space:
mode:
authorYaroslav Tykhiy <ytykhiy@gmail.com>2003-01-22 17:01:13 +0000
committerYaroslav Tykhiy <ytykhiy@gmail.com>2003-01-22 17:01:13 +0000
commit7cca481c2d66b1ddf30e2ba1af78e2453acd7b26 (patch)
tree581fe27eef160678fd9906cbdaf767f7f560dd49 /databases/gdbm/Makefile
parent3faeefebded3faa5c326a48ec4799ee7339a80a8 (diff)
Add an option, WITH_COMPAT, to install the UNIX dbm/ndbm
compatibility files--libgdbm_compat and the header files. PR: ports/47363 Approved by: Cyrille Lefevre <cyrille.lefevre@laposte.net> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=73802
Diffstat (limited to 'databases/gdbm/Makefile')
-rw-r--r--databases/gdbm/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index f9b4a927c2d9..aa67f0969e09 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -17,11 +17,25 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+.if defined(WITH_COMPAT) && ${WITH_COMPAT:L} != no
+INSTALL_TARGET= install install-compat
+PLIST_SUB= GDBM_COMPAT=""
+.else
+PLIST_SUB= GDBM_COMPAT="@comment "
+.endif
MAN3= gdbm.3
INSTALL_INFO?= install-info
+pre-everything::
+.if !defined(WITH_COMPAT)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you need UNIX dbm/ndbm compatibility functions,"
+ @${ECHO_MSG} "use \"make WITH_COMPAT=yes\""
+ @${ECHO_MSG}
+.endif
+
post-install:
@${INSTALL_INFO} ${PREFIX}/info/${PORTNAME}.info ${PREFIX}/info/dir